Slow installation/freezes at "Completing Installation"

Discussion in 'Windows 7 Installation' started by Calath, Oct 30, 2009.

  1. Calath

    Calath New Member

    Joined:
    May 13, 2009
    Messages:
    22
    Likes Received:
    0
    Hello guys. I just got my Windows 7 copy from Amazon and happily proceeded to perform a clean install. Happily my ass. Anyway, everything went fine, I formated my hard drive and hit the install button. Extracting and all that went fine, at one point it required a reboot and did so. After the reboot it started working on the "Completing Installation"-step, and it's been doing that since. (For two-three hours now.) The dots are still moving, but it seems as if they're lagging, as if the computer freezes for ten seconds then work for a few, and freezes again. It's like one dot > ten seconds > two dots > three > 10 seconds > one dot > 10 seconds > two > three. (Also at this point, if I move my mouse, the cursor won't move, and suddenly "jump" to a spot on the screen during the "unfreeze"-period.)

    I'm gonna keep waiting as it seems if the installation is moving albeit -very- slow, but this is somewhat annoying. No wait, disregard that, it's incredibly annoying. It's a Home-version ordered from Amazon.co.uk and the DVD looks just fine. I've installed Vista on my computer numerous of times with no issues at all. Some quick computer specs.

    Corsair Powersupply 550W Bulk
    Asus P5N-D nForce750i SLI
    XFX GeForce 9800GTX 512mb
    Corsair TWIN2X 6400 DDR2, 4096MB
    WD Caviar GP 500GB SATA2
    Intel Core 2 Duo E8400 3.0GHz (do note that this one is OCed to 3.6)

    I'm trying to install the 64-bit version of Windows 7. I'm pretty certain that all of my computer hardware should be compatible with 64-bit, but I might be wrong. I've also pretty much concluded with the fact that the 9-series of nVidia is causing a lot of problems.

    I'll come back to you with additional information later today. Gonna let it work for a couple of hours more, but I'm already considering reinstalling my old 32 bit Vista. And here I was looking forward to getting my Windows 7..
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    The overclocking might hurt, so perhaps slow it down during the install.
     
  3. Calath

    Calath New Member

    Joined:
    May 13, 2009
    Messages:
    22
    Likes Received:
    0
    Hrm, might do that. I got another thing to add though.

    During installation, at the point when it comes to the Completing Installation step, the computer froze for a couple of seconds and the resolution went from normal 800x600 to a full 1900x1200 which is the resolution I normally use. Which makes me think that maybe the installation might be trying to somehow install new drivers for my videocard, which I also have had a ton of problems with. No drivers past the driver released with Age of Conan in May last year (177 as far as I recall) have worked on my computer.

    Can this have something to do with the problem?
     
  4. Calath

    Calath New Member

    Joined:
    May 13, 2009
    Messages:
    22
    Likes Received:
    0
    Bumping this as the OS has been on the market for a while now and someone might have a solution. I've seen a Jessica-poster having alot of solutions to problems, maybe mine too? If not, anyone else?
     
  5. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Try removing a stick or two of memory depending on how much you have. Try 2 GB or less.

    Make sure you disconnect all peripherals and USB devices also.
     
  6. Calath

    Calath New Member

    Joined:
    May 13, 2009
    Messages:
    22
    Likes Received:
    0
    Seems like the general idea is to disconnect everything that you don't really need. I have a disconnectable soundcard and only two sticks of RAM (2gb each). I guess I'll try to remove these as well as the USB devices. I read somewhere that it should be enough to remove the USB devices during the first reboot in the installation, do you know anything about that? I currently have no 'normal' - so to say - keyboards or mouses (can't remember what they're called, P2 or something?) in my house, so getting through the installation from start till end without any USB devices will be hard for me, or cost me money. No one uses that stuff in Norway anymore. :l
     
  7. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    The USB mouse and keynoard are OK to leave plugged in.
     
  8. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Did you slow it down?

    The system changes resolution to what it thinks it should be after the Setup Starting Services and Completing Installation.

    The Nvidia driver does seem to be a problem for some folks, I suppose you saw this thread.
    http://windows7forums.com/windows-7-installation-upgrade/6596-solved-stop-error-0x1e-caused-nvlddmkm-sys-during-windows-7-rc-setup.html

    I did not check if he was running x64, but if you screen changes resolution, this may not be your problem.

    Do you have any anti-virus stuff in your bios?
     
    #8 Saltgrass, Nov 8, 2009
    Last edited: Nov 8, 2009
  9. Calath

    Calath New Member

    Joined:
    May 13, 2009
    Messages:
    22
    Likes Received:
    0
    I haven't tried slowing it down yet seeing as I'm currently on vacation. Just figured I'd ask for solutions so I could start working on getting it to work as soon as I got home. As far as I know I don't have any anti virus in my BIOS. I haven't ever had any anti virus on my computer at all (and haven't had any troubles with that either) and I've never seen anything that could relate to an anti virus of some sort while browsing through it.

    The error you linked does not seem to be related to mine. I don't get any error messages as I've written in my original post. The computer freezes for ten seconds, starts again for a few, then freezes again. Rince and repeat. As said, the dots are even moving, but in a choppy way. I left the installation on for several hours (from around 5pm to 10pm) without anything progressing.
     
  10. Calath

    Calath New Member

    Joined:
    May 13, 2009
    Messages:
    22
    Likes Received:
    0
    At home now. Put the bios settings to default, unplugged all USB-units that was connected and same issue still appears. Gonna leave it for a couple of hours and then try unplugging the sound and videocard and see if that helps. If that doesn't cut it, then I have no clue.

    I've read around that people with the same issue had it solved by flashing their BIOS to a newer version. Any way to do this when I don't have an OS installed?
     
  11. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    You can probably get a boot media with the new bios on it (if you can burn one), check with the MB or system manufacturer.
     
  12. droflex

    droflex Guest

    I just dropped in to see how 'ya all are doing and Holy Cow!. Same problems with the installation. i was hoping you guys would have figured it out by now:confused:.

    Keep plugging away:).

    later.
     
  13. Calath

    Calath New Member

    Joined:
    May 13, 2009
    Messages:
    22
    Likes Received:
    0
    Hey guys.

    I figured out half a solution that didn't really help me at all. In my desperation I unplugged the power to my video card as soon as I started the installation. I listened to the reboots and quickly realized that I got a second reboot only a couple of minutes after the installation started, which meant I had gotten further than before. I rebooted the computer, plugged the video card in and managed to finalize the install and booted up into Windows 7. "Rejoice!" I thought, but no. Seeing as the OS wasn't installed with the video card, it needed to reboot to since I had new hardware plugged in. And this made me completely unable to boot up. I get past the loading screen and after that I get a black screen with a cursor I can move around for about an hour, until it then freezes.

    I am unable to boot up in safe mode as well. When I try, I just get to the normal black screen where I can chose between booting normally or try fixing the issue with StartupRepair. StartupRepair finds an issue it cannot solve called BadDriver.

    So I've concluded with the fact that my videocard sucks dick. The same thing (black screen, cursor, locks up) happened with all the newest nVidia drivers. And by newest I mean the last driver that worked for me was 177, the one that came with the release of Age of Conan. Gonna send my video card back to the place I ordered it from now and see if they can figure something out. I can't really see what's wrong with it though. It's literally working, but it just doesn't fix newer drivers. How could that be? Any ideas? Might it have something to do with me not updating the chipset drivers for my motherboard or updating bios or something weird like that?
     
  14. Calath

    Calath New Member

    Joined:
    May 13, 2009
    Messages:
    22
    Likes Received:
    0
    Hello guys.

    After replacing my video card everything worked perfectly. So that was my issue. A somewhat borked video card that worked on vista with older drivers, but didn't work on Windows 7 and didn't work with any drivers past 177. (nVidia)

    Hope this helps someone. D: You could do as me for troubleshooting if you don't have another video card or somewhy can't connect your monitor to your motherboard: Unplug the power to the video card just after starting the installation. Listen to reboots; if you have two, you've gotten past the "Completing Installation" step.

    :>
     

Share This Page

Loading...