Slow Wireless Internet with 7 Home Premium

Peterg

New Member
Hello,

I have recently installed a legitimate copy of Windows 7 Home Premium 32Bit. Since installing it (clean install) Wireless speeds have drastically reduced. Other people sharing the same wireless network have not noticed the same problem, and neither did I when my laptop ran Vista. My laptop is an Asus F8VR if that helps.


Thanks,

Peter
 


reghakr

Essential Member
Hello Peter,

have you visited any speedtest sites to verufy you're getting the speed you're paying for.

Such a Speedtest.net - The Global Broadband Speed Test

Have you reboted the router or modem?
 


Peterg

New Member
Hi, thanks for the quick reply.

I tried both of these. My Internet should be 20 mbps/s but speedtest.net came up with 1.22/1.02 down/up and 39ms ping.
I also reset my router to no effect. Any ideas? i'm stumped!
 


pauljw

New Member
Slow internet on Windows 7

The same thing has happened to me. I installed Windows Home Premium last weekend on my 2 year old Dell and everything works great, faster, except for my Broadband. I'm hardwired into the router and used to get 6.5 Mbs on Speed Test and now only get 0.6 Mbs. I'm signed up to a 7.2 Mbs service. I called the provider, rebooted the router and they checked the line - all should be perfect. Any ideas would be appreciated.
 


T

TwiCom

Guest
Fixed this issue by disabling the wireless adapter's "802.11n Mode"!

I just got a new Thinkpad T400 with the Intel WiFi Link 5100 AGN card running Windows 7 Pro. Using Speakeasy Speed Test as a gauge of Internet performance, I was getting ~700kpbs download. By comparison, I have also have a Thinkpad Z60t with Windows XP Pro getting wireless speeds of ~12,000kpbs.

I tried a variety of options, including updating drivers, disabling "Remote Differential Compression" --- none of these worked. What did work was disabling the wireless adapter's "802.11n Mode".

From 'Network Connections', right-click on 'properties'. Click the button to 'Configure..." the wireless adapter. Go to the 'Advanced' tab, which is the second tab after 'General'. In the 'Properties' box, the third option down for me is '802.11n Mode' which I set to 'disabled'. After rebooting, I was getting wireless speeds of ~12,000kpbs.
 


reghakr

Essential Member
Great,

Thanks for posting back with the solution.
 


Peterg

New Member
WOW! My download speed went from 1.13 to 9.19! Thanks for that solution, I was sure it was solvable, just took someone a bit more knowledgeable than me...
 


Mitchell_A

Essential Member
Nothing like a good old unfinished 802.11 N specification problem :^)
 


Peterg

New Member
And there was me thinking it was no longer 'draft' n!
 


youneek28

New Member
From 'Network Connections', right-click on 'properties'. Click the button to 'Configure..." the wireless adapter. Go to the 'Advanced' tab, which is the second tab after 'General'. In the 'Properties' box, the third option down for me is '802.11n Mode' which I set to 'disabled'. After rebooting, I was getting wireless speeds of ~12,000kpbs.
I still can't figure this out. I apparently don't know where Network Connections tab is to even start this process. No where in Windows 7 had network connections tap to right click on.

Any help would be great.

Thanks
 


Peterg

New Member
Click on your wireless notification icon on the taskbar, bottom right of the screen and select 'open network and sharing centre'. In this window on the left panel there should be the option 'change adapter settings' clicking on this should see all your wireless connections. Here you can click on your wireless adapter (mine is an Intel wifi link 5100) and follow those instructions above.

Hope that helps!
 


youneek28

New Member
Ok I did what you said and im at the broadcom 802.11g network adapter properties. In the advanced tab, I a list of things non saying 802.11 mode. Here is the list if it helps.


Fragmentation Threshold
IBSS 54g(tm) mode
IBSS 54g(tm) protection mode
Locally Administered MAC address
No Description
Priority & VLAN
Rate
RTS Threshold

And nothing within these say 802.11 mode. I do have a 802.11 only in the IBSS 54g(tm)mode with the other two options being 54g auto and 54g performance.

This stuff really pisses me off. You buy a product thinking it will work right and you have to go through this crap to get it to work.

Thanks for the help again
 


reghakr

Essential Member
Could you please fill in your computer specs in the UserCP link at the top left hand side of the page.

Then click Edit Your Details.

This freeware program will give you all the information you will need:

SIV (System Information Viewer) 4.03
 


youneek28

New Member
Ok I hope it helps.
 


youneek28

New Member
Ok I tried it and it will not install. I get a message that says, No compatible hardware found. The software you are attempting to install is not supported on this system. The software will not be installed.

Any other suggestions?
 


reghakr

Essential Member
Try downlaod

Try this, download the latest driver from that site, then get Universal Extractor

DO NOT check any boxes ecpect for the one at the very to.p

Uopi don't need langauages or documentation eitheer

After install, right-click on that file and choose UniExtrac Files. Look for an .inf file,
Idfyou see one, post back.
 


youneek28

New Member
Ok i will try that. I logged on in safe mode with networking, and my internet speed is back to normal. So what is loading in normal mode that is not in safe mode? I ve heard that you can disable something in windows that is loading and taking the speed away. I will have to try it again, but if you can help me that would be great

Thanks
 


reghakr

Essential Member
See if you can unpack the .exe using {Universal Extractor
 


youneek28

New Member
I got it on the computer and I dont know exactly how to unpack the .exe file
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top