Windows 7 Solution - Netgear FA311 v1 + No Internet + RC Build 7100


New Member
Jun 3, 2009
Hi all,

I came to this forum in order to get a solution for my problem. As many know and some would know now, when the drivers are not available for Windows 7, the NIC will just return a APIPA i.e., 169.x.x.x IP. We all thought this is a driver issue, but how do we find whether it is a driver issue or setting issue? Follow these simple steps.
1. Ping, if you get success replies, then your NIC is working fine, rule out the driver issue.
2. If failure reply, then you can try searching for the best drivers and then give it a go. Or, you can fix the TCP/IP stack or fix the socket issue.

Fixing corrupt TCP/IP stack,
netsh int ip reset resetlog.txt

Fixing socket issue,
netsh winsock reset

Let me now come to the problem I was facing and the fix that worked.

I have tried all the steps which every1 wil do when they encounter APIPA. Nothing worked. Then one of our fellow member(Acestes) asked me to ping and check. This gave me success reply. So, this made me think in a different way, rather than the old driver issue.

Then went to Netgear website and studied the basic difference of FA311 v1 and v2. Then went to driversguide website, downloaded a bunch of drivers which included MacPhyter too.

Tried installing all the various drivers, nothing worked. From driversguide I got one set of driver with the name The description told that it is the extract of the CD given by Netgear. When I tried installing this, in DM, under NA, it showed, Netgear FA311 Fast PCI Adapter. This is the correct version of my NIC.

When I tried the others, it would show, Netgear FA311/FA312 PCI Adapter. This is not the right version of my NIC. Okay, now I have got the right drivers installed and again pinged 127, success. Tried ipconfig, same 169. Set a static IP, but stil no internet.

Tried to refresh my networking knowledge and started this process.

Went to DM, right clicked on my NIC, Selected properties. Then Clicked Advanced, Under the property, there were 3 entries,
1. Network Address - Not present selected
2. Speed & Duplex settings - Auto sense
3. Transmit buffers - 160

Went to Power Management,
Both the check boxes were selected.

When I went to Netgear website, the v1 doesnt support wake-on LAN and it has a speed of 100Tx.

So, In Advanced tab, Selected Speed & Duplex settings, selected 100Tx in the place of Auto sense.
Went to Power Management, Unchecked both the check boxes. Clicked Ok.

Went to command prompt, ipconfig..

VOILA!!!!!! Got my DHCP IP address.

Opened IE8, flashed the MSN webpage.

Finally, internet had a taste of my Windows 7 RC 7100.

Still I do not know which setting change made it to work, either Advanced or Power management, but got it to work.

Happy now.

Hope all the users of this forum and other people having the same problem be happy with this solution.

Try it and check.

Note: If somebody needs that, request here, will upload or send it to them. If some1 needs screenshots, let me know, will take and post it.
Last edited:
105 views and not even a single reply or thnx. Appreciate someones effort guys!!!!
I would like the

can you please send it to ffmusicdj(at the rate of)gmail(dot)com

make sure you change the .zip to .whatever cause gmail wont take any e-mails that have .exe ...


or you can upload it :) either way, I have this exact same problem and I would like to try out these steps.
here you go m8..have uploaded the

Link Removed - Invalid URL
dre@ms, Your fix for getting a Netgear FA311, rev B-1 to work in Windows 7 worked for me. :) THANK YOU!!!!! :)

For the past several days I've been trying to find a solution to get several older network cards working with:


Netgear FA311 rev B-1
Linksys LNE 100TXRev2.0

(Trick to getting the Linksys LNE 100TXRev2.0 in this thread. Short version is use the 4_2 Win2000 drivers as the 5.12 driver pack does not support early cards. (Below ver 3 I think)
Windows 7 RC 7100, Ethernet drivers: Netgear FA311 rev B-1, Linksys LNE 100TXRev2.0 - -

Netgear FA311 rev B-1 -getting it and Win 7 RC 7100 to play nice.:)
To recap:
On a non-working install:
Go to Device manager, right click on NIC, Select properties. Click Advanced tab, Under the property, there should be 3 entries listed,
1. Network Address - Not present selected
2. Speed & Duplex settings - Auto sense (This will be changed to 100TX)
3. Transmit buffers - 160
(Transmit buffers were set at 40 by default on my system for some reason. I thnk I'm running the 1.80 FA311 drivers) I set this value to 128, the Highest it would go

Select Power Management tab,
By default Both the check boxes were selected. (These will be deselected as Netgear website says the v1 doesnt support wake-on LAN and it has a speed of 100Tx.)

THE FIX, (5 steps):

1: Go to Device manager, right click on NIC, Select properties. Click Advanced tab. On the advanced tab, Select Speed & Duplex settings. Change Auto Sense to 100Tx.

2: Change transmit buffers (Optional), mine was 40 by default, I set them to 128

3: Go to Power Management tab, and UNTICK both of the check boxes.

4: Click Ok and exit out of all dialog boxes.

5: Reboot your router.

Additional info:
There should be no need to reboot- but you may have to power cycle your router /DSL modem if it has a built in router.

For me after doing the above settings I had to go into the Network and Sharing Center and change the network type to private from public..

(I hate the way the Network and Sharing center works- Please Microsoft put a OPTIONS tab makes these areas more like XP!
(In WIN 7 RC 7100 it Seems like everything is dumbed down, that advanced menus are hidden or stripped out- I hope this is not how the retail versions are going to end up!) - With the above said I've only had it up and running for a short time- I haven't used Vista hardly at all, so maybe I get things figured out)

Note to Microsoft- Put the:
NETWORK STATUS LIGHTS BACK in that appear on the taskbar that lets you know the STATUS of the network!!!.... like it was in XP.
Whoever was the idiot that signed off on removing this feature needs to be DRAWN and QUARTERED.
Downloads will STALL, or a webpage will not be responding- and the WIN7 Network icon gives NO clue

Note to Netgear, Linksys, etc..... For those devices that can be made to work with a simple edit- Please amend the Readme Files with details on how to do such!!!!.

Note#2 to Microsoft- You need to get after the manufacturers to at least update their readme files and docs with info such as the above...if they can't write updated drivers.

People don't want to replace perfectly serviceable equipment at the drop of a hat you know.
(EG: Alot of people are holding off migrating to Windows 7 /Vista for the fear that their equipment will have to be replaced.)

Footnote: I know the reason the manufacturers don't want to write new drivers, or amend the readme files...
They want you to buy all new equipment..

Last edited:
^^glad it worked for u, I didnt restart my machine after doing the steps. Anyways, happy surfing.
I have a problem where I can access the internet on my pc that has Win 7, but it says not connected to a network. The thing is, its connected via router (dlink) but not the main adsl modem (netgear) even though the ethernet cable from that modem is connected to my pc. I also found a part that says "ocal area connection status ipv6 no connection". And I looked in my ipconfig and I see DHCP is not enabled.

I also tried what you suggested - Device Manager, and there is no NIC in the list at all!!! What do I do??

A copy of my ipconfig is pasted below:
Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.
C:\Users\Chelle>IPCONFIG /ALL
Windows IP Configuration
Host Name . . . . . . . . . . . . : Chelle-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : Yes
WINS Proxy Enabled. . . . . . . . : No
Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8168C(P)/8111C(P) Family PCI-E
Gigabit Ethernet NIC (NDIS 6.20)
Physical Address. . . . . . . . . : 00-1F-D0-D4-D7-60
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::8921:3866:f90a:f64b%13(Preferred)
IPv4 Address. . . . . . . . . . . :
Subnet Mask . . . . . . . . . . . :
Lease Obtained. . . . . . . . . . : Saturday, March 27, 2010 1:15:05 AM
Lease Expires . . . . . . . . . . : Saturday, April 03, 2010 1:15:05 AM
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 184557520
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-13-2D-DF-49-00-1F-D0-D4-D7-60
DNS Servers . . . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Enabled
Tunnel adapter isatap.{B4969898-A37D-4CF5-8E06-355240D117E6}:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Tunnel adapter Local Area Connection* 11:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:484:2c0e:2302:8a85(Prefe
Link-local IPv6 Address . . . . . : fe80::484:2c0e:2302:8a85%11(Preferred)
Default Gateway . . . . . . . . . : ::
NetBIOS over Tcpip. . . . . . . . : Disabled
Tunnel adapter 6TO4 Adapter:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft 6to4 Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

If anyone can give me an idea what I can do for Win 7 to detect my main adsl netgear modem and to have a network connection please, that would be great!!
Thank you. This was the solution for me as well. To just go a bit further, it was the Power Management setting to "Allow this device to wake the computer." that did it for me. I first tried the Speed & Duplex change but it did nothing. As soon as I deselected the option (in the Power Management Tab), I was able to DHCP an address. I even put Speed & Duplex back to Auto and it still works.
Hi all,

I found this old LAN card Netgear FA311 PCI and try to use it under Windows 10 64bit but the drivers cant be installed - i tried at least 5-6 different .zip and .exe files - dont work, cant make them run even in compatibility mode....... the card is working just fine under Ubuntu........

I have tried manually to update them from the extracted .zip - no luck - the device stands as "Ethernet controller" in DM with exclamation mark and i cant make it to work, help pls ?!
Last edited:
Hi Shnureaga;
Yes, this is no surprise.:blink: That NIC card is now 16 years old and came out the same year Windows XP did!:eek: Don't know what kind of PC you are attempting to use it on, but you need to realize that Microsoft doesn't guarantee compatibility of W10 with hardware built pre-Modern-era, or in other words before 2009. :ohno: If the PC you are trying to plug that card into has a Motherboard older than 2006; it will NEVER work,:noway: as W10 will NOT work on Mobos of that age due to 3 missing CPU instructions in all CPU chips made during that era: that includes Intel, AMD, and Via. I've done that testing personally on machines from 2016-2002. Post back Make/Model of your PC and we can pretty much identify it's age and compatibility. If it's an OEM PC, such as Dell, Acer/Gateway, HP, Toshiba, etc., those PCs often have a Service Tag label with the Build Date (aka Manufactured Date) right on the label. Dells, Gateways, HPs usually have it on the top of the PC tower case, or on the rear of the PC tower where all the cables plug in, or often on the bottom of the PC tower where very few people know to look. All the FCC & UL certifications for worldwide use are also on that label too.

If your PC was built prior to 2006, due to Mobo/CPU processor chip limitations, that card will never work with W10.:down: If it is newer, such as 2007-2008, it might work, but I doubt it.:noway: If it's modern-era (as defined by Microsoft), built in 2009 and came with Windows7 installed on it, there's a chance it might work.:andwhat: I tried that same card (I have one here) on machines of all ages as I indicated and finally gave up, as the hardware and the drivers (tweaked or factory supplied from Netgear website) are just too old to work on a version of Windows which is 16 years newer and 5 versions newer.:serious: If by some miracle you get it working on your PC, please post back Make/Model of that computer and the EXACT driver you used to get it working and share that with our other forum users.

Hi, my PC is kinda new era - GA-770TA-UD3, Phenom X4 965 @ 4.0Ghz, 8GB ram, SSD + 2 TB HDD, ATI 280X, assembled by me. That NIC works just fine under Ubuntu MATE latest version, but it is so hard for Microsoft to integrate driver which is 500kb .......... never mind, just i am used to try solve stupid problems, maybe i will get another LAN card because i dont want to use my integrated on mobo.
Thanks anyway
Top Bottom