Some applications do not start.

Discussion in 'Windows 7 Help and Support' started by dan007, Jun 8, 2012.

  1. dan007

    dan007 New Member

    Joined:
    Jun 8, 2012
    Messages:
    8
    Likes Received:
    0
    32 bit apps don't run, 64 bit apps do Was:(Some applications do not start.)

    Hi, hope someone can help me with this. Having a problem that is almost worse than a program crashing. (At least I would get an error so I can see what is the cause of the problem.) Anyhow this is the sequence of events.

    In the morning I "woke" up my pc from sleep and had no problems (basically surf web and read email, play some fb games :tongue: ). I went to work. Coming home I woke up my pc again, and noticed some of my browser windows were no longer open, then I realized it looked like my machine rebooted. The desktop was showing, but the normal apps that remain open during start up were not present. I looked at the status bar?(the area that shows active apps like, sound volume, network connection, USB devices, New updates available, Microsoft Security Essentials...) and noticed only about 1/3 of the icons were showing. I naturally wanted to start up ie to search for this problem, but ie did not start up. Meaning, I double clicked on the icon and nothing showed up. I tried applications listed below.

    ie does not start
    Google Chrome does not start
    Firefox does not start
    Command Shell starts, able to ping externally so probably isn't network related?
    word does not start
    Notepad works, but doesn't help me much
    Windows Update does not start

    same problem in safe mode

    Rebooted back to normal mode (not safe mode) and noticed Windows gadgets start to appear about 3 minutes after desktop appears.

    performed a scandisk (had to reboot of course)

    Started Microsoft Security Essentials, got it uptodate, ran quick scan, nothing found.

    I eventually found out internet explorer 64 bit works! I searched and found this forum. Using problem identification guidelines posted.
    1) rebooted to capture beginning of ev log. on boot up eventviewer (after 2 minutes comes up)

    • The server {E10F6C3A-F1AE-4ADC-AA9D-2FE65525666E} did not register with DCOM within the required timeout.
    • The Peer Name Resolution Protocol cloud did not start because the creation of the default identity failed
    • with error code: 0x80630801.
    • The Peer Name Resolution Protocol service terminated with the following error: %%-2140993535
    • Session "Microsoft Security Client OOBE" stopped due to the following error: 0xC000000D
    • A timeout was reached (30000 milliseconds) while waiting for the Akamai NetSession Interface service to connect.
    • A timeout was reached (30000 milliseconds) while waiting for the Apple Mobile Device service to connect.
    .
    .
    .
    2) Device Manager shows no yellow triangles

    3) permon /report shows (as expected from ev log)
    Diagnostic Results/Warnings:
    Symptom: A service is reported as having an unexpected error code
    Cause: One or more services has failed. The service did not stop gracefully, suggesting the service may

    have crashed or one of its components stopped in an unsupported way.
    Details: Service exited with code not equal to 0 or 1077
    Resolution: Restart the service
    Related: Performance Diagnosis

    I'm not sure what else is relevent in the report. It does show under Anti-Virus Information that a Query
    of root\SecurityCenter:SELECT * FROM AntiVirusProduct resulted in 0x0.

    4) "Find and Fix" did not have any thing for my problem

    5) n/a did not upgrade from Vista, was a new install 2 years ago?


    Properties(right clicking and selecting Properties) on Computer does nothing.

    Running dxdiag does nothing (from Run option and cmd.exe)

    Edit Added:
    It's looking like 32 bit applications do not start, but 64 bit applications do. For example programs in the Program Files (x86) will not start, but programs in the Program Files (assuming these are 64 bit) do start.

    Also I've used msconfig and found same results when booting with no startup items, and no Services started.

    So is there an system application that runs the 32 bit applications on windows 64 bit? It seems that program does not work on my machine now. Is there any way to replace it?

    Begin Edit Morning of June 9th, 2012
    I've tried system restore and it failed during the restore, and then windows failed to boot. I was able to get it back to the same state? now with windows repair, sfc, and replacing reported bad files from windows 7 install disk.
    End Edit Jun 9th 2012

    Begin Edit June 10th, 2012
    I'm 90% sure it's just 32 bit applications that don't start.
    - Application Verifier does not start
    - Application Verifier (x64) does start
    - Internet Explorer (Program Files x86) does not start
    - Internet Explorer (Program Files) does start
    End Edit June 10th, 2012

    Any ideas where go to from here?

    Thanks,
    Dan
     
    #1 dan007, Jun 8, 2012
    Last edited: Jun 10, 2012
  2. Pauli

    Pauli Extraordinary Member
    Premium Supporter

    Joined:
    Mar 1, 2012
    Messages:
    2,499
    Likes Received:
    211
    Re: 32 bit apps don't run, 64 bit apps do Was:(Some applications do not start.)

    Do an extra Malware check, Malwarebytes : Free anti-malware, anti-virus and spyware removal download It sounds like something hit your computer. Another thing is hardware, viz. memories, Google "Memory Check", there are many options. Of course, it can be anything, the processor, video card, power supply unit.

    Hope you get it fixed. :)
     
  3. dan007

    dan007 New Member

    Joined:
    Jun 8, 2012
    Messages:
    8
    Likes Received:
    0
    Re: 32 bit apps don't run, 64 bit apps do Was:(Some applications do not start.)

    Hi, well I would if I could, but those are also 32 bit apps. The only anti- bad stuff that seems to run is MSE. Everything else seems to have a 32 bit version only so it does not run. You did give me a good idea, I'm going to see if I can run them from Bart's PE.


    Update - Problem solved!
    I don't know how or why 32 bit apps now works, but these are the steps I performed. I tried to include everything I did even if it seems insignificant.

    - Ran MSE full again and it still found nothing
    - downloaded Malware
    - tried to install, but failed... 32 bit apps won't work ( was hoping it was 64 bit so I tried just in case)
    - booted to windows dos mode couldn't install from there
    - windows recover found a win7 ultimate partition?
    - tried repair on main partition it found nothing wrong
    - tried repair on win7 ultimate install, failed (of course since it was my old xp)
    - installed win 7 on another partition ie to run Malware
    - on reboot (I left dvd in drive) it tried to install again so I removed it and rebooted again
    - reboot failed
    - rebooted back to my original partition (to get online to see install process) and machine fully booted!!!

    Thank you for your advice! I'm not sure why it worked, but I was seriously thinking of going Mac or Linux as my main machine. Now I think I'll stick with windows 7 and this time be more vigilant on windows restore points.

    Thanks again
     
    #3 dan007, Jun 15, 2012
    Last edited: Jun 15, 2012
  4. Pauli

    Pauli Extraordinary Member
    Premium Supporter

    Joined:
    Mar 1, 2012
    Messages:
    2,499
    Likes Received:
    211
    Re: 32 bit apps don't run, 64 bit apps do Was:(Some applications do not start.)

    SUPER!!!

    Quite often problems are solved in a way we don't really grasp, like the Biblical The Lord works in mysterious ways.

    Main joy is, You got it running. Cheers.
     
  5. dan007

    dan007 New Member

    Joined:
    Jun 8, 2012
    Messages:
    8
    Likes Received:
    0
    Re: 32 bit apps don't run, 64 bit apps do Was:(Some applications do not start.)

    I spoke too soon! My problem still exists. As everyone seems to suggest that I have malware, I was finally able to run the Malware installer (32 bit), when my machine came back up. Bad news, Malware wanted me to reboot after the install. So reboot I did, and my problem came back. 32 bit programs don't run. Malware doesn't run. :( I tried to boot off my failed windows 7 again to check the error, and then rebooted back into my current volume (to use the web to research) and voila! Machine fixed again? 32 bit apps run. Anyhow long story short, I seem to have to boot into the failed partition first and then boot my other partition and it works. I have run many sfc's as well as Malware full scans and I still have the problem. For now I will live with the manual boot to failed volume then boot to other volume to get things to work.
     
  6. SJConline

    SJConline New Member

    Joined:
    Jun 12, 2012
    Messages:
    2
    Likes Received:
    0
    ch? th?t oi, cho em cái email cái d? ti?n trao d?i nhé. có tý vi?c c?n h?i bác
     
  7. dan007

    dan007 New Member

    Joined:
    Jun 8, 2012
    Messages:
    8
    Likes Received:
    0
    Sorry can't understand what was written.

    Anyhow, Microsoft to the rescue! I think I'm going to get windows 8 instead!
     

Share This Page

Loading...