Some users displayed on Welcome Screen, others not displayed

Discussion in 'Windows 7 Help and Support' started by craig69, Aug 2, 2011.

  1. craig69

    craig69 New Member

    Joined:
    Aug 2, 2011
    Messages:
    10
    Likes Received:
    0
    Windows 7 Home Premium 64-bit SP1.

    Have 7 standard users created in the User Accounts. Only 5 user icons displaying on welcome screen. All 7 users are required to and do have passwords set.

    Creating a new user does not add that new user to the welcome screen.

    Deleting a user does not move one of the other users onto the welcome screen..it reduced the number of user icons to 4.

    All users have valid \User directories and if I force the login prompt instead of icons, they can login successfully.

    This happened about a week ago and may be the result of some software my son installed. Not sure.

    There is not an "Other User.." icon...just 5 valid user icons with 2 missing.

    Any help appreciated.

    - Hank.
     
  2. Conduct

    Conduct Banned

    Joined:
    Jul 15, 2011
    Messages:
    167
    Likes Received:
    0
  3. craig69

    craig69 New Member

    Joined:
    Aug 2, 2011
    Messages:
    10
    Likes Received:
    0
    I've googled myself crazy over this and the solution you recommend does not match my issue. I do not only have the last logged in user displaying, I have 5 users showing with two missing and no "Other User" icon present.

    I appreciate you replying though.
     
  4. nmsuk

    nmsuk Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Sep 7, 2009
    Messages:
    2,697
    Likes Received:
    194
    If you open regedit and navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList and delete the default entry. All user accounts should then show up on the welcome screen. If it doesn't work however post back and we'll see what else can be done.
     
  5. craig69

    craig69 New Member

    Joined:
    Aug 2, 2011
    Messages:
    10
    Likes Received:
    0
    I saw that thread also. I did not have a DEFAULT user profile in there. Only the three Windows required profiles along with the legitimate users I do have (including the ones that do not show).
     
  6. nmsuk

    nmsuk Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Sep 7, 2009
    Messages:
    2,697
    Likes Received:
    194
    OK! Have you tried this


    you can do this through secpol.msc
    1. Click Start->Run->secpol.msc
    2. Navigate to Local policies -> Security settings
    3. Find the entry "Interactive Logon: Hide last user..." and set it to activated.
    4. Reboot the machine

    Have you tried System Restore? Asking your son what he did and what he installed would be helpful :)
     
    #6 nmsuk, Aug 2, 2011
    Last edited: Aug 2, 2011
  7. craig69

    craig69 New Member

    Joined:
    Aug 2, 2011
    Messages:
    10
    Likes Received:
    0
    It's windows home premium. No local security policies. secpol.msc does not exist and when I fire it up through MMC, there is a blank policy.
     
  8. Conduct

    Conduct Banned

    Joined:
    Jul 15, 2011
    Messages:
    167
    Likes Received:
    0
    Did some Research Try going to this Link: Don't display welcome screen at logon (Computer) :eek:
     
    #8 Conduct, Aug 2, 2011
    Last edited: Aug 2, 2011
  9. craig69

    craig69 New Member

    Joined:
    Aug 2, 2011
    Messages:
    10
    Likes Received:
    0
    Solved.

    Set the [HKEY_LOCAL_MACHINE \Software \Microsoft \Windows \CurrentVersion \Policies \System]
    DontDisplayLastUserName value to a 1.

    Rebooted.

    Set the [HKEY_LOCAL_MACHINE \Software \Microsoft \Windows \CurrentVersion \Policies \System]
    DontDisplayLastUserName value back to a 0.

    Rebooted.

    All icons are back.
     
  10. Conduct

    Conduct Banned

    Joined:
    Jul 15, 2011
    Messages:
    167
    Likes Received:
    0
    If you have any other problems let us know!
     
  11. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Congratulation and great work in successfully resolving your own issue and thanks for updating your thread with your solution as it's likely to be very helpful to other members and visitors with similar issues.
    Hope to continue to see you around the forums and thanks for joining our community.
    Regards
    Randy
     
    2 people like this.
  12. jhertel

    jhertel New Member

    Joined:
    Jan 10, 2014
    Messages:
    1
    Likes Received:
    0
    Thanks, Craig69, for writing the solution. It worked perfectly for me too.

    I just want to tell others with the same problem that an even faster method worked for me: Logging off instead of rebooting.

    So the revised, faster method that worked for me is:

    1. Set the [HKEY_LOCAL_MACHINE \Software \Microsoft \Windows \CurrentVersion \Policies \System]
    DontDisplayLastUserName value to a 1.

    2. Log off and log in again. (You will have to type both the user name and password yourself. This is only temporary.)

    3. Set the [HKEY_LOCAL_MACHINE \Software \Microsoft \Windows \CurrentVersion \Policies \System]
    DontDisplayLastUserName value back to a 0.

    4. Log off.

    All icons are back.

    Thanks again, Craig69! You saved my day!
     

Share This Page

Loading...