Sony Vaio "FN" Keys

Discussion in 'Windows 7 Help and Support' started by Unseen, Mar 23, 2009.

  1. Unseen

    Unseen New Member

    Joined:
    Mar 23, 2009
    Messages:
    14
    Likes Received:
    0
    I have a Sony Vaio VGN-AW190 that originally came with Vista Home 64bit. I installed Windows 7 (clean install) 64bit.

    The problem is the special buttons are not working at all (eject, S1, S2, multimedia, AV Mode, onscreen display such as when you adjust volume or brightness), etc. I did install Sony Notebook utility drivers/software from that model's driver page (sonystyle.com). I rebooted as it instructed to do during install. The main software were the notebook utilities, but I installed almost everything on the list. I tried 3 times now. Still do not work.

    Any suggestions on this? Any alternatives?

    Just for clarification, I installed the 64 bit Vista Ultimate versions of the drivers/software. Also, these all worked fine when I did a simple upgrade from the original Vista recovery CD's. However, you all know the deal with bloatware and that clean installs are better.

    I installed the necessary software that *normally* would make all these fn keys work:
    Original - Sony® Notebook Utilities
     
  2. TanMan

    TanMan New Member

    Joined:
    Mar 20, 2009
    Messages:
    26
    Likes Received:
    2
    Recently loaded W7 64 Bit Ultimate Build 7068 on my Vaio Z36GD. Experiencing same issues as you report, and I also have not been able to resolve yet. No show stoppers yet in my limited testing, but I miss Eject and Volume FN keys. Strangely, FN-F2 for mute does work as does FN-NUM-LK for SCR LK. (FN keys for page up/down/home/end all work too) Same for you?
     
  3. lifeisfun

    lifeisfun New Member

    Joined:
    Jan 20, 2009
    Messages:
    16
    Likes Received:
    4
    Same problem here with VGN-FS640 :(
    Did anyone find solution ?

    Thanks
     
  4. danep

    danep New Member

    Joined:
    May 17, 2009
    Messages:
    4
    Likes Received:
    0
    Same issue here, VGN-S660P. Have tried installing just about every driver imaginable, including in compatibility mode.
     
  5. lifeisfun

    lifeisfun New Member

    Joined:
    Jan 20, 2009
    Messages:
    16
    Likes Received:
    4
    I got it working now :)
    Install exactly in this order:
    Download all sony drivers for Vista
    Instal Vaio event service
    Reboot
    Install Sony DLL Utils
    Reboot
    Install Sony shared Library
    Reboot and it should work
     
    erdem and (deleted member) like this.
  6. danep

    danep New Member

    Joined:
    May 17, 2009
    Messages:
    4
    Likes Received:
    0
    Wow! This worked great! Thanks so much. I had installed all of these already, but I guess doing it exactly in that order and rebooting after each one is key.
     
  7. lifeisfun

    lifeisfun New Member

    Joined:
    Jan 20, 2009
    Messages:
    16
    Likes Received:
    4
    I'm glad it worked for you as well !
    Enjoy :p
     
    dam89 and (deleted member) like this.
  8. Shooshi

    Shooshi New Member

    Joined:
    May 28, 2009
    Messages:
    2
    Likes Received:
    0
    Nice it worked for me too. Has anyone figured out how to configure the S1 S2 keys? it seems mine is automatically set to s1=medium brightness and s2=windows media center. If anyone knows how to do this please let me know! Thanks!
     
  9. dam89

    dam89 New Member

    Joined:
    May 8, 2009
    Messages:
    372
    Likes Received:
    8
    thanks just bought a second hand vaio it worked a treat.
     
  10. CurlyCarlos

    CurlyCarlos New Member

    Joined:
    Jun 3, 2009
    Messages:
    2
    Likes Received:
    0
    Thank you SO MUCH for this, it worked like a charm! This was pretty much the only thing that I hadn't gotten to work on 7 after moving from XP... thanks again, this tip should be more well known.
     
  11. beadleda

    beadleda New Member

    Joined:
    Jun 18, 2009
    Messages:
    6
    Likes Received:
    0
    Same problem, different laptop

    I'm experiencing the same thing, but on a Dell Inspiron E1505. I'm going to try installing a Dell System Tools disk, and I'll update after that.

    If that doesn't work, any ideas? All the drivers I needed for my computer to be 100% functional were automatically downloaded; the display adapter driver that was downloaded by Windows matches the one I have..... :confused:

    Also, I can adjust my brightness until my display turns off and my laptop is unplugged (eg. taking my computer on-the-go while hibernating/sleeping). After that, the screen is dim, yet the control panel says I have my brightness set to max.
     
  12. cyberstven

    cyberstven New Member

    Joined:
    Aug 25, 2009
    Messages:
    6
    Likes Received:
    0
    Hey guys. I'm still a little confused about what to do. So do I go to sony online care, download all the drivers for vista OS? Then, where can I get the Vaio event service and DLL Utils and Shared Library? This recommendation looks great, but I'm just a little confused as to where I can get everything. If you could help, it would be much appreciated. Thanks so much!

    -Steven
     
  13. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,828
    Likes Received:
    1,565
  14. cyberstven

    cyberstven New Member

    Joined:
    Aug 25, 2009
    Messages:
    6
    Likes Received:
    0

    AWESOME. Thanks so much for helping me Kemical. The only thing I want to ask before I go forward is do I need to get 64 bit drivers? Or do the ones on my product page (vgn-sz750n) suffice? Thanks again for the help, I really appreciate it.
     
  15. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,828
    Likes Received:
    1,565
    If you'll be using a 64bit os then you'll need 64bit drivers. If no 7 drivers are available then vista ones will do (or should do)..
    If you post a link to your product page I'll check the drivers over for you if need be...
    :)
     
  16. cyberstven

    cyberstven New Member

    Joined:
    Aug 25, 2009
    Messages:
    6
    Likes Received:
    0

    Kemical, you are a god. Thanks so much for the help, I really appreciate it.

    Sony eSupport - VGN-SZ750N - Software Updates & Drivers
     
  17. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,828
    Likes Received:
    1,565
    No worries, glad to help. The drivers look fine although they are for vista but should work fine under 7. If something doesn't seem to work... Remember that Windows update will often find drivers and is worth trying in case of any hitches.
    Post again if you need any other help... :)
     
  18. Sampurana

    Sampurana New Member

    Joined:
    Sep 8, 2009
    Messages:
    8
    Likes Received:
    0
    Hi all,

    I have a VGN-AR71S European model (which is similar to US model VGN-AR790U, I think), was initially delivered with Vista home premium, and I tried to install Windows 7 ultimate 64 bit, and download all the 64 bit drivers and followed all the steps given here, everything is working properly; ....except somehow I am unable to get these keys (eject, s1,s2, fn+) working,

    ...what I am doing wrong............help please...
     
    #18 Sampurana, Sep 8, 2009
    Last edited: Sep 8, 2009
  19. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,828
    Likes Received:
    1,565
    Hi Sampurana,
    usually drivers for stuff like that would be on the laptop makers web site

    See if this helps any:

    Vaio : Sony Europe
     
  20. Sampurana

    Sampurana New Member

    Joined:
    Sep 8, 2009
    Messages:
    8
    Likes Received:
    0
    Dear Kemical,

    I Did already for few times:

    Install exactly in this order:
    Download all sony drivers for Vista and install,
    Instal Vaio event service
    Reboot
    Install Sony DLL Utils
    Reboot
    Install Sony shared Library
    Reboot and it should work

    __________

    but still the button like eject, s1, s2, and Fn+ are not working...even though I download the necessary software from European and US sport site ( VGN-AR790U similar model from EU)....:confused: :mad:
     

Share This Page

Loading...