Sound Blaster Live 5.1 Digital SB0220 driver

Discussion in 'Windows 7 Hardware' started by cygnus333, Aug 25, 2009.

  1. cygnus333

    cygnus333 New Member

    Joined:
    Jan 29, 2009
    Messages:
    58
    Likes Received:
    0
    Is it possible to use this card (Sound Blaster Live 5.1 Digital SB0220) on a computer running Windows 7 32-bit build 7100? If it will, work can someone please provide a link to the driver? I've been searching with Google & Bing for the last hour and I should have probably come here first.

    Windows ver.: Windows 7 32-bit build 7100
    Main Board: Gigabyte M1689D
    RAM: 1024 mb
    Processor: 1.60 gigahertz AMD Pentium 4
    Sound card: Sound Blaster Live 5.1 Digital SB0220

    Thanks in advance,
    Chris
     
    #1 cygnus333, Aug 25, 2009
    Last edited: Aug 25, 2009
  2. Highwayman

    Highwayman Extraordinary Member

    Joined:
    Jun 3, 2009
    Messages:
    3,977
    Likes Received:
    112
    Try Creative, occasionally Vista driver may work....

    Creative Worldwide Support > Sound Blaster Live! 5.1 Digital (Dell)
     
  3. cygnus333

    cygnus333 New Member

    Joined:
    Jan 29, 2009
    Messages:
    58
    Likes Received:
    0
    Thanks, that worked. I had to manually install the driver. The setup program didn't work.
     
  4. volandzz

    volandzz New Member

    Joined:
    Aug 26, 2009
    Messages:
    4
    Likes Received:
    0
    I have exactly the same card and the same problem. Could you please provide me with link to the driver that helped you? I didn't find vista driver for this card on Creative site.
     
  5. cygnus333

    cygnus333 New Member

    Joined:
    Jan 29, 2009
    Messages:
    58
    Likes Received:
    0
    I downloaded the Vista Dell version from what Highwayman said. The filename is SBAXVSD_PCDRV_LB_2_12_0002.exe 38.3 mb. I extracted it with Winrar. Using Device Manager, right-click on the entry for the card and select "Update Driver Software" then click "Browse My Computer...". Navigate to the folder where you extracted the downloaded SBAXVSD_PCDRV_LB_2_12_0002.exe file. Make sure "Include subfolders" is checked and click on next. The rest was automatic. Device manager found the driver and installed it.

    Unfortunatly I downloaded so many soundblaster files that I am not really sure where I got this one but I know that's the right filename and I am 99% sure it was on the creative site.
    This may be it: http://support.creative.com/Products/product_list.aspx?catID=1&CatName=Sound+Blaster#

    Good Luck,
    Chris
     
    #5 cygnus333, Aug 26, 2009
    Last edited: Aug 26, 2009
  6. volandzz

    volandzz New Member

    Joined:
    Aug 26, 2009
    Messages:
    4
    Likes Received:
    0
    I've tried SBAXVSD_PCDRV_LB_2_12_0002.exe.
    Sound has apppeared but it's very very low quality. Like for rear speakers. I don't know what to do. Can anybody help me with that?
     
  7. cygnus333

    cygnus333 New Member

    Joined:
    Jan 29, 2009
    Messages:
    58
    Likes Received:
    0
    Try this. In the control panel go to 'Sound icon'. Select your device. Under 'configure' and 'properties' there are allot of settings there that may help. Under 'speaker properties' and 'advanced' one of the settings you can choose is your sound quality, like DVD or CD quality. I was getting mostly static until I changed this one.

    Regards,
    Chris
     
  8. Highwayman

    Highwayman Extraordinary Member

    Joined:
    Jun 3, 2009
    Messages:
    3,977
    Likes Received:
    112
    yea my souncard driver does much the same...with my Audigy-2-Z its fine in 16bit at any freq, in 24bit upto 96khz works then the sound goes to crap with distortions, no great surprise since it's low end card.
     
  9. loonwin7

    loonwin7 New Member

    Joined:
    Oct 29, 2009
    Messages:
    12
    Likes Received:
    0
    Sound Blaster Live 5.1 Digital SB0220 driver - Windows 7

    I've finally found a way to use this sound card on my win 7 x86 (up to date). The first driver I found to work is Daniel K's driver, but this one has a small problem: u can't use more then 2GB of memory(or you'll get BSOD). You can find this one by searching on google "creative daniel k". The second one I found to work is kxdrv3550-x86-full, from KX ofcourse(google "KX project"). Just to be on the safe side I installed the Kx driver when I had 2GB of ram and after the install I added the rest of the ram. Now it works well with more then 2GB of ram. I'm not sure if Daniel K driver works if u add more ram after you install it. Again, don't know if this had any influence but I first had the daniel K driver installed and then I installed the KX driver without uninstalling daniel K driver .

    So to make it simple this were my steps:
    1. Removed RAM until I had left 2gb
    2. Installed Daniel K driver (vers 1.5 google it)
    3. Installed Kx driver (3550-x86 google it)
    4. Added the rest of the RAM.
    5. Soundcard works good with more the 2GB of RAM on WIN 7 x86 :D

    If you have kx driver and you don't get 5.1 sound go to control panel -> sounds -> chose "SPDIF/AC3 Output -> press Set as Default
     
    #9 loonwin7, Oct 29, 2009
    Last edited: Oct 29, 2009
  10. Jparks5

    Jparks5 New Member

    Joined:
    Nov 6, 2009
    Messages:
    4
    Likes Received:
    0
    AAAAaaaaagahhhghghgghghgh!!!! *@$%&$!%^*

    Ok so now I will try a second time even to post this!!

    I used to download drivers and build machines like it was nothing.

    I dropped out of the industry for about 8 years and now I can't seem to download any kind of driver without someone trying to sell me the next best driver look up and install tool for $29.99.

    What am I doing wrong???

    When I try and run SBAXVSD_PCDRV_LB_2_12_0002.exe. it tells me to upgrade to Vista?!?!??!

    when I try the kxdrv3550-x86-full it tries to sign me up for a I think another forum?!?!?!!??

    HELP please If nothing else just semd me the driver!!!!! Jeesh nothing like feeling like an idiot already.....
     
  11. Jparks5

    Jparks5 New Member

    Joined:
    Nov 6, 2009
    Messages:
    4
    Likes Received:
    0
    got it =->

    I googled the crap out of every kind of driver and setup program that didn't work. It would crap out or say it worked but did not. Until, I decided to use bing and search! I figured different search engine should provide different articles. Low and behold it worked. I got other areas to look and after a few I found this one SBLive_SupportPack_1_5,exe. This one I simply ran the executable and poof a sound card that worked. Now it didn'r work perfectly it didn't seem to give me the front to back fade my speakers have on my other sound blaster, but it worked. so that was my solution hopes it helps somebody else. I am not sure where I downloaded it from It was a very slow download and free so I didn't complain to much. I also didn't play with it much. I had resolved to use the other SB card so it didn't matter to me anymore. If somebody else wants to play please post or send me an E-mail. to up date me. Thank win 7 forum some help some BS but it does seem to be a decent plac eto start.

    Now does any body know why my Symantec_Endpoint_Protection_11_0_4000_MR4_32 wont work when it is supposed to???
     
  12. DiabloIV

    DiabloIV New Member

    Joined:
    Nov 9, 2009
    Messages:
    2
    Likes Received:
    0
    It Workes like a charm

    I have been searching like crazy for a solution for this problem and had actually abandoned all hope, then i made one last attempt with this solution and i am happy to say my computer is now making perfect sounds in W7 32bit,
    loonwin7, thank you very much :)
     
  13. loonwin7

    loonwin7 New Member

    Joined:
    Oct 29, 2009
    Messages:
    12
    Likes Received:
    0
    Sound Blaster Live ! 5.1 drivers

    You can find the drivers here , seems there are both the daniel K and kx project
     
    #13 loonwin7, Nov 24, 2009
    Last edited: Dec 25, 2009
  14. candasm

    candasm New Member

    Joined:
    Dec 25, 2009
    Messages:
    2
    Likes Received:
    0
    it still not working just old drivers are workng and front speakers giveing sound but mic is working its ok wtih kx drivers mic not working and just center speaker giveing sound :D what a ashame need to be a good company creative but look cant write easy driver for it

    i have SB0220 and i sent email to creative and they wrote me use older version of ur operation system .They try to say creative company cant write a new drivers for windows 7 our old products are not supporting windows 7 im asking this question is it a new game ? new sound technologys for one operation system ok if it will be at windows vista i can accept vista problems but windows 7 ??? i dont think its a problem for it how it can be my audio card is not supporting windows 7 profeesssioan sound effects what a stupid idea... and still not any driver is working good for windows 7
     
  15. bojan

    bojan New Member

    Joined:
    Apr 9, 2010
    Messages:
    4
    Likes Received:
    0
    i have instaled kx project and sound is great but my microphone don t work if you know how to set up mic pleas help me :D
     
  16. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,790
    Likes Received:
    1,563
    Is the mic turned on in sound properties?
     
  17. Magwif

    Magwif New Member

    Joined:
    Jun 12, 2010
    Messages:
    2
    Likes Received:
    0
    SB0220 SB Live 5.1

    Hey
    I have been trying to get a Win7 driver for this card for weeks

    in the end I got it from Creative website works fine

    the driver name is "LiveDrvUni-Pack(ENG)", search it on the creative site

    everything else I tried crashed my OS

    :)

    M
     
  18. sreerajkishore

    sreerajkishore New Member

    Joined:
    Jun 18, 2010
    Messages:
    2
    Likes Received:
    0
    Re: AAAAaaaaagahhhghghgghghgh!!!! *@$%&$!%^*

    thnkz..........................................................................................................................................................................................
     
  19. MarkusPxPx

    MarkusPxPx New Member

    Joined:
    Jul 26, 2010
    Messages:
    2
    Likes Received:
    0
    I have installed the KX Drivers version 3550 and works perfect on my
    Windows 7 x64 with 4gb of ram
    but my problem is my microphone, still not working :/

    someone knows the solution ?
     
  20. Roggah

    Roggah New Member

    Joined:
    Aug 22, 2010
    Messages:
    6
    Likes Received:
    0
    Hi ...

    I had KX mixer installed earlier in windows 7 and the sound worked for a while after the sound disappeared and my microphone didnt wanted to work any more I uninstalled it because it seemed that I had to be einstein to understand all the stuff in the mixer and I dont seem to find any good and easy guides on google for it.

    After that I installed Daniel K's driver and the sound worked but very bad.. I couldnt even hear the music that I played on youtube..

    Now when I tried to install the "LiveDrvUni-Pack(ENG)" driver it say that it cant find any sound blaster cards on my system and it exit the setup.
    So what are you doing that I dont when you are installing the driver?

    I know that it is soundblaster live 5.1

    I am soon thinking about going back to windows xp(x86) again if microsoft or creative doesnt create a driver that will work for the soundcard..
     

Share This Page

Loading...