Sound levels not switching between headphones and speakers

Discussion in 'Windows 7 Hardware' started by admiralspock, Aug 7, 2010.

  1. admiralspock

    admiralspock New Member

    Joined:
    May 15, 2009
    Messages:
    14
    Likes Received:
    0
    Hi, I have an HP G60-230US laptop with Windows 7 x64. Previously on x86, Windows would detect when I am using the headphone output and when I am using the laptop's internal speakers. This way I had the headphone output running my monitor's speakers at the maximum level so I could adjust on the monitor's speaker bar itself. Then when I would unplug it, it would mute the internal laptop speakers. That way there are no surprise startup noises in a very quiet room!

    I have downloaded the drivers from HP for Win7 x64 for the audio, but this did not solve the problem. Is this just a 64-bit Windows bug or is there something I can do to fix it?

    Thanks for any help
     
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,829
    Likes Received:
    1,565
    Hi,
    this might down to a setting within the audio software. Does your audio software have a 'Sound manager'? If so check through the settings and you might find a box to tick saying 'detect headphones' or something similar...
     
  3. admiralspock

    admiralspock New Member

    Joined:
    May 15, 2009
    Messages:
    14
    Likes Received:
    0
    Thanks for your response... This doesn't do it... What it DOES do is whenever headphones are plugged in it will cut audio from the laptop speakers. What it did on Windows 7 x86 was assign a specific level to each... so when headphones were in it would automatically set the volume level at maximum, and when they were unplugged the sound would be muted so nothing came through the laptop speakers.

    My sound driver is Conexant High Definition Audio 221... seems to be on many of HP's laptops. I have an app in my control panel called SmartAudio which comes with the driver but that does not do much of anything.
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    You might check this. Right click the speaker icon and select Playback Devices. You should show at least speakers and headphone. Select each in turn and click the properties button then the Level tab. Try setting levels on each device there and see if it helps. You may have to right click in the Playback Devices windows and select show disconnected devices.

    If you do not show both devices, perhaps you need to right click the speaker icon and select Volume Control Options and check all devices currently playing sound.

    If that won't help, I would have to agree with kemical about a special utility might have done what you want in the past. Perhaps it works differently in x64, or you haven't loaded the x64 version of some driver.
     
    #4 Saltgrass, Aug 8, 2010
    Last edited: Aug 8, 2010
  5. admiralspock

    admiralspock New Member

    Joined:
    May 15, 2009
    Messages:
    14
    Likes Received:
    0
    All I am seeing in the playback devices window are Speakers and HDMI audio.

    On Windows 7 x86 I did not ever install an audio driver. It just worked, and I loved the way Windows 7 did it. Since Microsoft was much more forthcoming about the 64-bit version of 7 (including both discs in retail packaging) than previous versions, I can't imagine that the 64-bit version would not have the same capability.

    I tried uninstalling the audio driver (that I had installed from HP's website) and let Windows figure out what to do, and it put the same driver and software back in.
     
  6. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,829
    Likes Received:
    1,565
  7. admiralspock

    admiralspock New Member

    Joined:
    May 15, 2009
    Messages:
    14
    Likes Received:
    0
    Thanks for that link. I did not know there was a new BIOS update.

    I don't know what I did, but I think I fixed it. I was messing with the settings in the SmartAudio app and now it looks like the screenshot attached. My Output Devices now show HDMI audio, Speakers, Headphones, and Line.

    Thanks for all the help!

    2010-08-08_1505.
     
  8. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,829
    Likes Received:
    1,565
    That's great!
     

Share This Page

Loading...