Sound stuttering in Windows 7

Discussion in 'Windows 7 Help and Support' started by Obmutescence, Aug 30, 2009.

  1. Obmutescence

    Obmutescence New Member

    Joined:
    Aug 30, 2009
    Messages:
    12
    Likes Received:
    0
    Hi fellow Windows 7 users! Well so I've been using Windows 7 64 bit, Ultimate, for a couple months now, started on the RC and am loving it. Recently a couple weeks ago I took a step and got a technet sub and am currently using the RTM which is 6.1.7600 Build 7600. Problem I'm having now though is that I keep having sound stutters every now and again. Here are my specs:

    ASUS P5Q PRO
    Intel Core 2 Quad @ 2.66Ghz
    EVGA 9800GTX+
    Creative Sound Blaster Audigy SE
    4GB DDR2 1066 RAM
    WD Caviar Blue 320GB
    Corsair 650W PSU

    On the RC I didn't seem to have any issues but once I went up to the RTM it kinda crept up on me. Tried typing uninstall and re-install of drivers, used driver sweeper also, turned of enhancements on sound, reformat of Win7, Using the most up to date drivers, just recently got the chipset drivers from ASUS and SATA drivers even though I don't think those will do much. Any ideas guys? Thanks!
     
    #1 Obmutescence, Aug 30, 2009
    Last edited: Aug 30, 2009
  2. Jihrad

    Jihrad New Member

    Joined:
    Nov 16, 2009
    Messages:
    8
    Likes Received:
    0
    Solved!

    Hi,

    I had this exact problem on my stationary computer which is now 100% SOLVED!

    I used to run Windows XP x86 without any problem, with both overclocked CPU and not. After upgrading to Windows 7 x64 the problems started...

    The solution was to upgrade BIOS to the latest version. I have a GA-965P-DS3 (rev 3.3) motherboard running an Intel Core 2 Duo E6420 @ 2,13 GHz clocked to 2,66 GHz. I had BIOS version F10, the website states in version F11 "Support Intel E6420 & E6320 CPU", i.e. my CPU.

    So after downloading and flashing BIOS to the latest version, F14, everything works like a charm! No more choppy, jerky, sluggish mouse movement. No more jerky, slow moving windows. No more jerky browsing. No more glitches in sound or anything else while performing any kind of task in Windows 7.

    I can also add that before the update I got the system to run stable in Windows 7 x64 by removing the overclocking, i.e. have the CPU run in it's native speed of 2,13 GHz. After the BIOS upgrade everything works great in overclocked mode also!

    Good luck to all of you with this weird manifesting problem under Windows 7!
     
  3. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    The suggestion from Jihrad sound very good

    But are you experienced the jerky mouse movements and browsing?

    Did you get the drivers directly from Creative?

    Are you using SPDIF or the regular input jacks?
     
  4. Jihrad

    Jihrad New Member

    Joined:
    Nov 16, 2009
    Messages:
    8
    Likes Received:
    0
    Follow up

    Follow up:

    I fiddled around with the BIOS settings and discovered that if I Enable "SATA Port 0-1 Native Mode" the problem is back... After some testing I'm pretty sure this was the problem all along. Putting it back to "Disable" doesn't matter, the problem in Windows 7 remains. The only way to fix it again is to "Load optimized Defaults" from BIOS (which is what I originally did after the BIOS upgrade). This however definately solves the problem with jerky mouse movements and sound stuttering in Windows 7 x64 for me.

    So:
    1. Load optimized defaults in BIOS (or equivalent for your BIOS)
    2. Make sure the "SATA Native mode" setting is set to "Disable", i.e. it should run in "Legacy mode".

    Good luck guys!
     
  5. Jihrad

    Jihrad New Member

    Joined:
    Nov 16, 2009
    Messages:
    8
    Likes Received:
    0
    Hi reghakr,

    See my second post after fiddling around some. I suggest you try that before flashing BIOS...

    Yes, I experienced jerky mouse movement while browsing. If I had music playing (using Spotify or Webradio) the sound started to stutter just from opening a new tab in the browser, or scrolling up and down on a site, as well as the mouse movements being jerky. In programs which uses fades I got the same reaction. Moving a regular window around in Windows 7 could get me the same reaction. Turning Aero off and moving a window to the very top and then right/left continuously (the Windows 7 snap function) also gave me the same reaction.

    All these symptoms are gone now!

    I use the regular input jacks with my onboard motherboard sound chip.

    I got the drivers for my particualar motherboard from the manufacturer website, Gigabyte.
     
  6. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Sorry, I thought Jihrad was another poster

    So it was the sound card driver that fixed the problem.

    I ask so we can pass this information to people who are experiencing the same problem.
     
  7. Jihrad

    Jihrad New Member

    Joined:
    Nov 16, 2009
    Messages:
    8
    Likes Received:
    0
    No it was the "Disable SATA Native Mode" in BIOS + "Load optimized Defaults" in BIOS that did the trick for me.
     
  8. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Thank you Jihrad:)
     
  9. clivewilliams

    clivewilliams New Member

    Joined:
    Apr 1, 2010
    Messages:
    2
    Likes Received:
    0
    Had this problem yesterday, but my solution was completely different, so I'll post it here in case anyone finds it useful.

    A Windows 7 PC exhibited stuttering audio suddenly every few minutes, when it had been working correctly for months. The Device Manager was repainting itself, each repainting coinciding with stuttering sound.

    The issue was tracked down to Windows Defender, which had switched itself on following an automatic update; switching it off (the PC is behind a solid firewall, so it isn't necessary to run defender) via Control Panel / Windows Defender / Tools / Options /Administrator / Use this Program resolved the issue.

    Hope this helps anyone who needs it,

    Clive
     

Share This Page

Loading...