Spooler Crash 0x0000002 error on network printers

Discussion in 'Windows 7 Help and Support' started by BenC, Jun 28, 2011.

  1. BenC

    BenC New Member

    Joined:
    Jun 28, 2011
    Messages:
    8
    Likes Received:
    0
    Hi guys im hoping someone here might be able to help me, im at a loss with the problem we are having and MS dont have a clue what it is.


    Problem:
    We have around 15 printers on site all running off the network, static IP's the usual setup. For some reason since we have upgraded the computers to Windows 7 64 bit the printers have been acting up.
    We have an intermittant problem where some users get an error 'unable to print with the current print setup' or when trying to install a printer they can get 'Windows cannot connect to the printer. Operation could not be completed' (0x0000002). To quickly resolve the problem we need to stop and start the spooler service, once this is done everything works fine but it repeats itself again.

    Solutions Tried:
    We have checked the drivers on the server changing them to universal drivers, changed drivers on the machines, rebuilt machines, added admin privlidges etc all which do not seem to have any effect. I have tried hotfixes from MS (KB981070-v2 & KB982728) with no result, searched the web but am unable to find a solution, our setup is Server 2003 and computers all run windows 7 64 bit.

    Can anyone help?

    Thanks
    Ben
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    You don't mention it, but are these wired or wireless connections? Since you say "some" users, have you compared machines to see if any differences are present? Do all the machines have the same type of access to the printers?

    Is it a specific printer or group of printers? Could it be a location/wiring or signal strenth problem?

    I am not familiar with corporate setups, but this Microsoft thread discusses a similar problem...maybe it will help, or at least give some options, assuming you have not already seen it.
     
  3. BenC

    BenC New Member

    Joined:
    Jun 28, 2011
    Messages:
    8
    Likes Received:
    0
    They are all wired, we have around 250 machines on site all users have the same access. Printers are all the same there are no wire problems.

    I have had a look through that topic and it has some good information but nothing that I havent tried :(
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
  5. BenC

    BenC New Member

    Joined:
    Jun 28, 2011
    Messages:
    8
    Likes Received:
    0
    Thanks Trouble I will give that a go and see how we get on.
     
  6. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    OK, and please keep us posted. There was another similar post here not all that long ago and I believe that that member finally gave up and installed a 2k8 server and moved his printer shares to that server. So I would be interested in knowing if the registry edit actually works for you.
    And by the way, welcome to the forum and thanks for joining our community.
    Regards
    Randy
     
  7. BenC

    BenC New Member

    Joined:
    Jun 28, 2011
    Messages:
    8
    Likes Received:
    0
    Will do, Im going to roll it out on 10-20 machines and see what happens. At this point anythings worth trying we are even upgrading our print server to 2008 incase its a problem with the 64bit drivers on a 32bit system, although MS say this isnt the case
     
  8. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Not likely a problem. Typically normal printer sharing only requires that the resource be available on the network and the printer server does not necessarily have to have the correct client driver for the resource, the individual driver (PCL6, 5, 5e, PostScript, 32bit, 64bit, etc.,) whatever the client machine is actually going to use to take advantage of the shared resource can be installed locally on the client machine, so that shouldn't be the issue. (Except in the case of Terminal Service printing, which can be a real bear, if the drivers (that must be installed on the server) do not match exactly the drivers installed on the client.
     

Share This Page

Loading...