SSD Samsung 830 enable disable AHCI

Discussion in 'Windows 7 Hardware' started by rapidredone, Jul 2, 2013.

  1. rapidredone

    rapidredone New Member

    May 25, 2013
    Likes Received:
    I did a major rebuild last year which included Samsung 830 series 128Gb SSD as OS, apps and programs plus 1tb WD HDD as storage.
    Samsung Magician shows that AHCI is not enabled and suggests that this is slowing the PC.
    Device Manager shows IDE ATA/ATAPI Controllers as;
    Intel(R) 7 Series/C216 Chipset Family SATA AHCI Controller.
    Registry value under HKEY_LOCAL_MACHINE/ system/ CurrentControlSet/ services/ msahci/ start/ value is 0. This has not been changed since time of installation. BIOS has not been flashed/ updated.

    System; Mobo Asus Sabertooth Z77, Drives as above, 16Gb DDR3 GSkill RAM, GTX660Ti graphics card, Ivy Bridge 3750K processor, Asus Xonar Essence STX sound card, Windows Experience Index shows all components at 7.9 except processor which is 7.6. Fractal Design Define R4
    61GB of unused space remaining on the 128Gb Samsung SSD primary drive.

    This machine has definitely slowed considerably in the past couple of months and I can't find why. Any assistance would be appreciated.
  2. trog69

    trog69 Honorable Member

    May 25, 2011
    Likes Received:
    Yes, you'll have to enable AHCI via the BIOS Menu. I have the same SSD-256gb- and I found out that I had to re-install the OS after enabling AHCI. Go to their website; they'll have a good instruction page there.
  3. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Oct 16, 2009
    Likes Received:
    It sounds like it is set up correctly, but you might verify in the Bios the SATA controller is set to AHCI. Since I have a Asus Z77 motherboard, I know it is set that way by default.

    I have a Samsung SSD but have not run the software you mention to check. But you might think about installing the Intel Rapid Storage Technology drivers for the SSD. They do not have to be run in RAID mode but should help the performance of the SSD.

    If the Samsung software report might be correct, perhaps it could be caused by a controller on the SSD, but not really sure.

Share This Page