Windows 7 Star Wars: Knights of the Old Republic

#1
[Solved] Star Wars: Knights of the Old Republic

Hey, guys.

I recently got a copy of SW:KOTOR and installed it fine, but when I went to run it, it says "This game requires DirectX 9.0c (April 2006) or higher to run. You have an older version installed at the moment."

I ran dxdiag and I have DirectX 11 (like everyone else). What could be wrong?

Thanks in advanced,
-Stephen
 


Last edited:

Highwayman

Extraordinary Member
#2
Merely get the newest dx9 installer (FileHippo.com - Download Free Software) and install it, having dx11 doesnt include all previous builds of dx in windows 7, much like vista didn't.
 


#3
Alright, I did that and it still gives me the error... =(

I don't know why it does it. Maybe KOTOR just doesn't work on W7?
 


Highwayman

Extraordinary Member
#4
KOTOR 1+2: Vista Fix & Windows 7 Report - LucasForums

you might want to check out this fix posted on the official lucasarts pages, which is said to fix windows 7 issues also, in addition since both 1 & 2 use same engine its ment to work on both.

TSL Windows Vista Fix, Knights of the Old Republic 2 Downloads, Knights of the Old Republic 2 Patches
 


Last edited:
#5
Sweet, man, thanks. That fixed it. I no longer get the DirectX error. I'll let you know if there's any other errors. =)
 


Highwayman

Extraordinary Member
#6
glad to help a fellow gamer out...was toying with playing throught it again myself, could I just ask you to edit your original post and flag to solved on the title cheers.
 


#7
Done. Thanks again.
 


#8
Hey guys new on the forum but had a questin bout this which is doing my nut in. i gt a new copy of the game lately as my old copy was scratched for over use lol. thats cheat where you put enable cheats=1 into the ini. file?well it wont let me save that on my uncles windows 7 pc wtf is up with that as have full admin rights and was able to do it on my vista at home
any help would be hot :)
 


#9
Hi guys. I have a problem with my Star Wars the Knights of the Old Republic game. Every time after I finish the quest where I first get on the Ebon Hawk after killing Davik, and it goes to the cinematic with Malak decimating Taris, my game suddenly "alt-tabs" itself and I go to my desktop where I can't get back in the game. Is there something I can do to fix this? I've tried to change my resolution on my desktop to match my game's resolution. But sit still hasn't helped. Is there anything else I can do? Let me know whenever you guys figure it out! Thanks, everyone!
 


#10
bumping up
 


Highwayman

Extraordinary Member
#11
disable fullscreen mode and use run in window mode, to see what happens
 


#12
i looked in EVERY possible options menu in KotOR, and there is not a single spot that allows me to disable or enable fullscreen mode/ windows mode. is there any where else I can do this? :((
 


Highwayman

Extraordinary Member
#13
with most games simply holding Left ALT with Enter/Return does the trick, and the same to revert back to fullscreen
 


#14
All it does is brings me back to my desktop, like Alt+Tab or the windows button would. :S Is there another command, perhaps?
 


#15
SWKotOR doesn't allow you to automatically go to Windows Mode, so I had to find something on the internet to edit this and so I did. The Windows mode thing was correct. I really appreciate your help, there! Thanks!
 


#16
Hi ladies and gentlemen. I've been reading this thread and it seems as though people here know what they're talking about. So for the problem.

I recently re-installed Knights of the Old Republic on my Windows 7 Ultimate laptop. I have patched the game enough to be able to play it with no problems, yet. I have loved this game since it came out and I just wanted to run through it again for nostalgia sake. I have changed my .ini file to enable cheats correctly (I think), but when I hit my "`" button on my keyboard, nothing happens. I was wondering if this was a common issue and how to remedy this situation. Thank you for your time

Kevin
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.