Windows 7 Steam and HL2 Episode 1

#1
Windows 7 x64 RC
Ati (latest catalysts drivers)
Asus P5Q Pro board

I am having problems getting Half Life 2 Episode 1 to run in W7 x64. Steam starts fine and the game launches (I see the Valve logo etc) but when it tries to go any further it crashes back to desktop. Aero Peek is showing the game as trying to load (still pic before the menu) but if I try to go back into it the games crashes out completely. I previously has osme success using the -windowed launch option but now even that is failing. Has anyone any ideas I could try?
Have tried running HL2 in various compatibility modes and also Steam in the same
 


#2
works fine here, sorry
 


#3
Windows 7 x64 RC
Ati (latest catalysts drivers)
Asus P5Q Pro board

I am having problems getting Half Life 2 Episode 1 to run in W7 x64. Steam starts fine and the game launches (I see the Valve logo etc) but when it tries to go any further it crashes back to desktop. Aero Peek is showing the game as trying to load (still pic before the menu) but if I try to go back into it the games crashes out completely. I previously has osme success using the -windowed launch option but now even that is failing. Has anyone any ideas I could try?
Have tried running HL2 in various compatibility modes and also Steam in the same
Did it work no issues in your Vista ?
 


#4
Windows 7 x64 RC
Has anyone any ideas I could try?
Have tried running HL2 in various compatibility modes and also Steam in the same
If it worked fine in Vista x 64, then it could help if you install it Vista SP 1 compattible (i.e. make your installer file vsp 1 compattible). Can't guarantee, but I know this way people install and play certain games. As for me, I use Vista x 64 as the primary OS, including for PC games.

Good luck.
 


#5
I have a dual boot with Vista 32 and it works perfectly in that. Will try installing steam in compatibility mode this evening and report back
 


Matt

Senior Member
#6
Try adding -32bit to the startup options. I think HL2 and HL2EP1 have the option to run an old 64bit exe of the game, which isn't that stable.
 


#7
ok, tonight I have tried the following: Uninstalled Steam and reinstalled in compatibility mode, downloaded directx updater program, uninstalled and re-installed HL2 Episode 1 via steam client, removed and reinstalled ATI catalyst 9.6 x64 Win 7 drivers and set the game to -32bit mode. None of them have made any difference, still bombs straight to desktop when it gets past the Valve logo. Only way I can get into the game is to set to a 4:3 resolution using the -height 1024 -width 768 switches, but as soon as I switch to any 16:10 or 16:9 resolution, its back to the desktop. Really starting to lose the rag with this now
 


#8
update: Rebooted back into Vista to make sure, and game ran perfectly right away, so it's definitely a Win7 issue. It is also not just steam, have now tried several other games and all of them do the same, bomb straight back to desktop as soon as they try to go fullscreen. I have removed the ATi driver completely and reinstalled it but no difference
 


#9
Also tried running Smartclose which closes ALL running programs except for protected system processes and still same crash to desktop
 


#10
When I first tried to install steam it said some kind of error and terminated. I right clicked on the steam ican and said run as administrator, and it said something about 64 mode and updated. After that every thing workrd with occasional notes it was in 64 bit mode.

Joe
 


#11
definitely a win7 issue, have cleaned and reinstalled Steam and HL2, swapped the Ati card out for a much lower powered Nvidia card and still exactly the same issue
 


#12
Windows 7 x64 RC
Ati (latest catalysts drivers)
Asus P5Q Pro board

I am having problems getting Half Life 2 Episode 1 to run in W7 x64. Steam starts fine and the game launches (I see the Valve logo etc) but when it tries to go any further it crashes back to desktop. Aero Peek is showing the game as trying to load (still pic before the menu) but if I try to go back into it the games crashes out completely. I previously has osme success using the -windowed launch option but now even that is failing. Has anyone any ideas I could try?
Have tried running HL2 in various compatibility modes and also Steam in the same

i had the same problem...
solved like this....
go to your hl2 episode on directory - exampe (c:\Program Files (x86)\Steam\steamapps\[username]\half-life 2 episode one)
right mouse button click on properties---->Compatibility
In Settings area TAB(set) "Disable display scaling on high DPI settings" ON
Click Apply OK
Run Lunch Game from Steam\Game menu
Worked at my comp. phenom2x4/asusm4a77td_pro/4gbddr1333/rad4850_512/win7
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.