Windows 7 Steam not starting

bassfisher6522

Essential Member
#1
Every time I want to log on to steam and play any of my games, steam won't start. Except when I first turn my computer on. I can click on steam and it will start and I can play my games just fine. The I come back later, say 2 hours, I click on steam icon and nothing happens. I have to go into task manager and turn off/close the steam.exe process. Then click steam icon and it starts up just fine. Some times I wont even start steam at all and go to click icon and no go....but it's in the task manager running in the processes tab....so how does that happen. I've closed out steam and restarted it sometimes that works. I've un-installed steam and reboot then re-installed steam then the long process of downloading games again....that doesn't work....same problem. Any ideas.
 


Captain Jack

Extraordinary Member
#2
Hello Mate,

Not just Steam most of the Programs if you have multiple instances i.e. multiple process running it will not open the Program. Just click it once and wait maybe it's just taking time it load. When we double click on it then Program will fail to launch. Also after you close the Program after a minute or two check if it's still it's running then it might something it tired up with it maybe an Antivirus or scan Malware scanner etc.

Reboot the System in Selective Start-up Run Selective Startup using System Configuration make sure all the security is disabled then test it. I assume your using the legit version of the game. :p

Hope this helps,
Captain
 


bassfisher6522

Essential Member
#3
It is only steam, but when steam starts all my games play perfectly. I do just click on the icon just once. I also tried the icon form my desktop, start menu and from steam in programs list. When it doesn't start, the steam.exe is all ready running in the processes tab in taskmanager. How can that be if I haven't started it? I ran my anti virus along with malware, spyware and adware scanners and all come back clean. Yes the steam account is legal and I'm in good standing I've paid for all my games and have downloaded all of them through steam. Like I said, when computer is first turned on I can start steam and it works great, I exit out of steam, checking notification area and Icon is gone....let pc hibernate then come back a few hours later, start steam and nothing, check process tab in taskmanager and there the steam.exe sits. I stop that process and then start steam and bingo bango it works...So why is the steam.exe file showing up in the process tab with out being started.
 


Captain Jack

Extraordinary Member
#4
Try Selective Startup as I suggested ! It may work. Not not a gamer so idea how it works. Just this is a a odd behavior from few Programs. Like Outlook etc.
 


bassfisher6522

Essential Member
#5
Selective Services tip was a no go....
 


JimM

New Member
#8
Also check your network card isn't going to sleep with power saving options.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.