Steam thinks I'm running it in compatibility mode

Discussion in 'Windows 7 Help and Support' started by Obmutescence, Aug 31, 2009.

  1. Obmutescence

    Obmutescence New Member

    Joined:
    Aug 30, 2009
    Messages:
    12
    Likes Received:
    0
    Hi guys. So yesterday I went out and bought a new Hard drive for my computer. Installed my windows 7 RTM, started loading all my programs up...then I ran into Steam. Now here's where my problem is, error message came up around the lines of "Do not run steam in compatibility mode, please turn off any compatibility settings for steam.exe and start again." So I hit cancel to get rid of the warning, and now I can't use steam cloud or find any game info for games that my friends are in. Tried these things so far: Made sure it wasn't on compatibility mode(duh). Deleted the registry key for compatibility settings found here: Fix: Steam thinks its running in compatibility mode. Uninstall and re-install of steam. Finally I went through, turned off UAC and ran it in every compatibility mode possible and switched it off, which finaly fixed it.

    The issue came back tonight and I just did a reformat, still the same exact thing. Tried everything again as above, still no luck, thinking about going back to Vista 64 bit if this can't get resolved.

    Specs:

    Intel Core 2 Quad 2.66Ghz
    4GB DDR2 1066 RAM
    9800GTX+
    WD Caviar Blue 320GB
    Corsair 650W PSU

    Windows 7 6.1.7600 Build 7600

    Any ideas guys? Thanks!
     
  2. Mike

    Mike Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Jul 22, 2005
    Messages:
    8,488
    Likes Received:
    783
    I am using Steam but not extensively. I have one game for it - Fallout 3. I have had no compatability issues, but then again, it was also slow to load. I have only loaded it once maybe since the install... just to download and install the game. This is very strange... Perhaps a bug with Steam itself?
     
  3. Obmutescence

    Obmutescence New Member

    Joined:
    Aug 30, 2009
    Messages:
    12
    Likes Received:
    0
    Not sure, there are several threads about it floating around the internet that I've looked into, but none of the suggestions on there work. It also seems to be an issue that can occur on Vista as well but is less likely. The weird thing is this didn't happen on my old hard drive, but I doubt it would be a hard drive problem per say.
     
  4. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,806
    Likes Received:
    1,563
    Hi Obmutescence,
    I tried googling round for an answer (I use steam and it runs without a hitch, with or without compatibility mode) and like you say above, there are plenty of threads around about this but it's not exclusive to 7 or vista. It seems XP has had this problem too and many of the 'fixes' sound like the ones you've tried already... (basically unticking the compatibility tab)
    If I were you, I'd google for fixes and just go through each one until you find one that works for you.. Sorry it's a bit of a lame answer but at present it's the only thing I could think of suggesting....:confused:
     
  5. Obmutescence

    Obmutescence New Member

    Joined:
    Aug 30, 2009
    Messages:
    12
    Likes Received:
    0
    That's ok man, that's what I've been doing with the googling before I made this thread. The thing is it didn't happen my old hard drive, but it wouldn't be a hard drive problem. Might do some more research, if it doesn't work I might just go to vista for now. :(
     
  6. Obmutescence

    Obmutescence New Member

    Joined:
    Aug 30, 2009
    Messages:
    12
    Likes Received:
    0
    Well I got my old Seagate HD back in my computer which has no problems with Steam, so I guess my experience with Western Digital isn't off to a good start.
     
  7. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,806
    Likes Received:
    1,563
    Wow...so it was the HD after all.. Glad you got things fixed :)
     
  8. Revolexis

    Revolexis New Member

    Joined:
    Sep 6, 2009
    Messages:
    4
    Likes Received:
    0
    I'm having exactly the same issue with Steam, but it doesn't seem to have anything to do with the hard drive (mine is a samsung spinpoint F1) but I suppose I shouldn't rule it out. I played on steam yesterday fine, then when I was done and exited Steam I got the same Windows message auto-switching a compatibility mode on that doesn't seem to exist in any settings! I'm running Windows 7 Pro RTM 64 Bit and so far it's been running fine, but if I can't access all my Steam games it will be a real shame. Any advice out there?

    Scrap that I found an answer and it frigging works! *PELVIC TRUST*

    http://www.edugeek.net/forums/gaming/39417-fix-steam-thinks-its-running-compatibility-mode.html
     
    #8 Revolexis, Sep 8, 2009
    Last edited: Sep 8, 2009
  9. Obmutescence

    Obmutescence New Member

    Joined:
    Aug 30, 2009
    Messages:
    12
    Likes Received:
    0
    Yea that's the fix I tried, didn't work for me though.
     
  10. Revolexis

    Revolexis New Member

    Joined:
    Sep 6, 2009
    Messages:
    4
    Likes Received:
    0
    Ah fair enough! Well I'm glad we could all get our issues fixed! :D
     
    #10 Revolexis, Sep 9, 2009
    Last edited: Sep 9, 2009
  11. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,806
    Likes Received:
    1,563
    Thanks for the update Revolexis... It may help others in the future..:)
     
  12. Rappiddkill

    Rappiddkill New Member

    Joined:
    Jan 4, 2012
    Messages:
    2
    Likes Received:
    0
    I unchecked the compatibility box under the compatibility tab and it still doesn't work and still gives me the error message!

    please help!:-#
     

Share This Page

Loading...