Strange graphics problems!?!

Discussion in 'Windows 7 Graphics' started by SteelSLasher, Mar 1, 2009.

  1. SteelSLasher

    SteelSLasher New Member

    Joined:
    Mar 1, 2009
    Messages:
    40
    Likes Received:
    2

    EDIT:Fixed:
    Just installed graphic drivers for Geforce 6! No more flickering! YAY!

    EDIT:EDIT:BROKEN: Still need help
    At random times all the graphics seem to go haywire and crack up and it looks a bit like Google Earth in OpenGL on Win7. I cant print screen it because it looks fine in print screen for some reason. Luckily I took a picture on my camera and used that instead.

    [​IMG]
    [​IMG]

    I cant seem to find any other people with the problem, I was able to tame it slightly by installing the WDDM 1.1 drivers but it started to come back.
     
    #1 SteelSLasher, Mar 1, 2009
    Last edited: Mar 2, 2009
  2. SteelSLasher

    SteelSLasher New Member

    Joined:
    Mar 1, 2009
    Messages:
    40
    Likes Received:
    2
    Just bumping this topic since its still not fixed kind of, sorry for any rule breaking or anything.
     
  3. Radenight

    Radenight New Member

    Joined:
    Nov 16, 2008
    Messages:
    4,525
    Likes Received:
    108
    I'd suggest using the correct driver.. that is to say the most appropriate driver for your gpu.. as in the latest Windows Vista driver (they are supposed to work in 7) or the latest Windows 7 driver if available.. ;) By the looks and sounds of it, you don't have the correct driver for your gpu installed.. Also, have you checked device manager to see if there are any problems in there?.... Just because something says it's for Windows 7 doesn't necessarily mean it's the most appropriate driver for your particular hardware.. ;) Curious, what is your gpu?
     
    #3 Radenight, Mar 2, 2009
    Last edited: Mar 2, 2009
  4. SteelSLasher

    SteelSLasher New Member

    Joined:
    Mar 1, 2009
    Messages:
    40
    Likes Received:
    2
    I have installed 3 different drivers, the first was the WDDM 1.1, the second was the Forceware for Vista (cant remember where or why I got it but it kind of helped) then I went to the Nvidia site and downloaded the vista driver for Geforce 6 (my graphics card) yet randomnly the graphics will start to flicker and "corrupt".

    A good thing about the Geforce 6 driver is that it will crash and restore the graphics to normal although the crash seems to occur randomnly but so does the flickering so it is an improvement. It also intriguing that a print screen looks completely normal whereas the screen shows a large difference.

    I have "sent" a "report" to M$ via the feedback button (whether they do anything i do not know). I just hope the actual finished product will find drivers like in Linux (I heard linux will seek and download correct drivers???) but yeah it seems to be just Windows 7 incompatibility with some Vista products.

    Plus, whats happened to portable apps, its not as if Windows 7 cant handle portablised Pidgin.
     
  5. Radenight

    Radenight New Member

    Joined:
    Nov 16, 2008
    Messages:
    4,525
    Likes Received:
    108
    So you've installed 3 different gpu drivers? Ok, well did you uninstall each one before installing a new one? If you don't then your just asking for problems... I'd suggest uninstalling all 3 and starting fresh. Install the latest available Windows Vista driver from nVidia and OR if they do have a Windows 7 driver out (which I'm pretty sure they do) then install that instead.. ;) Don't install 3 different ones though.. they aren't going to work well with each other plus you don't need 3 different drivers to get a gpu working properly.. normally one will do it.. ;)
     
  6. SteelSLasher

    SteelSLasher New Member

    Joined:
    Mar 1, 2009
    Messages:
    40
    Likes Received:
    2
    the flickers have become less frequent now and only occur when i use opengl apps (not just the app but the entire screen) but it fixes itself after a while.

    in fact however "incorrect" it is to install 3 GPU drivers it seems to work on my system which is strange and if i did uninstall one i am worried it might collapse on itself
     
  7. Radenight

    Radenight New Member

    Joined:
    Nov 16, 2008
    Messages:
    4,525
    Likes Received:
    108
    I don't think I'd classify having 3 gpu drivers installed as 'working' if your still having graphic related problems.. ;) I still say you'd solve them all if you simply uninstalled all 3 and then just install 1.. :) It's not going to make your system collapse on itself.. hahaha But to each his own.... Glad to hear it's working a little better at least
     
  8. SteelSLasher

    SteelSLasher New Member

    Joined:
    Mar 1, 2009
    Messages:
    40
    Likes Received:
    2
    its been 48 hours without flickers!!! GO TRI-DRIVER SYSTEM!!!

    just uninstalled the drivers... wait a minute i cant reinstall any of them now???

    "The NVIDIA Setup program could not locate any drivers that are compatible with your current hardware. Setup will now exit."

    I think I was right about the uninstalling problems, now i am stuck in win 7 basic. might try downloading direct x
     
    #8 SteelSLasher, Mar 4, 2009
    Last edited: Mar 4, 2009
  9. hearry

    hearry New Member

    Joined:
    Mar 17, 2009
    Messages:
    2
    Likes Received:
    0
    i have identical problem with 6800 card, when aero is disabled. while areo is enabled everything works great exept on login screen, guess aero cant be enabled there. vga driver works ok but then i cant have more than 60hz refresh rate.
     

Share This Page

Loading...