SVCHOST.EXE (netsvcs) causing cpu running at 100%

Discussion in 'Windows 7 Help and Support' started by azance, Jul 23, 2010.

  1. azance

    azance New Member

    Joined:
    Jul 23, 2010
    Messages:
    2
    Likes Received:
    0
    at the start of my computer ranging anywhere from 10min-3 hours( and reoccurs sometimes), both my cpus stay at 100%, and when i looked at performance monitor, it showed that SVCHOST.EXE (netsvcs) was using 40-50 percent of the cpu. The high cpu usage also messes up any type of audio(causing crackles and pops).
     
  2. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,455
    Likes Received:
    268
    It might help to see what is running at startup and autoruns is superior to msconfig for this as it gives you much more information and enables you to select/deselect items to test for any changes. Get a copy of autoruns (free from here):

    Autoruns for Windows
     
    cybercore and (deleted member) like this.
  3. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    Hello and Welcome.

    Svchost.exe (netsvcs) is used to launch many dll based services on your PC in one process and itself being located at C:\WINDOWS\System32\ should be the normal part of your Windows. Some of these normal windows services use network connectivity to function properly. Aparently one of the dll based services is "choking". To try to find out which, use a very handy Process Explorer for detailed information.
     
  4. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    If you have VMWare installed, it is the problem. I've seen this recently a few times.
     

Share This Page

Loading...