Synaptics touchpad - buttons have merged?

#1
Hi

I have a 2330s HP laptop.

Everything worked fine till 1 hour ago or something like that.
Then everytime i press the left button it will "left button-click" AND "right button-click" and it actually does the same with the right button.

I have tried to see if the settings have been messed up, but no. Everything is normal. I have tried changing the usage of each button - like changing the right button assignemt to do a "down arrow" instead of a "special click", but then it just does a "left button-click" and the "down arrow"...

I have tried uninstalling the driver, updating the driver, rebooting the computer, changing the settings, used windows recovery...

I really don't know what to do.

When I plug in a USB mouse, that works fine. No problems there. It is just the touchpad buttons...
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
Do you show any updates in Windows Update?

Rebooting the computer normally clears out many problems, but since yours did not, does the Touchpad applet accurately make changes you want? Do you have any other mouse type devices installed?
 


#3
It didn't update anything. It has been days since it updated the last time. No I don't think it is that.
 


#4
Well... I tried updating EVERYTHING on windows and this morning. It worked again. :S
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.