System can't start and 'repairs' itself by restoring system to a strange state

Discussion in 'Windows 7 Help and Support' started by JordiB, Jun 13, 2009.

  1. JordiB

    JordiB New Member

    Joined:
    Jun 13, 2009
    Messages:
    4
    Likes Received:
    0
    After I have installed some program (FlatOut 2) it asked me to reboot, so I did. After telling the computer to reboot, I walked away from my computer for quite some time (probably over an hour) and when I came back, I got the login screen as expected. However, it appeared that FlatOut 2 was not installed and after some more usage of my computer, I found that some downloaded files and desktop shortcuts were missing. After a while, it also seemed like my computer became a little slow, so I tried to restart it, naively hoping that it would make things faster.
    When it tried to restart, I got a dialog that said that Windows could not be started, and that it was going to look for problems and repair them. This took over half an hour and since no headway seemed to be made, I walked away again for maybe 10 minutes and when I got back I could log in again.
    To my very big surprise, there were now icons on my desktop from the time before the problem started, but not extra ones that I made after. It seems to me now that Windows probably couldn't start both times that I rebooted and that it did a system restore or something. What puzzles me however, is that there are apparently two different valid restore points. If that is the case, the last one should always be used and there should be no problem.
    This is all speculation on my part and I would appreciate it if someone could help me out with this issue, because right now I'm kind of affraid to turn my computer off, because I have no idea what it will be like after I restart it.

    Thanks!
     
  2. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Hello and welcome,

    Could you clarify this statement:

    Did you try running the program? If I install something I immediately execute and use it.:)
    How old is this program?

    You can use the last Restore point, but that will wipe out anything you installed prior to this program
     
  3. JordiB

    JordiB New Member

    Joined:
    Jun 13, 2009
    Messages:
    4
    Likes Received:
    0
    What I mean when I say it wasn't installed (anymore) is that at least after the reboot, there were no files to execute (the folder that I installed into didn't exist), I didn't really check before rebooting, but when it had finished there was a shortcut and executing it gave some error (and not the error you get when the program the shortcut refers to doesn't exist). FlatOut 2 is approximately 3 years old by the way.

    To clarify: I didn't use system restore. However, I suspect that Windows may have automatically resorted to it when it saw no other way out, but I don't know this for sure.
     
  4. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    I guess we'll never know for sure what happened initially, but yes, the repair probably did do a restore and that's why you saw the extra items.

    I'd look up the programs' site a see if it's Windows 7 compatible.
     

Share This Page

Loading...