System freeze on repair attempt

Discussion in 'Windows 7 Help and Support' started by phr3akstorm, Dec 1, 2009.

  1. phr3akstorm

    phr3akstorm New Member

    Joined:
    Dec 1, 2009
    Messages:
    8
    Likes Received:
    0
    Well, I have stepped in it this time and boy could I use some help.

    Setup an XP/7 dual boot on two partitions on same drive. All good.
    Removed XP boot entry with easybcd. All good.
    Set 7 partition to Active. All good.
    Booting to 7 worked fine with the old XP partition still on the disk.
    Using GParted, removed the XP partition and grew the 7 partition.
    Upon restart got the expected error not able to find the windows partition, please insert your install CD and repair.
    Proceeded to to do just that BUT, the install hangs at the Starting Windows screen. Occasional HDD light flickers. Flag still pulsating. I left it for 2 hours with no change.
    Pulled the drive and put it in a Vista machine. Vista boots but goes to black screen after the progress bar goes away just before you would get the login screen.
    Booted a Fedora 10 live CD and tried to access the drive to remove files I need. (yep I backed them up but the 7 recovery disk locks up as well in the same spot the install disk does). Fedora says it can't mount the drive as the ntfs file system is reporting it's in use. Possibly due to an improper shutdown.

    Any help please. Normally I would reformat and reinstall but I don't have a way to get my files back if I do that even from the image as the image was for two partitions on the same drive.

    Thanks in advance.
     
  2. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Previously to this mess,. could you remove the XP partition using Disk Management..........how was it marked.

    How large did you make the new partition using GParted?
     
  3. phr3akstorm

    phr3akstorm New Member

    Joined:
    Dec 1, 2009
    Messages:
    8
    Likes Received:
    0
    I was able to make the 7 partition the active partition and unallocate the XP partition space with 7's disk utility. However, it would not let me remove the XP partition, or expand the 7 partition even after unallocating the XP space. Thats when I thought "Ill just use GParted". Done it before no issues. So I expanded the 7 partition with GParted to the full drive space which is just shy of 120Gb.

    Since my first post I was able to force a mount on Fedora and copy the important files. Whew! I would still like to get the 7 back up however without formatting that drive and starting over. Even if that's possible since I cant get anything to boot with it installed. Figured I would do it w GParted but look where that got me. :)

    Thanks again.
     
  4. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Is the Windows 7 partition marked as Boot,. System and pagefile also

    Since you've changed the partition space, you may have to re-install.

    You should be able to install right over it,. no need to perform a clean install
     
  5. phr3akstorm

    phr3akstorm New Member

    Joined:
    Dec 1, 2009
    Messages:
    8
    Likes Received:
    0
    Unable to run Win 7 Startup disk. It locks up at the Starting Windows screen with the pulsating flag. Left it for 2 hrs earlier with no change.

    Yes the 7 partition is the boot partition.
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    When you say Windows 7 Startup Disk, what exactly do you mean? Your system will not boot to the DVD?

    Your Win 7 Partition probably does not have the necessary boot files.

    I just went through this to test. Loaded XP then Win 7. Removed the XP partition which left the Win 7 partition with a 40 G offset. I got the Win 7 partition to boot fine using the Startup Repair. But I wanted to test moving the partition, and used GParted to do so, but it left my system unbootable. Someone the other day used Acronis, which seemed to have done the same thing as GParted.

    With the Win 7 install DVD in the DVD drive, the boot up went straight to the DVD for booting. From there I choose the Startup repair and watched the drive spin for 2 hours. System was still not bootable, so I started Setup Repair again. This time it ran for 3 hours, but at the end, the drive was bootable. How long yours may take might depend on the partition or drive size. I was using a 90 G partition on a 1 TB drive.

    The system ran a chkdsk upon restart and the OS is back to normal now.
     
  7. phr3akstorm

    phr3akstorm New Member

    Joined:
    Dec 1, 2009
    Messages:
    8
    Likes Received:
    0
    That was my plan...to run the repair...however, I can't even get that far. By startup disk I mean the install disk. Fortunately with a linux system I was able to mount the dirve with a forced mount (wouldn't mount normally) and get the data I needed. Still can't get the install disk to go past the Starting Windows screen.

    Did the exact same thing to a buddys pc last night and today his would boot the repair console but when all was done it told him his windows was not a legit copy (it is). So he didn't have anything on his pc to loose and we just formatted and reinstalled.

    But just as you described. After repartitioning with GParted they system says it cant find the windows partition and to enter the install disk.

    Got to run a few errands. Guess I'll just let it work and see if the next screen pops up when I get back. Otherwise it's a format and reinstall for me.
     

Share This Page

Loading...