System Restote win 7 x86

#1
I have got an error with system restore as follows;

System Restore did not complete successfully. Your computer's system files and
settings were not changed.


System Restored failed to extract the original copy of the directory from the restore
point.
Source: %System Root%\registration
Destination: ComPlusStaging

I have tried several restore points and still get the same error. Any help would be greatly appreciated.

Thanks in advance
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#2
Hi Silver88,

1. Check the Volume shadow copy service in services window. To check follow these steps:
i. Click Start and type services.msc in the search box
ii. Search for the Volume shadow copy service
Please let us know the Status and start up type. Make sure the start- up type is automatic
Steps to set the services to automatic
i. Search for the service
ii. Right click on the service
iii. If the service is stopped then Start the service
iv. Select Properties
v. And in the Start-up type select Automatic

2. Disable the firewall/ anti-virus temporarily installed on your computer and then check if the issue still persists. If the issue resolves, then you might need to uninstall the software and reinstall it back or change the settings and check.
 


#3
Thanks for the speedy reply kemical, did as you suggested but still getting the same error,
any other thoughts? would it be worthwhile resetting system restore (ie setting drives not to be covered by system restore then setting them to be covered) and trying again?
This is starting to drive me quietly up the wall!!:(

Cheers
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#4
Do your backups or restores effect anything other than your own computer, perhaps some network location or external drive is involved?

If you check the System Protection settings, do you have System Protection turned on for a drive other than your primary partition?

On the configuration page, how much disk space are you allowing and how big is your drive/partition?

This is probably what you are referring to, but the Delete button looks like it wipes the system restore clean which might help.

Other folks resolved the problem by doing a repair install, if you decide to go that way.

Is anything encrypted on your system, or any special permission situations?
 


#5
Hi Saltgrass, thanks for the reply

To answer your questions;
Only my own computer C=windows drive and D= programs

Yes my D programs drive

C drive 9.26 Gb & D drive 3.69 Gb

As far as I am aware there are no special permissions or encrypted files on my system

Think best thing to try is delete all restore points and set up with active partition "C" drive only

What do you think?
Cheers,
silver88
 


Elmer

Extraordinary Member
#6
Have you tried to use a system restore point while in safe mode? Sometimes when I do this I get an 'update failed' error message but when I reboot to normal mode it tells me 'system has been successfully restored'. Go figure!!

System restore primarily looks after the system, so I wouldn't bother with anything other than my main (system) C:\ partition. But you mention D:\ your Programs Drive, in my case any software is installed to C:\.

Generally recommended that system restore is set to 10% of disk or partition capacity.

But even better to back up with something like Macrium Reflect to make a backup image of your setup.
 


Joe S

Excellent Member
#7
Are you using a third party defragger? They can cause problems with system restore.
Joe
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#8
As well as the above suggestions you could try opening the advanced boot options (F8 whilst booting) and then choosing 'Last good known configuration'.

See the link provided for more information: Using Last Known Good Configuration
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#9
The space you have allocated seems to be about the same as mine, but as mentioned above, all of my stuff in in the C: partition.

I am not sure I remember correctly, but it seems that one person had a problem and found that there was a file or folder that pointed to another location on his system. Not exactly sure why that was causing problem, but perhaps the backup could include the necessary files. When the offending folder was removed or changed in some manner, the restore worked. I am assuming you have not moved your libraries, which may not be a problem even if you did.

But I would do as you suggest. Bring the restore down to its most basic form and try a backup. I would have to think something is interfering, or you have a basic system file problem or registry problem, assuming you can't get it working using the above suggestions.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.