SYSTEM_SERVICE_EXCEPTION while playing BF3

Discussion in 'Windows 7 Blue Screen of Death (BSOD)' started by KGrow, Jan 20, 2012.

  1. KGrow

    KGrow New Member

    Joined:
    Jan 16, 2012
    Messages:
    10
    Likes Received:
    0
    Hello, I've been having a recurring BSOD issue for the past couple of months. Every time that the BSOD window appears for long enough to read what's happened it has been a "system_service_exception". I've been reading a few threads on this forum and tried applying some advice I've read but I figure it's about time I started my own thread since I havn't been able to fix this issue. I've read it can be something to do with admin privileges, however it happens when I'm logged in as the administrator. I have updated my motherboard BIOS, and every other component has been updated to the best of my abilities, although there may be some old drivers that I don't know how to update. I even uninstalled AVG (using the AVG removal tool), although I have installed avast! in it's place. I thought it might be a RAM issue, but I tweaked my motherboard's RAM settings because my G.SKILL RAM is rated at ddr3-1600 9-9-9-24 1.5v but on auto the motherboard was running it at 1333 9-9-9-24 1.65v. After all of these changes I still get the BSOD once in a while, and always in the middle of playing BF3 online, for anywhere from 5 min after starting the game to a few hours after starting. I hope I have provided a decent history and enough information for an eventual cure.. attached I have included all of the .dmp files from my minidump folder, the cpuid html report and screenshots, and the RAMMon html report. -->View attachment files.zip Thank you very much for your time and help! -Andrew EDIT: I put "BS3" in the title... I meant "BF3" (Battlefield 3). :p
     
    #1 KGrow, Jan 20, 2012
    Last edited by a moderator: Jan 20, 2012
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Hello and welcome to the forum.
    Just a thought, use your BIOS setup utility to
    Enable XMP
    and
    Disable Cool and Quiet
    Consult your MoBo Documentation (manual)
    Easily done, easily reversed just a test to chase a theory.
    Thanks
    Randy
     
  3. KGrow

    KGrow New Member

    Joined:
    Jan 16, 2012
    Messages:
    10
    Likes Received:
    0
    Hi Randy,

    I have disabled Cool and Quiet, however I can't find anything about XMP in my MoBO documentation and have sifted through the BIOS options. My mobo is an Asus M5A97.

    Andrew
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Sorry, my bad, sent you on a wild goose chase. XMP (Extreme Memory Profile) is an Intel Standard and AMD uses a different standard BEMP (Black Edition Memory Profile) and is not available on all MoBo configuration.
    However, I would still like to know if the Computer is acting any better with Cool and Quiet disabled.
     
  5. KGrow

    KGrow New Member

    Joined:
    Jan 16, 2012
    Messages:
    10
    Likes Received:
    0
    I'll have to get back to you on that... I have only ever had the problem while I am playing Battlefield 3.
     
  6. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Additionally when you have time you have an old network adapter driver which needs your attention
    athrx.sys 7/8/2009 Either an atheros card or a card from another manufacturer using an atheros chipset if you can identify it you will likely be able to update it from here ATHEROS drivers for Microsoft Windows (Atheros?????)
    and while you are at it go ahead and catch up your Realtek Network adapter driver from here Realtek labeled Win7 and WinServer 2008 R2 Driver 7.050 2012/1/20 719k
     
  7. KGrow

    KGrow New Member

    Joined:
    Jan 16, 2012
    Messages:
    10
    Likes Received:
    0
    I updated both, thanks for the heads up!

    On a sadder note, I had another BSOD while playing BF3. This time about 5 minutes after starting multi player, however I played for some hours last night with no problems whatsoever! Anyways, here is the latest dmp fileView attachment latest_dmp.zip .

    P.S. just an FYI The BSOD occurred before I updated both drivers.

    Thank you
     
  8. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    The latest dump was practically identical to the immediately previous dump
    EXAMPLE:
    Blaming ntkrnlmp.exe (critical system file and not likely the actual cause at all)
    Code:
    BugCheck 3B, {c0000005, fffff80002c8da9b, fffff8800a7d40b0, 0}
    Probably caused by : ntkrnlmp.exe ( nt!KiInsertTimerTable+13b )
    Followup: MachineOwner
    SYSTEM_SERVICE_EXCEPTION (3b)
    An exception happened while executing a system service routine.
    Arguments:
    Arg1: 00000000c0000005, Exception code that caused the bugcheck
    Arg2: fffff80002c8da9b, Address of the instruction which caused the bugcheck
    Arg3: fffff8800a7d40b0, Address of the context record for the exception that caused the bugcheck
    Arg4: 0000000000000000, zero.
    Debugging Details:
    EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.
    FAULTING_IP: 
    nt!KiInsertTimerTable+13b
    fffff800`02c8da9b 488b42f8        mov     rax,qword ptr [rdx-8]
    CONTEXT:  fffff8800a7d40b0 -- (.cxr 0xfffff8800a7d40b0)
    rax=0000000000000003 rbx=fffffa800c3c3120 rcx=0000000000000003
    rdx=ffbffa800993af10 rsi=0000000000000ac0 rdi=fffff88002fd5180
    rip=fffff80002c8da9b rsp=fffff8800a7d4a90 rbp=fffff88002fd7e48
     r8=ffffffffffffffff  r9=0000000000000046 r10=fffff88002fd5180
    r11=00000000002f5b00 r12=fffff88002fd7e48 r13=0000000000000001
    r14=0000000000000000 r15=0000007b88174bb2
    iopl=0         nv up ei ng nz ac pe cy
    cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010293
    nt!KiInsertTimerTable+0x13b:
    fffff800`02c8da9b 488b42f8        mov     rax,qword ptr [rdx-8] ds:002b:ffbffa80`0993af08=????????????????
    Resetting default scope
    CUSTOMER_CRASH_COUNT:  1
    DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
    BUGCHECK_STR:  0x3B
    PROCESS_NAME:  PnkBstrB.exe
    CURRENT_IRQL:  2
    LAST_CONTROL_TRANSFER:  from fffff80002c87092 to fffff80002c8da9b
    STACK_TEXT:  
    fffff880`0a7d4a90 fffff800`02c87092 : fffffa80`0c3c3060 00000000`00000001 00000000`00000000 00000000`00000003 : nt!KiInsertTimerTable+0x13b
    fffff880`0a7d4af0 fffff800`02c88742 : 00000000`00000001 fffff880`049800dc fffffa80`00000046 fffff880`0a7d4ca0 : nt!KiCommitThreadWait+0x332
    fffff880`0a7d4b80 fffff800`02f784de : fffffa80`0c3c3060 00000000`00000000 00000000`014f0a00 fffff800`00000046 : nt!KeDelayExecutionThread+0x186
    fffff880`0a7d4bf0 fffff800`02c80ed3 : 00000000`014f0ade fffff880`0a7d4c01 ffffffff`ffffb1e0 00000000`7efad000 : nt!NtDelayExecution+0x59
    fffff880`0a7d4c20 00000000`73782e09 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
    00000000`0096f0f8 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x73782e09
    FOLLOWUP_IP: 
    nt!KiInsertTimerTable+13b
    fffff800`02c8da9b 488b42f8        mov     rax,qword ptr [rdx-8]
    SYMBOL_STACK_INDEX:  0
    SYMBOL_NAME:  nt!KiInsertTimerTable+13b
    FOLLOWUP_NAME:  MachineOwner
    MODULE_NAME: nt
    IMAGE_NAME:  ntkrnlmp.exe
    DEBUG_FLR_IMAGE_TIMESTAMP:  4e02aaa3
    STACK_COMMAND:  .cxr 0xfffff8800a7d40b0 ; kb
    FAILURE_BUCKET_ID:  X64_0x3B_nt!KiInsertTimerTable+13b
    BUCKET_ID:  X64_0x3B_nt!KiInsertTimerTable+13b
    Followup: MachineOwner
    BugCheck 3B / SYSTEM_SERVICE_EXCEPTION (3b) been seeing this a lot associated with BF3 with no definitive answer to date. Microsoft's recommendations regarding addressing this issue are;
    While good recommendations not as helpful as we would like. SOURCE: Bug Check 0x3B: SYSTEM_SERVICE_EXCEPTION
    NOTED:
    Attached new dumps if problems persist post driver updates.
    Regards
    Randy
     
  9. KGrow

    KGrow New Member

    Joined:
    Jan 16, 2012
    Messages:
    10
    Likes Received:
    0
    I've got a new dump hereView attachment 012412-15849-01.zip , this time with a different code. It occurred as the game was opening during loading while the screen was still black. My machine really doesn't like this game it seems haha!
     

Share This Page

Loading...