Taskbar Icon will not delete

#1
I have an icon (ITunes) that when I click it, it says "This action is only valid for products that are currently installed".

When I try to right-click it to delete, it does not give me a menu to choose from. No option to delete.

When I go to the folder that contains all of the taskbar links, this particular link is not there, but the other links are.

I've tried rebooting, tried uninstalling ITunes and reinstalling it, cleared the IconCache and restarted Explorer.exe, nothing. I've searched for Itunes.lnk on my hard drive and can't find anything.

Even after I reinstalled Itunes, I re-pinned a shortcut of it on the taskbar and now I have 1 good link that works and still the other bad/corrupt link that just sits there.

Any ideas?
 


reghakr

Essential Member
#2
Hello and welcome to the windows7forums.

I'm glad to hear you got rid of Itunes.

Try starting up in safe Mode and see if you have the option to Unpin from taskbar?

Restart and hopefully it will be gone.
 


#3
Does it show when you RIGHT click on your time and select properties? and then go to Customize? Maybe you can remove it from there.
 


#4
I tried both ideas mentioned above (Reboot into safe mode & check the properties under clock).

Both did not resolve issue. Under safe mode, the icon acts exactly the same, by not giving me a right-click menu with unpin option.

Under the properties under the clock, it does not list this Icon pinned to my taskbar.

Any other ideas on where in my system this is stored? Registry? Another folder?

Note: In terms of folder I checked, i looked in my username, the other account (my wife's), the shared folder and the "all users" folder.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#5
Is this an in-place upgrade from another OS?

If you check or uncheck the iTunes toolbar with the taskbar unlocked, does it make any difference?
 


Last edited:

reghakr

Essential Member
#6
This issue has arose before.

Please look over the similar threads at the bottom of the page.
 


#7
I'm still wondering if he/she simply tried to drag and drop it to the recycle bin... and if the file is named desktop.ini that file is rebuilt sometimes.. so it may be just coming back. What's the file name?
 


#8
Found a solution

I found a solution. Nothing on the other boards seemed to work.

I opened GLARY UTILITIES, and it has a "Shortcut Fixer". I scanned and deleted all of the entries it gave me.

After I did that, I clicked on the Icon again, but instead of it saying "This action is only valid..." it now said something like
"path cannot be found, delete shortcut?" Of course I said yes and it is gone!!!
 


#9
Another solution

This worked for me:

Navigate to C:\Users\<Username>\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar

As a shortcut for the above, can type the following in the address bar of windows Explorer:
%appdata%\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar

Find the offending shortcut and delete it. Done. :)

You many need to refresh your taskbar (Toggling 'Lock the taskbar' worked for me) to get the change to appear.

If you don't want to type all that into the address bar in one go, but instead want to navigate step by step, then you'll have to show hidden folders, because the 'User Pinned' folder is hidden. To do this, you need to:

Organize | Folder and search options | View tab | Show hidden files, folders and drives
 


reghakr

Essential Member
#10
If the above didn't work,. give this atryu:

How To Purge & Rebuild The Icon Cache In Windows 7 or Vista.

If you find that one or more of your icons are not displaying correctly, or that your icon cache is corrupted, you might want to consider rebuilding your icon cache.

To do so, Open Windows Explorer, and configure your Folder Options > Views to show Hidden / System Files. Next go to C:\Users\Owner\AppData\Local folder and delete the hidden IconCache.db file. Reboot. This action will purge and rebuild the icon cache.

There is also another way to do it, should the above method not work for you.

Kill Explorer.exe process. To do so, click Start button > Hold down Ctrl+Shift & Right Click on empty area in the Start Menu > Click "Exit Explorer".

Click Ctrl+Shift+Esc keys and open Task Manager.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.