The confirmation box for deleting files takes WAY too long

#1
Hi everyone.

I have a weird problem that I cannot find a previous poster has had...

When I try to delete a file, either by choosing the "delete" option on the context menu or by pressing the "delete" key with the file selected, it take between something like 20 to 60 seconds to show me the usual confirmation window (the one with "Are you sure you want to delete file XXX.X?"). It's quite annoying, however it seems that that is the only problem. When the confirmation windows does come up the file can be deleted OK and I can drag and drop files to the recycling bin without any problems.

Can anybody help?

Thank you.
 


Highwayman

Extraordinary Member
#2
its likely down to UAC settings checking your privilege rights to do the action
 


#3
So it's checking my rights every time I try to delete something?

How can I fix it?
 


Highwayman

Extraordinary Member
#4
well if you have the admin account, then it may not be that, the non-admin accounts tend to have draconian checking by UAC. UAC is a handy security tool to have enabled, although some find it can get in the way, personally I leave mine on but don't have it annoying me in the way you mentioned. You could experiment to see if the issue is resolved by temporarily lowering the UAC settings, if the changes dont make a difference you can set back to the default and hunt down a different idea.

To alter UAC you simply run MSCONFIG from the start icon, goto the tools tab it brings up, and launch the UAC option
 


Highwayman

Extraordinary Member
#5
Might also be worth checking settings on Antivius software etc too, as some have read and write checking for all files, which can also slow down some operations.
 


#6
Doesn't seem to be the anti-virus, but I'm in my admin account, so I don't know...
 


Highwayman

Extraordinary Member
#7
is the hard drive set to auto spin down after a period of non-use.... that would also have a part in the issue, check in the power options, as if it's parked it will take that long to get to speed.
 


#8
I can't find any "auto-spin" option... I do have the energy option chosen to never shut down the hard disk unless I set it that way.

Also, wouldn't that make my whole dealing with files slow?, it only happens when I try to delete them, and also, the files don't take long to be deleted per se, it's the confirmation window what takes forever.
 


Highwayman

Extraordinary Member
#9
sadly thats about the extent of my ideas, hopefully the more techy admins will drop a suggestion
 


#10
Still, thanks a lot for trying to help man!
 


#11
Can anybody else provide some help?

It's really bugging me and I don't seem to be able to find a fix!
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.