The DNS Server Is Not Responding

Hi so I am having problems connecting with the internet on my PC. I have a Linksys WRTP54G router and am running two computers (desktop, laptop) on wirless G and an Xbox 360 wired.

I flashed the firmware on the router and this seems to have cause problems, but the new firmware is way better for VOIP and has improved the wired connection.

Weird thing is, my laptop with the integrated wirless card connects to the internet and network without a hiccup.

The desktop keeps connecting to the network, but has no internet connection. The diagnostic says the DNS server isn't responding. Both those fields for IPV4 are set to obtain automatically, the same as my laptop. IPV6 is not being used for any of the computers.

The only difference I see between the setups are that my desktop uses a USB wireless card. For some reason when I connection to my network which is called "connection" with the desk top it shows up as "connection 2".

I have tried re-installing the USB adaptor, I have manually given IP address and the DNS servers. None of it works, keep getting "The DNS Server isn't Responding".


Noob Whisperer
There are a number of issues which can produce DNS problems, not the least of which is third party software products, specifically the Bonjour service in all its many forms. So first check for the presense of something called mDNSresponder.exe in taskmanager under the processess tab, show processess for all users. If present post back and we'll help further with that issue.
Also you may consider that sometimes some routers stumble a bit with DNS forwarding. So normally with all IPv4 options set to auto, the router itself will normally be the DNS resolver (actually forwarder). Try leaving the IPv4 set to auto but manually insert a public dns server and see if that makes a difference. Try preferred and alternate. I know you said you set them manually but you did not make clear if you persisted with the use of the router in your manual assignment so I thought I would throw that in as well.

Hi Randy,

Thanks for the quick response. Yeah in my router, DNS 1 and DNS 2 have the primary and secondary DNS servers of my ISP, I tried the google ones you mentioned before as well to no avail.

In the task manager though, I do see a little process called mDNSResponder.exe*32, it's a system process.

Like I said, my laptop has aboslutely no issues and the desktop was working up until the firmware flash of the router.


Millennium Celebration Award Winner
Premium Supporter
Did you delete the old network connection from the desktop and start fresh? I've had to do that before.


Noob Whisperer
In the task manager though, I do see a little process called mDNSResponder.exe*32, it's a system process.
Type services.msc into the search box and hit enter
look for either of the two following services
Bonjour Service
or something like this
or both. In either or both cases, double click the service and in the properties dialog box under the general tab set the startup type to disable and click the stop button. Reboot the computer
See if that has any impact on the problem

OK so I did what you said, no luck.

Went to Best Buy, bought a Linksys USB AE1000 wireless key and replaced the cheap Retail Plus wireless USB card with that. Everything works beautifully now.

I had a strong feeling it was something with the USB wireless card that was giving me all the trouble. Something in the router's firmware update was not compatible with the Retail Plus wireless USB card.


Noob Whisperer
Great news, glad to hear your were able to sort out your problem. Good job and thanks for posting back with your solution.

What will I do next if I see the "mDNSresponder.exe" ? Please reply immediately.


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.