"There Is No Disk in the Drive..." when launching software

#1
Hi forums, this is my first post here, unfortunately not for a good reason.

Basically whenever I try to launch a specific program (Autodesk 3ds Max 2010 64-bit to be precise), I receive the following error message:

"There is no disk in the drive. Please insert a disk into drive \Device\Harddisk1\DR1"
[ Cancel | Try Again | Continue ]
This error has only occured recently, I have had the software installed for about six months with frequent use with absolutely no trouble. I have made no significant changes to my computer in the last couple of weeks (the last time I used the program) to the best of my knowledge. The software is a legit copy from Autodesk installed from a CD/DVD.

I have ran a virus check with no results, although I did not expect it to help at all.
I completely uninstalled and did a fresh re-install of the software and the problem still persists.

I have been searching for a couple of days but I have yet to find a solution. This is a major problem for me as I am currently starting work on a project and have no access to my primary program, and I really do not want to begin working in another program because of this.

If anyone can help you are a lifesaver :)

Thanks.
 


zvit

Honorable Member
#2
In the meantime, for a first quick reply just to get you started on your project is to do a system restore to a point when you know the program worked.
I will now do some research on the specifics.

Update: Solution form Microsoft:
http://support.microsoft.com/kb/330137

Only because you said it was specific to your using 3dsMax, I will also try this small thing that has to do with Quicktime:
http://techsalsa.com/solved-no-disk-error-in-windows/
 


Last edited:

patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#3
Have you previously run this program with an external drive plugged in?
 


#4
Yes I have ran the program whilst using an external HDD, but not in a while as I have had no need for it. It caused no problems though.

As for a system restore I already did that a week ago due to another problem. The built-in SDHC card reader was causing windows explorer to crash. I did a system restore before simply reinstalling the device driver which solved it.

I will try reinstalling 3ds Max again because I realised I didn't delete the actual file directory, just uninstalled via the control panel. So any problem files may still exist. I will update after I have done this.
 


zvit

Honorable Member
#5
I would also suggest not just deleting the folders but also the registry entries. I myself have 3ds Max 2010 64-bit installed and when I did a search in regedit, there are only 7 entries:

HKEY_CLASSES_ROOT\.max
HKEY_CLASSES_ROOT\3dsmax
HKEY_CURRENT_USER\Software\Autodesk\3dsMax
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.max
HKEY_LOCAL_MACHINE\SOFTWARE\Autodesk\3dsMax
HKEY_LOCAL_MACHINE\SOFTWARE\Autodesk\Reg\3dsMax
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Autodesk\3dsMax

Delete these from the registry as well.
 


patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#6
Yes I have ran the program whilst using an external HDD, but not in a while as I have had no need for it. It caused no problems though.
It would not cause problems at the time and I'm not suggesting it did - but your program registered its existence and is now expecting the drive to be there when it starts up. I don't know if the intention of the recommended registry edits is to handle this problem. If not then it should be sorted by plugging the drive back in when starting the program and thenremoving it from the drives it uses.
 


zvit

Honorable Member
#7
The only reason 3dsMax specifically would ask for an external drive is if you defined the ex. HDD as your scratch disk. If not, and you open a new project and you get that error, that's serious.

The "Please insert a disk into drive \Device\Harddisk1\DR1" is not a 3dsMax specific problem and is widely spread with other software as well, and as I wrote, Microsoft deals with this issue.

The registry entries were to advise you that if you are anyway going to uninstall 3dsMax to eliminate it as a problem, then do it right.
 


#8
I think I have solved the issue. I ran Computer Management as that webpage said to, and under the list of drives was a disk simply named Disk 1. Turns out it is the SDHC reader that I previously had trouble with. Because the error message specified 'Harddisk1' I figured it might mean this. So I have changed the drive letter and all appears to be well, although I haven't tested the reader yet.

I will update if I have any further trouble, thanks a lot for the help!
 


zvit

Honorable Member
#9
That's was Microsoft's solution in the first post I wrote. Glad it worked out.
 


#10
Aaha i gotted the cause of problem... i was facing the same problem and now it is resolved. Whats happening at end, let me explain

when i plugin any kind of datacard like " TataPhone+" or "BSNL3G DataCard" or any other then i got the message "Please insert a disk into drive \Device\Harddisk1\DR1" with different .exe
Then noticed that there is a space for memory card in the datacard but there is no memory card inserted and when i insert memory card then this message get stoped.

Now what to do if you have no memory card, just simply go for "Computer Management" and disable that drive
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top