there is no disk in the drive

Discussion in 'Windows 7 Help and Support' started by jmacari, Jan 24, 2009.

  1. jmacari

    jmacari New Member

    Joined:
    Jan 24, 2009
    Messages:
    6
    Likes Received:
    0
    I am currently using Win7 Ultimate64; When I remove a CD or DVD from the drive, several minutes later I will receive the following dialog box (msnmsgr.exe), "there is no disk in the drive. Please insert a disk in drive d." The only way I can remove it is by going into Task Manager (and ending it); what's funny is SOMETIMES (not always), I also have to end the Live Messenger app (that may be just coincidental) ......anyways, all my drives are labeled properly (HDD's, CD/DVD drive, Readyboost USB drive).

    I have tried the following;
    When I get the error msg, I re-insert the DVD, click "Eject"....error dialog box still happens...

    Any ideas??

    -Joe
     
  2. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Can't understand why Microsoft messenger would be causing that error message.

    Just for kicks, Go to Start > Run, and type msconfig and uncheck msnmsgr.exe so it doesn't load at startup.

    Do you still get the error?
     
  3. jmacari

    jmacari New Member

    Joined:
    Jan 24, 2009
    Messages:
    6
    Likes Received:
    0
    I figured that would solve the problem.....I stopped Live Messenger from starting (at boot up-as you suggested) and all is well. As I stated in my initial post, I thought maybe it was just a coincidence, but I guess Messenger is causing that problem ("there is no disk in the drive. {Please insert a disk in drive d"). Funny, that's the first time I've ever fooled around with messenging-If I do continue with it, I'll just start the service as needed.

    Thanks for the info-

    -Joe
     
  4. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    No problem Joe,

    Actually any time you install a program, you should look through the options for something such as "Run at Startup" and uncheck the box. If it isn't in the options, run msconfig and that will tell you if anythings been added.
     
  5. sjankis630

    sjankis630 New Member

    Joined:
    Oct 21, 2009
    Messages:
    12
    Likes Received:
    0
    Sorry to bring this thread back up but I too have the same problem. Except the difference is I do not have live messenger running. It is a strange problem as I get the message "There is no disk in the drive. Please insert a disk into drive F" (here F is the DVD drive I most often use to burn and watch media.
    I have had this computer since October of last year Windows 7 ultimate 64 bit and this problem has cropped up in the last 2 months. I have not been able to diagnose it.
    I have done every malware and virus scan known and nothing. It seems to be entirely random as well. With it cropping up multiple times during some days and then not showing up for as long as a week.
    I use my computer daily and usually always keep in on.
    Any other suggestions on how to get this annoying problem fixed?
    Thank you in advance.
     
  6. mikebc10

    mikebc10 New Member

    Joined:
    Aug 24, 2010
    Messages:
    2
    Likes Received:
    0
    I had this problem on Windows 7 64 bit with a Plextor Blu Ray b320sa drive.....
    I had Windows 7 installed for the first time the install was about 10 months old.
    Motherboard was MSI Pro E.
    Here are some things I did to remedy the situation in order of what I tried.
    First what happened is the Plextor was having problems with DVD so I thought it might be Roxio Creator 2010 or Cyberlink Power DVD.
    So then I uninstalled Roxio. Now the drive got noisy and wouldn't play dvd now and then I got a DVD to play but it would be choppy.
    Then it only started to play CDs.
    I tried uninstalling Cyberlink but still couldn't get the DVD to play properly.
    I tried all the reinstalling drivers etc. Going to regedit and removing filters etc. still no good.
    I then moved all my files off the hard drive and re-installed Windows 7. (I wanted to do a re-install anyways)
    ........still no work it wouldn't even tell me that there was a disc in the drive! But it still installed Windows 7 after I changed the boot sequence.
    Then I got frustrated and just deleted the whole DVD registration key....I don't recommend this.
    Still nothing drive makes noises like it is reading the drive but nothing.
    In the system it says the drive is a CD drive?
    So now I think the drive which is 9 months old is toast!
    I figured out a way to test the drive on my laptop.....I connected it by SATA to a hard drive enclosure I had then connected it by USB to my laptop. The test proved the Plextor still worked. I was able to instantly access the drive and even play DVDs. I then connected it to my main PC and was able to do the same on it.
    So I was happy I didn't have a burned out drive. Now what exactly fixed it I am not sure but I will run you through the last few things I did. I went into the Bios and reverted it to factory settings for optimal performance. BTW I should mention I did also try the official Microsoft Windows Tool that you download to diagnose the drive. It told me no disc in drive! I also went into Windows recovery and went to a point when I had just installed Windows 7 with a few programs. I then also tried a new SATA cable and connected it to a SATA port that I hadn't tried. I actually think that port might have been the original port I had the drive set up on. BTW I also installed the Realtec HD driver as somewhere I read this was required for the hdcp compliance and also used an analog cable as this is required on my computer for Blu Ray to work.
    Now on the working PC this is what it says in the Device Manager under DVD/CD drive....Plextor and my model and in the details it says Location 1 (Channel 1, Target 1, Lun 0)
    It doesn't look like anything has changed in the IDE ATA/ATAPI or the com settings. The last thing I will say is I also changed the com port address in the Bios.
    Also before it was fixed it seemed to act like the drive was a hard drive?
    Before I had the Plextor Blu Ray with SATA I had an NEC DVD which I was very happy with. It was connected by ribbon cable. The only problem I had with the NEC was it once reverted to PIO mode. I tried that fix it too thinking that would solve the SATA issue with no luck. So anyways sorry to be long winded...but to sum up.....I would first maybe revert if you can to an earlier save point on Windows 7. Try a new SATA cable and double check the drive if you can on another PC or laptop.

    Mike
     

Share This Page

Loading...