There might be a problem with the driver for the Local Area Connection Adapter.

Discussion in 'Windows 7 Help and Support' started by Speeker, Jan 13, 2011.

  1. Speeker

    Speeker New Member

    Joined:
    Jan 13, 2011
    Messages:
    10
    Likes Received:
    0
    I recently installed Kaspersky Internet Security 2011 on my computer and am now having a problem with my internet connectivity. When I run the Windows 7 Troubleshooter I get the message that says that 'There might be a problem with the driver for the Local Area Connection Adapter'. I have attempted many things to fix this.

    I have uninstalled the drivers for the Network Adapter and that didn't fix it

    I have run sfc/scannow and that didnt fix it

    I tried ipconfig /dnsflush that didnt work

    I cannot use ipconfig /renew and /release because it is not connected to the internet.

    System restore will not work because there are no restore points.

    I uninstalled Kaspersky and disabled Windows firewall hoping it might be a firewall issue.

    I installed a USB wireless network adapter which changed the message from 'Local Area Connection Adapter to 'Wireless Area Connection adapter'.

    Please help, I do not want to reinstall windows. If anyone has any advice that can help please let me know.
     
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,806
    Likes Received:
    1,563
    #2 kemical, Jan 13, 2011
    Last edited: Jan 14, 2011
  3. Speeker

    Speeker New Member

    Joined:
    Jan 13, 2011
    Messages:
    10
    Likes Received:
    0
    I tried this remover and it did not fix the problem.
     
  4. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    Instead of re-installing, could you not do a repair install?

    Course, you need a disc for that!
     
  5. Speeker

    Speeker New Member

    Joined:
    Jan 13, 2011
    Messages:
    10
    Likes Received:
    0
    running the repair utility didnt work either
     
  6. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    If we could let's concentrate on the wired adapter and remove the addon wireless usb adapter from the machine and the diagnostic equation. Please provide some specifics regarding the wired adapter. Manufactuer name, model name, model number and Rev. Number.
    Type ncpa.cpl into the search box and hit enter.
    Right click the wired adapter (Local Area Connection) and choose properties.
    Select the "Configure" Button and then the "Details" tab.
    Select the drop down arrow and change "Device descritption" to "Hardware Ids"
    Right click in the "Value" box and choose select all
    Right click again and choose copy
    Paste that information into your next post.
    And by the way greetings and welcome to the Forum
    Randy
     
  7. Speeker

    Speeker New Member

    Joined:
    Jan 13, 2011
    Messages:
    10
    Likes Received:
    0
    Here is what is shown when do that

    PCI\VEN_10EC&DEV_8168&SUBSYS_E0001458&REV_01
    PCI\VEN_10EC&DEV_8168&SUBSYS_E0001458
    PCI\VEN_10EC&DEV_8168&CC_020000
    PCI\VEN_10EC&DEV_8168&CC_0200
     
  8. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Realtek RTL8168B/8111B Family PCI-E Gigabit Ethernet NIC.
    Go here Realtek and down load this-> Win7 and WinServer 2008 R2 Driver7.0342010/12/22
    Use device manager to force a driver update.
    Expand network adapters, right click the problem adapter and choose update driver software, then Browse my computer, then Let me Pick, then have disk, then browse, browse to the folder where you downloaded and extracted (if necessary) the driver noted above.
    If that dosen't help try this
    type ncpa.cpl into the search box and hit enter
    right click your adapter and choose properties
    click the configure button
    choose the advanced tab
    look for something called speed and duplex (may be worded slightly differently)
    select it then in the right column select the drop down arrow and choose 10Mbps/Half
    OK your way back out of there and reboot
    If that seems to work for you then start experimenting with different settings, because your card/driver is having a problem auto negotiating link speed and duplex settings with your router.
    Ideally a setting of 1000 full (never half with Gig Ethernet) is what you would want, so change to 100 half and reboot, then 100 full and reboot, etc.
    Keep us posted.
     
    #8 Trouble, Jan 14, 2011
    Last edited: Jan 14, 2011
  9. Speeker

    Speeker New Member

    Joined:
    Jan 13, 2011
    Messages:
    10
    Likes Received:
    0
    Alright I tried both of the suggestions and neither worked. Nothing improved the situation :(.

    Btw thanks for the help hopefully we can figure this out.
     
  10. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Sorry for the delay, things have been a bit hectic.
    Try resetting both the IP stack as well as the Winsock catalog.
    Elevated command prompt type
    netsh int ip reset C:\ipreset.txt
    then
    netsh winsock reset
    reboot
    copy and paste the results of an ipconfig /all into your next post.
    Again apologies for the late response.
    Randy
     
  11. StormofThunder

    StormofThunder New Member

    Joined:
    Oct 20, 2012
    Messages:
    2
    Likes Received:
    0
    I've got the same problem here, except it's with a wireless driver. I am connected with an Ethernet cable now, but this is really a mess. I have an Asus N55SL and my wireless adapter is an integrated Intel Centrino Wireless N-100.
    I have a tried everything too: installing, uninstalling and reinstalling drivers, going back on restore points didn't do anything, and it's not the AVG network filter problem like some, as it never appeared in the driver/connection properties. It just happened completely out of nowhere! And it's the second time it does, but unlike last time, which it just fixed itself overnight, it did not this time. I really, really do not want to re-install Windows again, please help.
     
    #11 StormofThunder, Oct 20, 2012
    Last edited: Oct 20, 2012

Share This Page

Loading...