Touchpad on Dell Latitude D420 stopped working

#1
Hi, new user here. Tried to find answers for why my touchpad just quit working, but I haven't found anything yet! I'm running Windows 7 (32-bit) on a Dell Latitude D420.

I was running the computer, typing some homework, and then hibernated it to change classes. Booted it back up five minutes later, after a successful hibernation, and the touchpad had stopped working.

I tried downloading all the driver again, but Windows isn't even recognizing the touchpad device. right now it only recognizes the USB mouse I have plugged in. I tried downloading the original driver, but I have a sinking feeling it isn't compatible with Windows 7.

Does anyone have any suggestions??
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
Any chance a mechanical shock could have dislodged the touch pad connector?

Have you done a cold reboot?
 


#3
I didn't notice any movement out of the ordinary that could cause that, but it's possible. Windows isn't even detecting it, so that's a good theory. I'll have to look up where it connects.

Waking up from hibernation wouldn't count as a cold reboot, right?

Thanks for the help.
 


#4
Waking up from hibernation wouldn't count as a cold reboot, right?
Right. Try using shutdown from the start menu. After it's powered off for at least 20-30 seconds, power on the machine and see how it goes.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.