TP-LINK TL-WN722N Wireless Adapter will not connect to Virgin Super Hub

Discussion in 'Windows 7 Help and Support' started by fuggles, Feb 10, 2012.

  1. fuggles

    fuggles New Member

    Joined:
    Feb 10, 2012
    Messages:
    6
    Likes Received:
    0
    My virgin Super Hub wireless option is on - yes

    I am typing in the correct security key - yes

    I disabled the security key making an open connection - yes

    It detects my wireless modem , but doesn't connect, - yes


    This is simply a windows 7 64 bit problem

    The TP-LINK TL-WN722N Wireless Adapter has glowing reviews and works on my XP machine.

    There is something in windows 7 stopping this device from working.

    I even used a different wireless usb stick and that worked .
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Since you have gotten another adapter to work with the system, it appears you do not need help with that.

    Have you checked to see what the differences are with the two adapters as far as type, SSID, etc?

    Are you using the WPS to setup the adapters, or entering the information manually?

    Do you have the external antenna connected and have you tried moving it around.

    I don't really know what in Windows 7 would keep one wireless adapter from working and allow another one.

    Any specifics as to what your system is showing as to what might be going on could help. There is also a trouble shooter in the Network and Sharing center that might help.

    Let us know..
     

Share This Page

Loading...