Tranposed keys on keyboard: changing language does not resolve the issue

#1
Hello - my inverted commas key and the "@" key are transposed. I have done the obvious: gone into Regions and Language to check that the settings are not US English (they are English (Ireland)). Having trawled the Internet I cannot find any other solution to the problem. Any help greatly appreciated. Rosie
 


Elmer

Extraordinary Member
#2
Do you mean " and @ are swapped? That says to me English (US).
I'm assuming the English (Ireland) is the same as English (UK). Have you tried the UK setting? Is English (Ireland) the only keyboard setting? If you've just changed the setting, did you re-boot afterwards?

UPDATE

Just read this somewhere so cannot validate it.
Holding the "Shift" and "Ctrl" keys at the same time, while keying a quotation mark ("), will cause the @ and the " to reverse with each other. To fix this, just repeat the same button sequence again.
 


Last edited:
#3
Elmer thank you very much for the reply. Unfortunately, the problem is still there. Yes, I did try with the UK as opposed to the Ireland language option, and I also tried the ctrl/shift possibility, but nothing works.
 


#4
Sorry, meant to say that yes, I did reboot after the setting changes...
 


Elmer

Extraordinary Member
#5
I'm afraid that's as far as I go with keyboard errors as I've never had to dig deeper than the fixes I've already mentioned.

I did Find "Sharp Keys" over at How-To-Geek which could possibly be a work-around, although personally I hate using work-arounds instead of solving the issue.

OFF TOPIC Around the millenium, I spent the better part of two years working and living on the edge of Cork (Glanmire). Probably the best two years of my life.
 


#6
Thank you anyway, Elmer. I'll have a look at Sharp Keys. Glad you liked Cork! Regards, Rosie
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#7
Hi

First I would try a different key board and see it it is works normally.

If not.

Try updating the drivers for the keyboard.

If this doesn't help then uninstall the keyboard in Device Manager.
Unplug it and reboot your computer.

Once it has booted plug the keyboard back in and let it reload.
Pick UK English.

I don't know if this will work but it's worth a shot.

Mike
 


#8
Thanks Mike - but i should have said it's a laptop, not a PC...
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#9
I don't have any other ideas either.
Sorry we couldn't come up with an answer.
 


Elmer

Extraordinary Member
#10
FN + _ ? Depends on make though.
 


#11
Thank you anyway! Rosie
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top