TRENDnet TEW-423PI not installing properly.

Discussion in 'Windows 7 Help and Support' started by Dr. Nick, Jan 16, 2009.

  1. Dr. Nick

    Dr. Nick New Member

    Jan 16, 2009
    Likes Received:
    Okay, so I downloaded the 64-bit version of Windows 7 Beta and installed it on my spare partition.
    Install took 20 minutes and everything went fine. I even got my integrated audio to work.

    Unfortunately, my wi-fi card(TRENDnet TEW-423PI) doesn't want to work.
    I've tried reinstalling over and over again, but that didn't work, I tried installing without the card in the slot(worked for XP, although for vista I was told to leave it in the machine)

    Then finally, I realized that Win7 was recognizing it as an Ethernet Controller, which it clearly isn't.

    I'd consider buying a new wi-fi card later, but currently I don't have the money to spend on a decent one.

    Anyone know what's causing the problem, or how to fix it?

    I'm gonna go to sleep, I'll check back here when I wake up and post any extra information.
  2. vahnx

    vahnx New Member

    Oct 25, 2006
    Likes Received:
    I had it working for a second until I rebooted in Build 7232 with the default Windows 7 driver but now it's no loger working. Works fine in Jaunty.

    UPDATE: Been trying for 3 hours and no luck! I read plugging in ethernet then windows update fixes it; and an update did appear but didn't work. Now I think it says Network Profile #6 but even when I show hidden devices in device manager in normal/safe mode I don't see the other 5! Ran CCleaner to no avail.
    #2 vahnx, Jun 19, 2009
    Last edited by a moderator: Jun 20, 2009

Share This Page