Trouble Connecting to Network (long)

Discussion in 'Windows 7 Networking' started by Chamenas, Jun 24, 2010.

  1. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    Specifications:
    The Machine is Custom-Built, running Windows 7 Home Premium 64-bit
    Processor: AMD Athalon II x4 620 @ 2.6 GHz
    RAM: 4.00 GB

    Network Card(s):
    Realtek PCIe GBE Family Controller (built-in to the mother board)
    ^ The above card wasn't working, so I bought a separate one:
    Dynex Gigabit PCI Adapter
    For reasons explained elsewhere, I also got a USB Wireless Adapter:
    WNDA3100v2 - RangeMax Dual Band Wireless-N USB Adapter

    Problem:
    Short Version
    Desktop computer will switch between "Local Access Only" and being connected to an "Unidentified Network". Occasionally the "Unidentified Network" will get "Internet Access" but it's never really connected as I cannot browse or do anything else that required an internet connection during these times. It also will not see the router, I've tried pinging the router and connecting via its IP Address.

    Long Version
    I came home from graduating College towards the end of May. While I was at school there, my Desktop was connected to the campus network and never had issues connecting if the campus network itself was working properly. I brought the computer home on two occasions during school breaks and it worked fine on the network here.

    However, after coming home upon the completion of school, I hooked up the Wireless and found that it was limited or no connectivity. At this time it was still running Vista 64-bit Home Premium. The reasons for this was because my school's network had certain software specifications in order for a computer to run on its network. These software specifications hadn't been completely stabilized with Windows 7, though they said it should work, I decided to play it safe and stick with Vista.

    However, now I was finding myself unable to connect. So, I did a bunch of things (explained below) over the course of two weeks with nothing working. Except one brief period in which it worked for less than an hour. However, roughly two weeks after I came home, I had upgraded the computer to Windows 7 and was preparing to simply wipe it completely and install Windows 7 from scratch when I noticed something odd.

    My Windows 7 machine now wanted to do updates. Of course, logically, I knew it could only want to do them if it had finally reached internet access. I looked and unbelievably, for no explicable reason, I had internet access. I waited and waited for it to go away, but it didn't. So, I had internet access. 10 days later (aka as of today) as I was online, the internet connection suddenly died on me. The router hadn't gone out, the internet was fine on my laptop's wireless. But, for some reason, my Desktop's ethernet suddenly went back to limited connectivity again.

    Since I don't know why it suddenly began to work and I don't know why it suddenly failed again, I have no idea where to begin in order to get this problem fixed.

    What I've Done:
    Trying to put this in chronological order, but I've done a lot of things and it isn't all recent in my memory. As it stands I may not even list everything I've done, so if you bring up an idea and I've done it, I'll let you know. It's not me trying to be argumentative, I simply may not account for everything here and you may end up jogging me memory by it.

    > I've tried connecting via another computer's ethernet jack. Interestingly enough, my Laptop and another Laptop in the house wouldn't connect to the modem/router via ethernet. This initially led me to believe it was the router. However, several days into it, I tried a Desktop computer downstairs via the ethernet and it connected just fine.
    > I've tried it with no less than 3 different ethernet cables
    > I've tried rebooting the router by turning it off, waiting, and then turning it back on
    > I've tried restarting the router by hitting the small button in the back with a paper clip
    > I've tried connecting directly to the router on all 3 computers (even the Desktop, ugh, lugging that around sucks) that wouldn't connect via ethernet.
    > I've had all of the anti-virus and firewall software for the school removed from the computer.
    > I've shut Windows Firewall completely off just for the purposes of trying to connect.
    > I've had the router replaced. Before I realized that there was a computer working on the ethernet, I called Verizon and naturally they concluded it must be the router as well and sent a replacement.
    > I've tried reinstalling the drivers for the Realtek adapter (the other two adapters were fresh installs as of today. But I searched online for their latest driver updates just in case).
    > I've tried manually rebooting the motherboard by disconnecting it from the power supply, waiting, and reconnecting.
    > I upgraded from Vista to Windows 7
    > Finally, I backed the computer up and prepared to reinstall 7 from scratch when I noticed the update thing, and voila, I had a connection for 10 days for unknown reasons it began to work.
    > Today, during the morning, I suddenly lost connectivity and I haven't had it back since.
    > I tried installing a separate ethernet card, but that didn't change anything, it still won't connect. I also tried a Wireless N USB adapter, but that "connects" to one of the Wireless networks in the house (the one off of the main Verizon router actually) but there's no actual connection there it behaves like the ethernet does, with a "Limited Connectivity" behavior without actually seeing the router.

    So there, that's what I've done. It feels like I've done more so I may have forgotten something.

    I'd like to fix this problem without having to reinstall Windows 7 from scratch but am willing to if I have to. I've posted on the FIOS forums for Verizon and tried things they've suggested, but none of them seem to work. I figured that this is likely more of a software issue on my computer's end and was hoping it might simply be a setting I'm unaware of in Windows 7.

    I should note that one thing I've noticed is that whenever it started working, it would ask me what type of network I was on (seems to be standard for Windows 7 and Vista) and I selected Home twice. The first time it connected (lasted an hour before it went away) I had selected Public. Selecting Home the first time was what lasted 10 days. I selected home again today when it came up, but nothing happened. The trademark sign of an issue is that it won't see the Home network, it instead can only see an "Unidentified Network" which only seems to consist of my computer.
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    First, since you say that you have a computer on the network that has a working wired connection, please start with that computer, and from a command prompt type ipconfig /all use this utility to determine what IP addressing scheme your network is using
    IP address
    Subnet Mask
    Default Gateway
    DNS Server(s)
    Now on the problem machine simplify as much as possible by using device manager to disable network adapters that you are not using. Then use the same command ipconfig /all to determine what IP address information the problem machine is receiving from the DHCP server on the network (usually your router). Compare this information with the known good information from the working machine and see if there are any glaring discrepancies. Maybe post back the information to help us better understand what's going on.
    Usually the unidentified network issue is a product of missing default gateway information and a result of your network card being unable to communicate with the DHCP server on the network. You can try an ipconfig /release and then an ipconfig /renew and see if that produces accurate information or an error something like "unable to find DHCP server".
    Sometime wired ethernet adapters have trouble communicating with various routers because they fail with the default setting of "Auto Negotiation". Try opening device manager, expand network adapters, right click on problem adapter, choose properties, select the advance tab at the top of the resultant page, under the Property column look for something called "Speed & Duplex", select it and under the Value column use the drop down to select another setting. Experiment with different values, try 100 Full, or 100 Half, etc. see if that produces any better results. You may have to reboot after each change of these settings, not sure, but it won't cost you anything but a few minutes of your time so reboot just to make sure.
     
    #2 Trouble, Jun 24, 2010
    Last edited: Jun 24, 2010
    Chamenas and (deleted member) like this.
  3. Agent Data

    Agent Data Banned

    Joined:
    Jan 9, 2010
    Messages:
    918
    Likes Received:
    42
    try a repair install from CD first - if no joy clean wipe the box and install after a quick format and you'll be well provided you got no real hardware issue.
     
  4. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    Working Desktop:
    IP Address: 192.168.1.5
    Subnet Mask: 255.255.255.0
    Default Gateway: 192.168.1.1
    DHCP Server: 192.168.1.1
    DNS Servers: 192.168.1.1
    71.243.0.12

    Non-working Computer:
    IPv4 Address: 169.254.84.63
    Subnet Mask: 255.255.0.0
    Default Gateway: ??? (nothing here)
    DNS Servers: 192.168.1.1
    71.243.0.12

    Now, that's with the non-working computer trying to talk to the DHCP. I had actually had it on a static IP before and forgot to mention that as one of the things I "tried". It was suggested to try a static IP address and it worked on the static IP address for the 10 days (though it didn't work immediately, which is why I didn't list it as the solution or even remember it).

    However, your suggestions called for a dynamic allocation, so I switched it back to that since the computer downstairs (which works) is using the DHCP.

    Interestingly enough, right now the computer is showing in the Network panel as being connected to the internet (even though it's not) on an Unidentified Network.

    Using ipconfig /release gives the following error: An error occurred while releasing interface Loopback Psuedo-Interface 1: the system cannot find the file specified.

    ipconfig /renew gives me:

    Windows IP configuration

    And then it simply hangs from there.


    However... I just tried your other suggestion and changed the negotiation from "Auto Negotiation" to 100 Mbps Half Duplex and now it works. I don't know why that did anything, but if anyone is able to explain I would be even more grateful than I am.

    (Doesn't work on 100 Mbps Full Duplex)

    Thank you.
     
  5. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    As I explained earlier some Network Interface Cards (it seems especially true with some Gig Cards) and router combinations have trouble with auto negotiation, I always assumed it to be a problem with the driver code for the NIC, but it can also be an issue with the firmware for the router.
    I was unable to find your Dynex card on the Microsoft Windows 7 Hardware compatability list here
    http://www.microsoft.com/windows/compatibility/windows-7/en-us/Browse.aspx?type=Hardware&category=Networking&subcategory=Ethernet%20Adapters
    so I really can't help with a driver solution, although that particular card may actually be using a chipset from another more familiar NIC manufacturer, I really can't say. You may also want to check with the router manufacturer and see if there is a firmware update that may help, just make sure you follow any and all applicable instructions regarding this process, since a bad firmware flash, can brick your router.
    Good luck, and glad to hear that at least it's working now.
     
  6. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    When checking the router when all of this started I looked to see if there was a firmware update, but there wasn't one. Of course, we had also just received a new router. The drivers on both adapters are up-to-date as well. Of course, sadly, there's another issue. Suddenly I've lost connection again for no reason and it's once again connecting to an "Unidentified Network" even with it specifically set to 100 Mbps Half Duplex. I changed it to Full but it never connected there either.

    I'm at a complete loss. It worked perfectly when changed to half duplex and now it suddenly has lost connection again... I don't know why it would suddenly fail to work at that negotiation too.
     
  7. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    Nevermind, router just needed to be reset. I was panicking when the solution was obvious...

    Also, why does it seem that the Edit button on posts appears and then doesn't appear even when I'm logged in?
     
  8. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Glad to hear that you figured it out with the router reset. I found this article which seems to explain the whole speed duplex issue pretty well, of course there's a lot of technical stuff in the middle but the first paragraph has some good information and near the bottom where it explains the duplex mismatch issues with auto negotiation is worth reading because it explains why some people appear to be connected but the network performs very badly.
    http://en.wikipedia.org/wiki/Autonegotiation
    As far as the edit button is concerned I believe that it is a time sensitive utility and may only be available for a couple hours and then no longer supports editing a thread once the time has elapsed. Not absolutely sure.
     

Share This Page

Loading...