Trouble installing software

Discussion in 'Windows 7 Help and Support' started by Alvar van Rijn, Nov 1, 2011.

  1. Alvar van Rijn

    Alvar van Rijn New Member

    Joined:
    Nov 1, 2011
    Messages:
    4
    Likes Received:
    0
    Hi! Thank you for reading this. Here's my problem:

    Problem
    I get errors when trying to install programs. They seem to relate to the temp folders.
    I have 4 partitions on my HD: a system partition of 100mb, c:\ 110GB with windows and programs, D:\ 8Gb for virtual mem, E:\ 800+GB data.
    When I instal from E: to C: or from a (virtual PowerIso) disk to C: i get install errors. So the big problem is, i can't install anything from a (virtual) disk. The small problem is, it's just not a perfect install. The other big problem is that it's a PC intended for my mother and I don't want her having any issues with it down the line.... which I then have to solve ;-)

    Two examples:
    installing Partition Wizard home edition 7, double click setup, popup error: Setup was unable to create the directory "C:\Users\Marja\AppData\Local\Temp\is-RIVB.tmp". Error 5: Acces is denied.
    Installing Crysis 2 (illegal) it starts with trying to install VC++ 2008 redis. and immediately there's an error: The installation package or a needed file could not be opened. Verify that the package exits and that you can access it.

    When it doesn't happen
    When I copy the Partition Wizard setup, or any setup files for that matter to C: it installs perfectly. So basically it only happens when not installing from C: and the setup wants to put data in the temp folder.

    What may have caused it
    I have moved some of the special folders. Downloads, my pictures, my videos, my music, my documents, saved games and desktop.

    What i tried to fix it
    1. System restore to first point
    2. Check temp folders, they are there TEMP and TMP. (C:\Users\Marja\AppData\Local\Temp)
    3. I am logged onto the (only) administrator account
    4. I run the setup as administrator
    5. I've run sfc /scannow twice. Fixed some stuff the 1st time, but did not solve the problem. Second time it was clean.
    6. Ran the ms utility form Diagnose and fix program installing and uninstalling problems automatically but it didn't find anything
    7. Ran windows repair from USB boot but that didn't find or fix anything
    8. Switched of Avast (only security program active in bckgrnd)
    9. Unmarked 'read only' (right click on folder) from the AppData folder and subfolders plus items
    10. Also tried to follow the steps in this KB arctile but when I get to step 4 (shift r-click open elevated command window here) i get a pop up saying: "This file does not have a program associated with it for performing this action. Please install a program or, if one is already installed, create an association in the Default Program Control panel."
    More info
    I've attached some reports just to be on the safe side. DxDiag, Msinfo32 and CBS log

    What to do?
    A clean install is not an option at this point. So.... I don't know.
     

    Attached Files:

  2. Medico

    Medico Senior Member

    Joined:
    Sep 20, 2011
    Messages:
    1,158
    Likes Received:
    65

Share This Page

Loading...