Trying to map/share a drive on an xp machine and to access it on win7

Discussion in 'Windows 7 Networking' started by funkyApache, Sep 5, 2010.

  1. funkyApache

    funkyApache New Member

    Joined:
    Sep 5, 2010
    Messages:
    24
    Likes Received:
    0
    Hi.

    Setup:

    1. Windows 7 Home Prem - (PC-A) This is my new machine
    2. Windows XP Pro SP2 - (PC-B) This is my old machine which will end up being my server
    3. Windows XP Pro SP3 - (PC-C) This is my netbook

    All three are connected wirelessly to a Wifi router.


    I'm quiet new to windows 7 and have just built my own pc. I'm now trying to share/map two drives on PC-B so I can access it on PC-A. Now I have googled and run through a few tutorials on how to share/map but I cannot get PC-B to share with PC-A. PC-C can access and view all shared folders on PC-B and can see/access the shared files/folders on PC-A so it must be connected some way.

    From PC-A - I pinged PC-B and it replied I ran cmd.exe and did net view and could see all three machines but when I try open/map the machine it asks me for a password and refuses to let me in. I have not had this issue with PC-C trying to connect to either PC-A or B.

    Any suggestions?
     
  2. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Yes, if it is asking for the password and not letting you in, it is very likely due to both machines having the same user name for the accounts running, but different passwords. That won't work. So set the passwords for the same account names (if this exists and is how yours is) to be the same as well.

    If that's not your issue, right click on the folder(s) you're trying to share and choose properties. Go into the security permissions and assign them to "Everyone" (without quotes) by typing that. After, set it to allow or disallow the types of access you want to give.

    I'd really use Windows Update to install SP3 on that XP SP2 machine. SP2 is not supported any longer. And for performance/reliability reasons too.
     
  3. funkyApache

    funkyApache New Member

    Joined:
    Sep 5, 2010
    Messages:
    24
    Likes Received:
    0
    Thank you for the quick response, much appreciated. :)
    they have the same username and password.

    I'm trying to share C: and D: not specific folders if that makes any difference. I right click on the drive and went to the sharing as you suggested "Everyone is already in the list and there are three ticks in FULL/READ/WRITE.

    PC-C can access it. I just tried PC-A to PC-B again and when I'm in Windows Explorer and click on PC-B a prompt comes up saying

    Windows cannot access \\PC-B
    You do not have the permission to access \\PC-B. Contact your network admin to request access.

    I have just shared some files on PC-C to see if PC-A would talk to PC-C and the same thing happened.
     
  4. funkyApache

    funkyApache New Member

    Joined:
    Sep 5, 2010
    Messages:
    24
    Likes Received:
    0
    Oh yes as for upgrading XP SP2 to SP3 I have tried in the passed but it keeps telling me that I dont have admin rights even though when I go to users it recons I am the admin (I'm the only user of this machine). Once I have all my files over on PC-A I'm look at upgrading it again.
     
  5. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    It would seem that the primary issue is with PC-B, the same one that will not allow you to upgrade to Sp3, because of an issue with your account rights.
    Have you considered creating a new user (admin user) on that machine with a new password just to see if that might get you over the hump, both with upgrading to Sp3 as well as the sharing issue.
     
  6. funkyApache

    funkyApache New Member

    Joined:
    Sep 5, 2010
    Messages:
    24
    Likes Received:
    0
    OK I managed to upgrade PC-B to SP3.

    I read that Windows 7/Vista uses Link-Layer Topology Discovery (LLTD) Responder technology to build a map of the network While I installed the protocol on PC-B and C and whe nI view the map on PC-A I can see PC-C but PC-A is linked to "UNKNOWN" which is then connected to the the router. I'm not sure if this would give us a clue. I'M just going to reboot incase it just needed a reboot.
     
  7. funkyApache

    funkyApache New Member

    Joined:
    Sep 5, 2010
    Messages:
    24
    Likes Received:
    0
    I managed to upgrade it by booting up in safe mode and then running it as admin.
     
  8. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    That's good news.
    Make sure that there are no duplicate machines names on the network.
    Make sure that you are not attempting to use blank passwords on your user accounts.
    When attempting to access the PC-B machine from the Win7 machine try using
    NameOfTheXpMachine\Administrator
    and then the password for the administrators account on PC-B
     
  9. funkyApache

    funkyApache New Member

    Joined:
    Sep 5, 2010
    Messages:
    24
    Likes Received:
    0
    all my users have passwords. All three machines have different names (I did my Comptia network+ about 7 years ago so remember some of these things :) )
    where do i enter that?

    On PC-A, I went to advanced sharing settings and under "HomeGroup connections" I changed that to "Allow Windows to manage homegroup connections(recommended)". I know I'm using advances sharing setting on PC-B.

    The thing thats really getting me down is the fact that PC-C connects to PC-A and PC-B. I recon PC-A is at fault because I cannt open either PC-B OR PC-C

    Grrrr..... :)-])
     
  10. funkyApache

    funkyApache New Member

    Joined:
    Sep 5, 2010
    Messages:
    24
    Likes Received:
    0
    Hmm Strange I just refreshed the network map.

    It now displayed as follows:

    PC-A hard wired to "unknown" which is hard wired to router. (Very strange seeing as my PC is connected to the router wirelessly)
    PC-B is now shown on the map and is connected to the router wirelessly.(correct)
    PC-C is on the map and is connected to the router wirelessly.(correct)
     
  11. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Examine both PC B and C (XP machines), for third party software such as firewalls and internet security suites, that might be causing your issues. It doesn't take much, just neglecting to include the new PC into a trusted group, or forgetting to include a MAC address into the filters. Often uninstalling any such software until you are able to resolve your issues and then reinstalling with the correct configurations in place will help.
    The other information you are getting regarding that map, may just be an issue with UPnP. Check the router interface and if it has an option to enable UPnP, then try enabling it.
     
  12. funkyApache

    funkyApache New Member

    Joined:
    Sep 5, 2010
    Messages:
    24
    Likes Received:
    0
    I'll try that. Antivirus app shouldn't cause a problem. should it?

    where must I enter that username /password you suggested?
     
  13. funkyApache

    funkyApache New Member

    Joined:
    Sep 5, 2010
    Messages:
    24
    Likes Received:
    0
    Coudl it be because PC-A is 64bit and the other 2 are 32bit?
     
  14. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Yes, some anti virus applications have been identified as causing similar issues, as I said an uninstall, test if problem persists and then a reinstall if that is not the issue, is just an issue of time and can often move the diagnosis of the issue along.
    And
    No 32bit vs. 64bit OS(s) shouldn't be an issue.
     
  15. funkyApache

    funkyApache New Member

    Joined:
    Sep 5, 2010
    Messages:
    24
    Likes Received:
    0
    ok,

    On PC-C there was only windows firewall. I disabled it and I was able to ping it from PC-A where before it was givign Request timeout. When I click on PC-C under Network on PC-A I can see the shared folders but when I click on it it takes ages and then says

    \\PC-C\c is not accessible. You might not have permisions to use this network resource.
    The specific network name is no longer available.

    PC-C can still access PC-A shared harddrive and open files.
     
  16. funkyApache

    funkyApache New Member

    Joined:
    Sep 5, 2010
    Messages:
    24
    Likes Received:
    0
    On PC-A when it asks me for a username and password it always has "Domain: [PC-A Computer Name]". Is this right?
     
  17. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    That is the default behavior, but if you begin to type the machine name of the xp machine and then a backslash you will probably see that change.
    Disabling the Windows Firewall on PC-C doesn't make any sense, since you said that PC-B was OK with file and printer sharing to PC-C, presumeably with the Windows Firewall enabled, unfortunately I don't remember that much about the settings in the built-in windows firewall for XP, but as I recall, it was pretty basic and you justed checked or uncheck programs or services, so I'm not sure why that would have blocked one machine and not the other.
    You aren't using any type of third party network management software utility on any of these machines are you?
     
  18. funkyApache

    funkyApache New Member

    Joined:
    Sep 5, 2010
    Messages:
    24
    Likes Received:
    0
    I got it to ping with the firewall on the "Dont allow exceptions" was check I uncecked that it responded to the pings.

    Ok I did some more pings

    PC-A Ip is 192.168.123.125
    PC-B IP is 192.168.123.123
    PC-C IP is 192.168.123.124
    Router is 192.168.123.254

    From PC-A I pinged PC-B it responded and had the right ip address. Then I pinged PC-B computer name it responded but this time with a different IP 192.168.56.1. I then tried ipconfig /all and checked through the connections. I saw two entries for DNS Servers one being the router and the other being 194.168.4.100(i have no idea about this ip)

    When I ping PC-C from PC-A using both the IP and computer name it uses the right IP Address.
     
    #18 funkyApache, Sep 5, 2010
    Last edited: Sep 5, 2010
  19. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    OK, well that doesn't help at all.
    Does one or more of these machines have access to a second collision domain? Are there either multiple routers and or multiple NICs actually in use with any of these machines. Are all machines configured with automatic IP addressing, or have you assigned these as static values? Are all machines point at the router as the default gateway? Are you using a default Class C subnet mask of 255.255.255.0?
    remove the extraneous entry from DNS
    Clear your DNS cache>Cmd Prompt>ipconfig /flushdns
    Clear your NetBIOS cache>Cmd Prompt>nbtstat -R (case sensitive Captiol R)
     

Share This Page

Loading...