Two Windows 7 Gadgets Stopped Working

#1
I hope this is the correct place to post. This is my first time here.

I recently renewed my internet security subscription. (I won't say of what, because I honestly don't think that the type is the issue here.)*****

Immediately after doing so, the Calendar and Weather gadgets stopped working. The Calendar shows up as a blank orange/white square and opening up the Weather gadget will just reveal the "i" information symbol and a X close button, neither of which actually work.

I also SWEAR the Clock gadget also stopped working but then after an hour later it started working again and has been working since.

I have tried deleting/uninstalling the gadgets but that hasn't worked. I have tried several tricks with the Windows command prompt which doesn't work either.

I'm considering using an automatic system restore (I don't have any manual saved points to restore) on just the gadgets themselves. Is that the way to go, or is there something else I could try?

Please keep in mind that while I'm good with laptops I'm by no means an expert. So try not to get too technical on me all at once. ^^;


*****I've decided to name it: McAfee. I didn't at first, because it's been my experience whenever I mention a problem and mention an antiviral program; people will ignore the problem entirely and just tell me what I should buy. (I should trust you guys.) :p

I mention McAfee because it's an odd thing: I've searched forums and have found that others have had the almost the same problem; except with them it happens when you UNINSTALL McAfee, not renew it.

I've also found another possible solution that involves deleting a registry key, but I'm way too nervous to try that. Unless you people think I should.
 


Last edited:

Joe S

Excellent Member
#2
Since the problem started right after renewing the subscription I would be suspicious especially if it was an updated version. Did you try disabling the AV and reboot to see if that made a difference? You can try system restore if you have a date when they wee working.
Joe
 


#3
I assume you mean, turn the AV off, and restart. I just tried that and it didn't work.

I did try to restore the files to an earlier version (several days before I renewed) and that didn't seem to work either. Stupid question but should I try saving the files elsewhere, delete EVERYTHING, restart and see if it all comes back? I did read somewhere that if I like changed at least the Settings.INI file and closed/opened Windows Explorer that the file would be restored. But I tried that and it didn't work.

So either these are ineffective or I'm an idiot and doing them wrong, in which case I'd like step-by-step instructions if they're any good. (Same going with point restoring the files.)

I've decided to reveal more info in my original post concerning the Anti-Virus.
 


Last edited:

Saltgrass

Excellent Member
Microsoft Community Contributor
#4
Are you seeing any error or warning messages in the Event Viewer?

Does McAfee have a place to allow programs through the firewall? Does McAfee keep a log of its activities?
 


#5
McAfee went haywire today, and this isn't the first time. I decided to switch AntiVirus security systems, and have uninstalled McAfee. Doing this has brought back the gadgets, so this has now been solved.

Thanks everyone. :)
 


iftieaq

Active Member
#6
Maybe your pc is virus affected. Scan your windows.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.