UAC settings will not let me open itunes.

#1
I originally had iTunes working on my computer and all the sudden I tried to open it up one day and windows 7 popped up with a message saying I do not have the privilages to access this program.???

I played with all of the settings to make myself (the one and only administrator) to have full control and ownership over the program then the whole C: drive. Still nothing.

It wasn't until I turned the UAC settings down to the lowest possible setting that I was able to open iTunes. (also can open it if I run the program by short-cut menu and selecting "Run as Administrator.") That is not how it is supposed to work though so now I guess my question is;

How do I get iTunes to open and run properly with the UAC settings at the recommended level of security without having to right click the program and "Run[ning it] as Administrator"
 


Mitchell_A

Essential Member
#2
Hello and welcome to the Windows 7 Forums :)
Not sure what could have went wrong - a file permission error somewheres,
But you can right click on the shortcut and go to "Properties" followed by "Compatibility", from here, check the box that says "Always Run this Program as an Admin"
Click OK.

The program will now run as admin without you having to right click each time.
A re-install may fix the problem.
Also, if you're running 64-bit Windows 7, ensure you have the 64-bit version of iTunes.

Hope this helps.
 


Joe S

Excellent Member
#3
I turned UAC off on Vista and did the same with Windows 7. On a single user PC it was more trouble than it was worth.
Joe
 


#4
Joe,

Personally, I would like to keep the UAC setting turned on if possible. But right now that seems to be difficult.

Mitchell_A,

Thanks for the welcome...

Second, I can do that in the campatibility mode however it has restricted all my access as far as drag and drop and other general features i used to have with iTunes. So essentially it allows me to open the program but it still doesn't work correctly.

Also, I Have reinstalled it a few times trying to find every file on the computer that would even hint at a iTunes relationship (such as Bonjour, Quicktime, any apple update software plus any thing that either says apple or itunes on it.) It does not change my privaleges for the program.

As for the type of itunes I have installed, Originally i tried just clicking the main like off of apple's webiste which is the general download for anyone. When the 32-bit 64-bit idea hit me i searched specifically for it and found the "64-bit for windows 7" file. It turns out it is just a 32-bit .exe file and 32-bit program. It always puts it in the default folder (x86) under the program files folder. This is specifically where all of the 32-bit programs go and they run just fine except iTunes for some reason? Not sure how to fix it still. Wish this wasn't so difficult to make work. As i have said before this is the first time i have ever had problems with windows and iTunes have a 'Rights' conflict.
 


Mitchell_A

Essential Member
#5
Hmmm... Agent Data, you got anything?
 


#6
You can always use Take Ownership.

http://www.howtogeek.com/downloads/TakeOwnership.zip


This is the direct link for howtogeek's article.

The article: Add "Take Ownership" to Explorer Right-Click Menu in Win 7 or Vista - How-To Geek

This should resolve it; if it doesn't then i would first uninstall it, disable UAC, install it again, then enable UAC.
That's just a theory that might work :S
 


Mitchell_A

Essential Member
#7
Honestly, I'm not sure why I didn't say that ;)
 


#8
I had the exact same issue even when performing a clean install.
Before doing the following do this: right click on the itunes file then click unlock.

Here is how I fixed it:
1) In IE goto internet options ->certificates
2) Export the apple certificate from the untrusted publishers tab
3) Import the certificate into the trusted tab
4) Delete the old certificate.
Note: If you view the certificate for apple it stated that the certificate has been revoked.
This allowed me to access itunes.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.