Ubuntu dual boot: grub crash caused missing partitions and HDD memory. Windows problem

Discussion in 'Windows 7 Hardware' started by gopherkiler9, Jul 25, 2012.

  1. gopherkiler9

    gopherkiler9 New Member

    Joined:
    Jul 25, 2012
    Messages:
    2
    Likes Received:
    0
    Hello there. I have posted this issue on a Ubuntu help forum, but everyone seems to be suggesting that this is indeed a windows error. This is a copy and paste of my problem.
    ------
    hi there. I haven't messed with ubuntu in a long while, because of this problem.

    what happened was i had ubuntu dual installed alongside my windows 7. I had grub as its main boot loader. I can't remember if i did the partitioning myself that time or not, pretty sure I did. However, for whatever reason, my grub loader failed once and it caused me to have to reset the mbr via a windows 7 disk.

    after I did this and ever since, the partitions I had set for ubuntu (a whopping 50gb) have been invisible to me. I KNOW they are there because my windows 7 says that my HDD says it is only like 418 in size. Clearly the memory is gone SOMEWHERE, but the partitions are not visible in either windows' partitioning tool, or when I load up a boot disk and use something like gparted.

    any suggestions on what happened or how I can get my memory back? ive been making due with the missing memory, but its annoying me like a twitch.


    as well, if this is in the wrong forum, its quite obvious how its a tough call between a software and hardware issue.


    thanks.

    EDIT: I must also mention that my dual boot worked just fine for the longest time. it then suddenly made me go through two screens to get to my ubuntu. (id click ubuntu, then it would give me options for what ubuntu as opposed to how it was originally of just clicking ubuntu once) then shortly after that (few days) the grub crash happened. it really had no reason to do that, so i am very confused as to WHY. I just want my memory back though. currently it only has windows 7 at startup and does NOT use grub.

    --------

    This here is a link to an image of what I am talking about with the missing memory
    http://i182.photobucket.com/albums/x27/gopherkiler9/sizecontradiction.jpg

    This here is the result of a sudo fdisk -lu command using a Ubuntu live disk.

    Disk /dev/sda: 500.1 GB, 500107862016 bytes
    255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x36958aca


    Device Boot Start End Blocks Id System
    /dev/sda1 * 2048 206847 102400 7 HPFS/NTFS
    Partition 1 does not end on cylinder boundary.
    /dev/sda2 206848 976771071 488282112 7 HPFS/NTFS
    root@ubuntu:/home/ubuntu#


    What it comes down to, is that my partitioning tools say two different things. That my internal HDD is either a 465gb or a 418 (418 is the result of shrinking the HDD size to incorporate the dual boot for Ubuntu). But according to EVERY partitioning tool I use, the partitions no longer exist... but windows 7 still doesnt see the space I used for it as being there again. Its like someone physically chipped away 50 gigs out of my hard drive.
     
    #1 gopherkiler9, Jul 25, 2012
    Last edited: Jul 25, 2012
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    What exactly did you do to reset the MBR using the Windows 7 disk? Did you originally shrink the partition using Windows or Linux?

    Did you allow Grub to install on the MBR, or on the Linux partition?

    Have you tried repairing Grub?

    What is the status of your install as far as are you willing to wipe the drive and start over. Have you made a system image so you can restore?

    What partition managers have you used, and have you tried any partition repair operations using them.
     

Share This Page

Loading...