Unable to connect to Server 2008

#1
Hi everyone,

I've been tearing my hair out trying to work out why half of our PC's/Laptops are able to connect to our server and the other half can't since we upgraded to Windows 7.

Everyone is using identical firewall and settings (ESET).

I've done the NTLM negotiation change but no affect.

I can ping the server but unable to map a network drive.

Just get a "windows cannot access" message.

Some machines can see the server and some can't but even the ones that can see it can't connect
 


Trouble

Noob Whisperer
#2
First, may I ask, is this a Windows Workgroup or are you using the 2k8 server as a Domain Controller, for a Active Directory Domain, or is it a member server in and Active Directory Domain?
 


#3
Trouble,

it is a member server and active directory domain.

I am able to ping the servers IP but not its DNS name.

All users have the same rights and I've also added all the computers to the directory.

I'm afraid I am very much a novice when it comes to Windows Server so I've tried to keep the whole setup very simple.

There was no issue when all the machines were XP it is only since the upgrade to WIN7

Thanks in advance
 


Trouble

Noob Whisperer
#4
Trouble,

it is a member server and active directory domain.

I am able to ping the servers IP but not its DNS name.

All users have the same rights and I've also added all the computers to the directory.

I'm afraid I am very much a novice when it comes to Windows Server so I've tried to keep the whole setup very simple.

There was no issue when all the machines were XP it is only since the upgrade to WIN7

Thanks in advance
If we can assume from your answer that it is an Active Directroy Domain Controller and you just left out the word Controller, then
Open Server Manager
Expand Features
Expand Forest, then Domains, then your specific Domain, then Group Policy Objects
Right click on Default Domain controllers Police and choose edit
In the resultant Group Policy Mangement Editor expand
Computer Configuration, then Windows Settings, the Security Settings then Local Policies, then highlight User Rights Assignments
In the right pain near the top "Access this computer from the network" make sure the group "Authenticated Users" is included
 


#5
Hi Trouble,

Yes I've checked that "Authenticated Users" are in the list. I've also tried adding individuals but to no avail.
 


Trouble

Noob Whisperer
#6
OK, make sure that the windows 7 machines are pointing to your Windows DNS server and only to that server for DNS resolution.
Then pick one of the problem Windows 7 machines and unjoin it from the Domain, put it back to Workgroup reboot. On the Active Directory Domain Controller, remove it from the list of Domain Computers. Then from the problem windows 7 machine attempt to rejoin the domain, supply the necessary domain administrator's credentials when prompted, reboot. Then log on to the problem machine with Domain Administrator's credentials and see if you still have problems accessing domain resources.
Keep us posted.
 


#7
we don't actually connect to the domain (at the moment anyway).

The drives are shared and accessed via "map network drive" as part of the WORKGROUP.

I've also noticed that those who do have access are able to access from different machines e.g. 1 colleague has 2 laptops that both connect. Both are different model Dells.

Actually come to think of it the only thing that connects the upgraded windows 7 laptops that are having problems is that they are not Dells.

Also those who can connect keep losing the network drive and have to re-map at least one of them.

I'm now debating whether to downgrade to Vista as there is no connection issue with Vista.

Or I'll have to bring in a network guy to poke around and hopefully not charge me an arm and a leg.
 


#8
Also those who can connect keep losing the network drive and have to re-map at least one of them.
In all machines, using the device manager while looking at the network adapter settings, look at the Power Management tab. Uncheck the box to "Allow the computer to turn off this device to save power."

If that doesn't help, then you can try creating a batch file to map the drives and place it in the startup folder so it runs each time Windows starts.
This command will make it non-persistent type, which is what may be causing the issue (being persistent in the first place.)

Here's an example of local drive I: being mapped to a remote machine:

Code:
net use i: \\servername\folder /persistent:no
Make as many lines as needed, in notepad. Save then rename to whateveryouwant.bat. Move to startup folder. Reboot and test.
 


Trouble

Noob Whisperer
#9
Make sure that the workgroup name on the client machines have the same workgroup name as the domain name just leave off the suffix. (mydomain.lan would be workgroup name mydomain).
You said you can ping the server. Make sure that you can ping the server by IP as well as HostName. If the first works and the second fails, then your netbios information is not being propagated across the network and you should tend to that. Make sure that the server has a fixed (static) ip address. From the client machines open command prompt and clear netbios name table cache
type nbtstat -R
then ping the server by ip and hostname
check the cache table on the client machine, command prompt type, nbtstat -c
if the server name and ip aren't in the client machines local cache then you have an issue.
You need a means of name resolution, eithere NetBIOS broadcast, WINS or DNS, don't know why you are not connecting to the domain, buy if this is going to be a long term process you might want to throw WINS on the server and point all the clients there under the WINS tab, in the IPv4 properties of each clients network card.
Also double check username and passwords, you say you have one user with two machines who seems to be able to attach to the server, is he using the same username and password on both machines?
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top