Unable to Delete a .mkv Video File

Discussion in 'Windows 7 Help and Support' started by izziekat, Jun 7, 2010.

  1. izziekat

    izziekat New Member

    Joined:
    Jun 7, 2010
    Messages:
    10
    Likes Received:
    0
    I have a .mkv video file which I cannot rename, move, or delete. Every time I do so this message shows: "The action cannot be completed because the file is open in windows explorer. Close the file and try again." If I try to delete the folder, a similar message pops up saying that a file is in use in another program.

    I've done some searching on the Internet for solutions and have tried the following:
    - restarting the computer and retrying
    - using safe mode to delete the file
    - running some commands
    - downloaded the following software: CCleaner, FileASSASIN, Glary Utilities, and Unlocker

    I downloaded Unlocker but never found a way to use it, so I downloaded the other programs, but none of them solved my problem. Furthermore, I tried re-downloading the file from a different website, was unable to replace the original file, and ended up with two undeletable files. I then tried to copy the file so I could at least have a non-problematic copy (this apparently worked for other people) and now I have three undeletable copies.

    Please help!
    (Note: If someone offers a command-type solution, I warn you I am a complete novice at typing commands so please give very detailed instructions. Thank you.)
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Have you checked msconfig.exe to see if anything is starting up you do not recognize that could be related?

    Could it be a virus of some type?

    Can you move it, perhaps to the root directory?

    Have you tried taking ownership of it using the properties/security settings?

    If you have the Install DVD, you might try booting to the Repair and command prompt area and deleting it from there.
     
  3. izziekat

    izziekat New Member

    Joined:
    Jun 7, 2010
    Messages:
    10
    Likes Received:
    0
    I forgot to add to the list of tried and failed solutions that I stopped and restarted explorer.exe but that did nothing.

    As for the suggestions you gave, I scanned the files using McAfee but it said there was no problem with them. Also, I forgot to mention that the files work perfectly (that is, I have no trouble playing it, just modifying it). Msconfig shows no unusual start-up programs running either.

    The last one, the Install DVD option, I'm not really sure what that is. The file in question is from the Internet, not a DVD. (Or is this a reference to a program name?)

    In regards of taking ownership, etc, I mentioned in my original post that I can't run commands very well, so while I tried to take ownership, I couldn't find detailed instructions so I probably did it wrong. Basically I have zero experience with that sort of thing.
     
  4. Mitchell_A

    Mitchell_A Excellent Member

    Joined:
    Feb 7, 2009
    Messages:
    5,068
    Likes Received:
    240
    Is it possible the file doesn't actually exist? Where did it originate from? Can you watch the file?
     
  5. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Use a program called Unlocker to delete it. Don't try to actually unlock it with the program. Use the program itself to delete and it will be gone.

    Other thing you can do is to use the task manager to close explorer.exe and then use the command prompt to navigate to its directory and delete it. (Type cmd.exe then hit enter in that start menu before closing explorer.exe to have it ready to use.)

    For example:


    Code:
    chdir /d C:\FolderLocationGoesHere
    Code:
    del filename.mkv
    Finally, do this in safe mode if needed.
     
    #5 TorrentG, Jun 7, 2010
    Last edited: Jun 7, 2010
  6. izziekat

    izziekat New Member

    Joined:
    Jun 7, 2010
    Messages:
    10
    Likes Received:
    0
    To answer the first few questions, I downloaded the file from a website (though I've been downloading from them for years now and never anything like this). The file itself comes from a different source (though, that too is a reliable source). When I actually use the file, it plays perfectly fine, with no problems in the video player either, so I think it does exist (also, it says it's a 391 MB file).

    Some good news: Using cmd.exe while closing explorer.exe helped me delete the original file. However, when I tried to delete the other two copies, it said that it could not find the original file. For example, I would say "del filename (1).mkv" and it would say "filename.mkv not found." In other words, no matter which copy I try to delete or how I tweak the filename (adding/subtracting spaces, etc), it would tell me that the original file is gone. So for now I'll re-download the original file in its original name and start again with the copies this time.

    As for Unlocker, I downloaded that before coming to this forum but for some reason it doesn't seem to activate. The icon appears in my programs and I click on "start unlocker" as well as the assistant, but when I right-click the files, the Unlocker icon does not appear (not just the three files in question, but regular files as well). And since I can't seem to find a way to start Unlocker and add the files in from the program window, so I'm not sure what to do.

    Update: I just ran cmd.exe again starting with the copies, but no difference. It still says "cannot find (original) filename.mkv," so I deleted the original file again. At least I'm down to two copies now. Thanks for all the help!
     
    #6 izziekat, Jun 8, 2010
    Last edited: Jun 8, 2010
  7. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    When you type the file name that you're trying to delete, actually use quotes around it. For example:

    Code:
    del "filename (1).mkv"
    Your welcome.
     
  8. izziekat

    izziekat New Member

    Joined:
    Jun 7, 2010
    Messages:
    10
    Likes Received:
    0
    Well that certainly helped with finding the file, but apparently my computer hates me. It now says "the process cannot access the file because it is being used by another program," though I've already terminated explorer.exe. However, when I go back and try and delete it directly, it just says that explorer is using it, so I don't know what other programs are involved, which is strange considering the first one was deleted in this way with no trouble. Great.

    (Here are the programs I downloaded so far for this problem: CCleaner, FileASSASIN, Glary Utilities, and Unlocker (please see my last post for Unlocker issues))
     
  9. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Doing it in safe mode should do the trick I think. Give a try. :)

    Worst case scenario: Download a Linux Live disc, boot to it and then delete.
     
  10. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    It seems obvious the file is running or is being used by something else that is running. Or you have the file in an open explorer window. You say Explorer was shut down, so maybe it isn't that. The reason you could delete the original might be the result of another one replacing it.

    What program is associated with the .mkv extension?

    I must assume you could not move the file? Have you tried changing the extension, which it probably also won't allow.

    Do you know how to open an administrative command window? Type cmd in the Start Meny search box then hit CTRL+Shift Enter.

    The reason I suggested booting to the install DVD and going to the Repair Command Prompt window would make sure nothing was running that could be using the file.

    I do not think redownloading more files will help. Just rename the ones you have.
     
    #10 Saltgrass, Jun 9, 2010
    Last edited: Jun 9, 2010
  11. izziekat

    izziekat New Member

    Joined:
    Jun 7, 2010
    Messages:
    10
    Likes Received:
    0
    Resolved!

    Sorry this last message came so late, but happily I was able to delete the last two files! (I went in safe mode and tried the commands with explorer turned off). In hindsight, the solution seems very simple, but, in any case, thanks to everyone who helped!
     
  12. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Nice, you're welcome.
     
  13. dvader679

    dvader679 New Member

    Joined:
    Aug 9, 2010
    Messages:
    2
    Likes Received:
    0
    i had the exact same problem with the mkv file... after trying everything i would suggest using east-tec eraser... its very easy to use and a 15 day trial is available
     
  14. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    In explorer click Organize -> Layout then uncheck the Preview and Details panes and try your delete again.

    I ran into this one right away with Win7. I had all my multimedia on a separate drive but decided that with a new OS it was time to shuffle and tidy my collection. Some file types would not move or delete but I could copy them. I got the message that the file is in use. After some head scratching I realized Explorer was opening the files to show content on icons... Turning that off freed me up to move and delete files.
     
  15. zvit

    zvit Honorable Member

    Joined:
    Nov 3, 2009
    Messages:
    2,455
    Likes Received:
    84
    Hey guys - great advice. Just heads up for further reference, files that can't be deleted almost always can either in safe mode (TorrentG) or before windows loads. Sometimes, it's not even a problem of "used by another process", but instead it's not a real file but a junk piece of a lost file that lost some pointers along the way and Windows can't recognize it to be able to delete it.

    One good program (besides Unlocker, which I use all the time) is Hijackthis which has an option in it's tools to delete a file on reboot. (Will only work if it's a real file).

    Another get around this with the command window is using the short names generated for non-8dot3 file names instead of the full name. To display the short name you would type dir /x. This helped me in the past. Especially with files that had gibberish names like wrLWssKy17PC_=³ײ²ֲ²׳²ֲ²ײ²ֲ²׳³ֲ²ײ²ֲ²׳²ֲ²ײ²ֲ²_.wmv.
     
  16. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,052
    Likes Received:
    303
    Hi

    Try downloading and running Malewarebytes.
    Under the More Tools tab there is an application called "File Assassin".

    I have found this to get rid of stuff that I couldn't delete any other way.
    I would try doing this from Safe Mode.

    Malwarebytes

    It's a good idea to have it scan you whole computer too.''

    Mike

    Whoops: I see I was only looking at the bottom of page one and this has already been solved.
     
    #16 MikeHawthorne, Aug 9, 2010
    Last edited: Aug 9, 2010
  17. hjgrsbdt

    hjgrsbdt New Member

    Joined:
    Oct 25, 2010
    Messages:
    2
    Likes Received:
    0
    I had a similar problem that I was dealing with, mine was a problem with renaming a file, specifically a *.mkv file. I found the solution to my problem to be killing teatimer.exe (something like that anyway). It is a program that is part of Spybot Search & Destroy. If you have SD installed, try killing TeaTimer. It's a lot simpler than the command line stuff. :D
     
  18. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,052
    Likes Received:
    303
    I see this was resolved, I got an email and started typing. LOL
     
    #18 MikeHawthorne, Oct 26, 2010
    Last edited: Oct 26, 2010
  19. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    Yes I nearly fell into that one! Would be handy if you could mark a thread as solved and a green (?) tick appeared in the left hand corner of the envelope icon before the thread title.
     
  20. georgie

    georgie New Member

    Joined:
    Oct 27, 2010
    Messages:
    2
    Likes Received:
    0

Share This Page

Loading...