Unable to install USB controller driver or any USB device after BSOD

Discussion in 'Windows 7 Help and Support' started by Anton17, Oct 21, 2011.

  1. Anton17

    Anton17 New Member

    Joined:
    Oct 29, 2010
    Messages:
    44
    Likes Received:
    0
    I had one of my regular BSOD (I'm quite sure its a RAM issue) and nothing unusual ever really comes from it, however today it screwed up my USB controller driver and now I'm perplexed as to how to get a fix for it.

    (Windows 7 64-bit)

    Windows recognises all of my 8 Universal Serial Bus (USB) Controller devices in Device Manager and upon startup it attempts to install the drivers, but fails on each one of them every time. I've tried to manually update the driver and I get the message:

    "Windows found driver software for your device but encountered an error while attempting to install it.

    Intel(R) ICH9 Family USB Universal Host Controller - 2935

    The system cannot find the file specified."

    The file associated with each of these devices is C:\Windows\System32\drivers\usbuhci.sys

    I've tried countless chkdsk C: /f in CMD to no avail and my Windows 7 disc did nothing to automatically find a cure (wasn't sure how to find the driver manually from disc). I've been told that the drivers for USB controllers are downloaded through Windows Update however I have extremely limited internet bandwidth and simply cannot be downloading 300mb of updates (I searched and couldn't find anything vaguely matching the description of the driver I'm after).

    This is driving me a little mad and I really don't want to resort to reinstalling Windows. I've tried Aida32 to try and find out my motherboard type and it shows as unknown... Does anyone have any advice I haven't tried?
     
    #1 Anton17, Oct 21, 2011
    Last edited: Oct 21, 2011
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    I would probably make an effort to track down the Blue Screen issues if any future BSODs are going to result in this type of problem. You can probably get some help with that topic here http://windows7forums.com/blue-screen-death-bsod/38837-how-ask-help-bsod-problem.html#post140678 read the first post in that thread and do your best to amass the data asked for, put it all into a new folder on your desktop, zip it up and post a new thread in the BSOD forum.
    Regarding your present problem, have you tried using the System File Checker utility to see if can resolve the issue.
    Launch an elevated command prompt
    Start Orb->All Programs->Accessories->Command Prompt right click it and choose run as administrator and type
    sfc /scannow
    post the log results and someone may be able to review them and suggest some additional options.
    Regards
    Randy
     

Share This Page

Loading...