Unable to reach msn.com

Discussion in 'Windows 7 Help and Support' started by cymru, Nov 11, 2009.

  1. cymru

    cymru New Member

    Joined:
    Nov 11, 2009
    Messages:
    24
    Likes Received:
    0
    Hello all,

    I have a strange issue with a new W7 Proffessional box. First, a little about my environment.

    I am part of a w2k3 domain and all network resources are functioning well. I am also behind a Sonicwall 210TZ firewall with what I can only describe as a *normal* setup for a business. Whatever that is. I have McAfee enforced AV (as do 20 xp pro workstations) but it does not seem to be causing me any issues at all.

    Here is the problem. The box is a dell vostro 220. It is brand new and functioning. Internet in general seems to be working as does email, IM, etc. Problem I have is going to MSN.com. Everytime I type it in the browser it trys to redirect to http://dell.v14.msn.com/. A ping shows that that address is bad. I have deleted the address from IE options>Home Page but it keeps appearing. Anyone know where else it could be lurking?

    I would really like to make this go away and I am loooking for suggestions. Any help would be greatly appreciated.

    TIA
     
  2. cymru

    cymru New Member

    Joined:
    Nov 11, 2009
    Messages:
    24
    Likes Received:
    0
    Drew, thansk for the help. You link works until I click on the take me to msn USand then I get redirected to http://dell.v14.msn.com/ which of course craps out.

    Then I get the google toolbar message "Oops! This link appears to be broken." and a link to msn.com. I click on that and it says redirecting to msn.com and guess where I end up? Right back at the beginning with http://dell.v14.msn.com/.

    Cant find anything in msconfig that could help. Thanks.

    *EDIT* FYI, if I open in private browsing I get to msn.com. Going to try deleting cookies, etc. Guess I should have done that from the start.
     
    #2 cymru, Nov 11, 2009
    Last edited: Nov 11, 2009
  3. cymru

    cymru New Member

    Joined:
    Nov 11, 2009
    Messages:
    24
    Likes Received:
    0
    so I deleted cookies and I think I've got rid of the redirect but now I get "Internet Explorer cannot display the webpage". As I said in the previous post, in private browsing I get no problem.
     
  4. cymru

    cymru New Member

    Joined:
    Nov 11, 2009
    Messages:
    24
    Likes Received:
    0
    Anyone have any ideas?
     
  5. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Look for a hosts file in your Windows\System32\drivers\etc folder and open it with notepad. Do you see any entries without a # in front of them?

    If you see the offending entry, delete that line or put a # in front of it. Hopefully that will allow it to work normally, but if it comes back, you may have a virus. Some anti-virus programs now have a setting to keep anything from changing the hosts file.
     
  6. cymru

    cymru New Member

    Joined:
    Nov 11, 2009
    Messages:
    24
    Likes Received:
    0
    thanks. I looked in there yesterday but they are clean as a whistle. Only entries are;

    # localhost name resolution is handled within DNS itself.
    # 127.0.0.1 localhost
    # ::1 localhost

    Its definately an IE/Dell thing. All other browsers work without a problem.
     
  7. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    You deleted cookies, did you delete everything, including the cache?

    I would probably do a search of the registry for some of the words in the redirect address.

    Are you running any type of toolbar with IE?
     
  8. cymru

    cymru New Member

    Joined:
    Nov 11, 2009
    Messages:
    24
    Likes Received:
    0
    Thanks for the reply.

    I have a partial fix but still not 100%. I went to IE > Tools > Internet Options :: Advanced (tab) Reset to factory defaults and clicked on the the option to delete/reset all personal settings.

    It did and now I am not being redirected to the dead link anymore but to dell.msn.com. I still want to change that to msn.com which I have done in the internet options but still, I am being redirected.

    Deleted cookies, searched the registry, rebooted and there is nothing visible even though i must be there somewhere. The redirect is hidden well but that is a bit too big brother'ish for me.

    Quite simply, I just want to go where I want to go.
     
  9. tblount

    tblount New Member

    Joined:
    Sep 27, 2009
    Messages:
    3,537
    Likes Received:
    64
    That's probably the problem.... isn't that the Sam file? I think it's protected and difficult to edit or delete and rebuilt... sfc may replace it with the original one??? anyone know?

    I read where a company developed a hijack program that modified the sam file and redirected all google searches to their site.... then used google to display the search results so that everyone THOUGHT they were on google.. but when they clicked on any of the advertised url's they got credit for sending the user to the site... the ripped off google for hundreds of thousands of dollars in advertising revenue before the were caught.
     
  10. cymru

    cymru New Member

    Joined:
    Nov 11, 2009
    Messages:
    24
    Likes Received:
    0
    The SAM file is also clean as a whistle. MS default sample.
     
  11. tblount

    tblount New Member

    Joined:
    Sep 27, 2009
    Messages:
    3,537
    Likes Received:
    64
    Run regedit and press f3 and search for that link it opens to ... delete all the url's listed... press f3 again and see if it fnds the url in any other locations.

    Possible locations.. under Prefetch.. then under Interenet Explorer there many possiblities such as "Start Page Redirect Cache"

    Once you clean all that up in your registry, and the SAM file is clean it can't even guess any other possibilities other than what you tell it.
     
  12. cymru

    cymru New Member

    Joined:
    Nov 11, 2009
    Messages:
    24
    Likes Received:
    0
    Regedit was the first thing I tried. Whatever this is, its hidden well and I really dont like it!
     
  13. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    I'm assuming Dell is re-directing. My HP did the same thing

    Open Internet Options and see what the home page is set to and if there are multiple entries.

    The registry is a good idea.

    Do a search for home page or homepage

    Other than that, have you installed any new software?
     
  14. tblount

    tblount New Member

    Joined:
    Sep 27, 2009
    Messages:
    3,537
    Likes Received:
    64
    I tried to locate Google and it wasn't found because in the registry it's recorded as www.google.com like he said.. look for your hompe page. A browser, ftp program or whatever can't find something that it's not programmed to find. Be suspicious.. you can go to web sites usig ip numbers. .. so ping the site it's going to and record that ip number like this from the command prompt:

    C:\Users\Terry>ping google.com
    Pinging google.com [74.125.45.100]
     
  15. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    log on to this link

    MSN.com
    and save it as your MSN home page.

    I understand there is an inherent fault in Dell which is causing the problem. This may fix it.
     
  16. cymru

    cymru New Member

    Joined:
    Nov 11, 2009
    Messages:
    24
    Likes Received:
    0
    Thanks but as I said, even this link gets redirected to dell.msn.com.
     
  17. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    The link I gave has a little more added than you see in the post. Do you did try it and got redirected?
     
  18. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Is anything showing up on the bottom left of your windows as far as addresses flashing while your browser is going to the site?

    Maybe someone else would know how to use Hosts to redirect the redirect. I tried changing it and there may be a ownership change needed before it can be edited.

    What happens if you put the dell site in your restricted sites list?

    Do we know the differences in the acutal IP numbers for the two sites? Firefox has an add-on that will give numbers for urls. I will see if I can find out.

    Could there be another DNS substituting the addresses. or would that be the hosts file?
     
  19. cymru

    cymru New Member

    Joined:
    Nov 11, 2009
    Messages:
    24
    Likes Received:
    0
    Yes, I have tried msn.com. Still redirects.

    I'm going to try running in safe mode and go back through everythign I've done and see if I can get to the bottom of it.
     
  20. cymru

    cymru New Member

    Joined:
    Nov 11, 2009
    Messages:
    24
    Likes Received:
    0
    Here is a quick update but still no resolution;

    After booting into safe mode, I confirmed that msn.com was my default home page and opened correctly. I then went into msconfig and looked in startup but there was nothing in there to worry about. I then went into regedit. HKLM\Software\Microsoft\Windows\CurrentVersion\explorer\Browser Helper Objects and renamed by putting a dash in front of the names all of the keys and then rebooted.

    Then I logged in normally and confirmed that my home page address was msn.com in internet options. I then launched the browser and still, dell.msn.com.

    The only thing I can think of is that it's a script of some kind. Any other suggestions?
     

Share This Page

Loading...