Unable to see empty drives in Explorer

julio99

Senior Member
#1
I have tried every conceivable way to get Explorer to let me view my empty drives under Computer. They show when there's a disk in them. They show in the reading pane, they just won't show up as empty drives in the Nav pane. I have tried deleting the upper and lower filters in the registry. Un checking the "Hide empty drives" in Folder options, adding a (1) to the registry settting "Hide drives with no Media". That setting seems to change itself back to (0) all the time. I am totally at a loss getting the empty drives to show themselves in the Nav pane.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
Already tried...

Are these just DVD/CD drives? Do they show up when you open the tray and then disappear later?
 


Last edited:

julio99

Senior Member
#3
Already tried...

Are these just DVD/CD drives? Do they show up when you open the tray and then disappear later?
Nope. The only time they show themselves in the Nav pane is when they are running or when I put a disk in. This is very strange that I
can't fix this even when working in the registry.
 


Last edited:

Saltgrass

Excellent Member
Microsoft Community Contributor
#4
I don't really understand the "Nope" part of your answer, but if they are DVD drives, you might look into updating the firmware.
 


julio99

Senior Member
#5
You asked me a question to which I replied "Nope". The question being, "Do they show up when you open the tray and then disappear later?" Answer,"Nope". Sorry if I wasn't clear. The dvd/cd drive I'm referring to is built into my laptop. It's the burner that came with the Acer 8943g. As far as I know their is no firmware to update on that one. The external burner and the built in burner both show up in the reading pane and they both show when their is a disk in them. They just won't show in the Navigation pane when they are empty.
 


davehc

Essential Member
Premium Supporter
#6
Have you tried , in - Tools - Folder Options , "Show all folders"
 


julio99

Senior Member
#7
Have you tried , in - Tools - Folder Options , "Show all folders"
That does the trick, however it also brings a lot of other folders with it. I was under the impression that your empty drives would show along with the hard drive as long as you unchecked the box -folder options-view-hide empty drives. For some reason that won't work for me.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.