Unexpected IO error during install, after previous good install on same system?

Discussion in 'Windows 7 Installation' started by soul777toast, Jun 7, 2009.

  1. soul777toast

    soul777toast New Member

    Joined:
    Jun 4, 2009
    Messages:
    14
    Likes Received:
    0
    So, I have a strange issue. I think it would be easiest to just describe the steps that I have taken and the results.
    First, I just built a new system. Specs are Asus P6T motherboard, intel i7 920, 12 GB OCZ Platinum 1333mhz DDR3, XFX Geforce GTX 260 black edition, 1300W Tagan ABS modular psu, 1 160gb western digital caviar black SATA hdd that I would like to triple boot xp, vista 64, and windows 7 64 on, but if I can't I'd settle for just xp and windows 7 64, and 3 750 gb western digital caviar black SATA hdd's in a raid 5 array. After build was complete, I succesfully installed and dual booted XP and windows 7 RC build 7100. I then realized that to set up my raid array, I would need to re-install with RAID enabled in my bios, so I turned on raid, set up the array, and succesfully reformatted and reinstalled the windows 7 partition and installation. Later on, I was having some compatability issues with a piece of software I was trying to run, so to try and troubleshoot I succesfully installed Vista Ultimate 64 over the previous XP installation. At this point, I lost the windows 7 entry in my bootloader, so I tried to run recovery on the windows 7 rc install cd. When I tried to boot from the cd, I reached approximatey 80% of "windows loading setup files" and then got an "unexpected IO error" which it said was caused either by removing a usb device while installing or by a faulty hdd or disk drive (this on a DVD that had worked correctly on THIS SYSTEM twice before). I then tried to use the Vista recovery tool, which successfully found my windows 7 installation and added it to the bootloader. When I then tried to boot into Windows 7, I got a "winload.exe digital signature cannot be verified" error, and when I tried to use f8 to choose the option to run without signing drivers it would just give me the same error again. I then tried to use the windows 7 RC install cd again, and it gave me the same error as before. At this point, I have now completely reformatted the drive, tried unplugging the raid array drives, tried plugging those in and unplugging the 160gb OS drive, using an old IDE drive with no other drives installed, reset my bios, and used drives configured as both RAID and IDE. With all of these configurations, I can at this point only install Vista. My windows 7 rc install cd keeps giving me the same error as before and when I tried to install xp (again with a disk that has worked before on this system), I got a bsod before the setup finished loading. Anyone have any ideas on this puzzler?

    -update: just reset bios AGAIN and it seems I did something right, because now I can at least get the xp install disk to load with an old IDE dvd drive. I'll keep posting developments.

    -update: this has something to do with my RAID controller. I was able to boot the xp install disk fine when my storage configuration was set to IDE, but when I went to RAID it goes back to the old error message. I can't figure out what could have made this stop working, because it did before.

    -update: I think I have this figured out. I'm not sure how this was working before, or why it stopped working, but I was able to get XP to install by loading the raid drivers for my mobo during the xp install disk load (f6 option). We'll see how this affects installing vista and w7.

    -update: I'm giving up on XP, between not having a floppy drive to load drivers from and the bootloader problems with booting xp and vista and w7, I've had enough. Trying now for just vista and 7.
     
    #1 soul777toast, Jun 7, 2009
    Last edited: Jun 7, 2009
  2. mike2k9

    mike2k9 New Member

    Joined:
    May 27, 2009
    Messages:
    184
    Likes Received:
    0
    I have the same issue with my XP cd. BSOD during the "copying files" part of setup. Though this never happened, obviously, when I installed it (on a raid 0 BTW. 2x sata 80GB) Dunno what the issue is. When I setup the raid array, Windows 7 install errors out right at where the first reboot would be. I had to install it on a single S-ATA drive, and it is working great.
     
  3. soul777toast

    soul777toast New Member

    Joined:
    Jun 4, 2009
    Messages:
    14
    Likes Received:
    0
    For your XP bsod problems, did you try loading the raid drivers during the xp install? I have issues doing this because I don't have a floppy drive and that's what xp looks for, but if you have one you should try to make a driver disk with your raid drivers and then press f6 when xp asks if you need to install any third party scsi or raid drivers. The other option is to use a program like nlite to slipstream the raid drivers into your windows xp install disk, there are multiple tutorials out there on how to do this. I unfortunately ran out of cd-r's before I could succesfully get this to work, but if you have some you might give it a try, I've heard it works well.

    As for win7, I was installing on a separate drive from my raid array. I now have vista set up fine on one partition of my OS drive, I'm just updating it then I'm gonna try to install win 7 on the other partition. We'll see how it goes.
     
  4. mike2k9

    mike2k9 New Member

    Joined:
    May 27, 2009
    Messages:
    184
    Likes Received:
    0
    I installed XP on my raid 0 3 years ago, and when i moved to win 7 and had initial trouble i tried to go back to XP and now i get the blue screen, i don't even get to hit f6 before the error. Now i got win 7 running on the single drive, and that works for me. Gonna build a new rig when win7 is released
     

Share This Page

Loading...