Unidentified Network and "No internet access" Please help!

Discussion in 'Windows 7 Networking' started by Jonny Cox, Aug 20, 2012.

  1. Jonny Cox

    Jonny Cox New Member

    Joined:
    Aug 20, 2012
    Messages:
    2
    Likes Received:
    0
    First time poster in a great deal of stress.

    Just bought a new laptop with windows 7 installed. Ive got it home and tried to connect it to my BT homehub and all im getting is "Unidentified Network" and "No internet access".
    When im in Network and sharing centre all i get is that connection breaks down after the Unidentified network section.

    Ive have been searching online for some 4 hours with numerous suggestions simply not working.

    I know this issue isnt with my modem or internet connection because im using it on my existing laptop as we speak. Please, please, please can anyone help?
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I was trying to track down BT, which I though meant BlueTooth, but I suppose it is a company.

    Anyway, Are you using the same workgroup as the other computers? Is the Router broadcasting the SID of the network?

    When you right click the Wireless icon in the tray, it does show your network with good signal strength? Have you checked the properties to make sure any security settings are correct?

    Do you have any type of MAC filtering set up on the router? Do you have enough IP addresses available to have one assigned to your system?

    Have you run the troubleshooter?

    Have you tried manually assigning yourself an IP address?
     
  3. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I have been running some tests to see if I can figure out exactly what causes loss of internet access.

    In the Advanced Sharing settings, having Network Discovery on, makes a difference.

    Whether you can ping your router or not depends on whether you have an valid IP address. If your IP address is not valid (169.xxx...) you should be able to set your IP address manually to be able to ping the router. If you do not set a DNS address, you will still not show internet access, but setting a DNS IP address will allow access. Some of these changes may take around a minute to take effect, so give it some time.

    If you can't get an IP address automatically, then you are not getting a connection to the router or you DHCP server, or that server is turned off. Why you may not be able to reach the router, could be a firewall or anti-virus.

    These comments are made assuming your Network adapter is installed and functioning properly and you have a strong wireless signal or a good wired connection. Also assumed is that no unusual circumstances are present, such as some required service on your system is disabled.
     
    #3 Saltgrass, Aug 21, 2012
    Last edited: Aug 21, 2012
  4. Shakil Ahmed

    Shakil Ahmed New Member

    Joined:
    Aug 22, 2012
    Messages:
    2
    Likes Received:
    0
    [COLOR=rgba(0, 0, 0, 0.792969)]I went through this menace during last two days couldnt find anything absolutely anything on internet to solve this problem for me. I called my internet service company helpline, the guy told me to connect the laptop through ethernet cable and allow him to take control, he thereafter just changed the name of network to one with less alphabets, password or phrase to a short pin of numeric ones, wpa-personal to wep and everything started working :)[/COLOR]
     

Share This Page

Loading...