Unidentified network - invalid IP configuration

#1
As per a lot of other people on here, I'm having issues with connecting my desktop PC to my BigPond router. It will connect via wireless (have an installed D-Link DWA525 wireless card) but will not connect via LAN.

I've changed the IP, DNS and Default gateways to the same as the other working PC's in the house, but still no luck. The mobo uses Realtek GBE Family PCI-E controllers, but for some reason it won't move off 10Mbps (even when I try to tell it to change this).

I have tried new drivers, and have tried uninstalling drivers and letting windows install its own. None have worked. I've disabled V6, didn't work.

My IPCONFIG ALL shows up the following:

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\CJHBeast>IPCONFIG/ALL

Windows IP Configuration

Host Name . . . . . . . . . . . . : CJHBeast-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : BigPond

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
Physical Address. . . . . . . . . : 1C-6F-65-3D-7A-18
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::9524:a51e:e2af:166e%14(Preferred)
IPv4 Address. . . . . . . . . . . : 10.0.0.5(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 10.0.0.138
DHCPv6 IAID . . . . . . . . . . . : 421293925
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-82-40-63-1C-6F-65-3D-2C-37

DNS Servers . . . . . . . . . . . : 10.0.0.138
NetBIOS over Tcpip. . . . . . . . : Enabled

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . : BigPond
Description . . . . . . . . . . . : D-Link DWA-525 Wireless N 150 Desktop Ada
pter
Physical Address. . . . . . . . . : 1C-AF-F7-68-68-43
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::41b:81e0:e1d8:bb33%12(Preferred)
IPv4 Address. . . . . . . . . . . : 10.0.0.10(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Wednesday, 01 December, 2010 7:05:54 AM
Lease Expires . . . . . . . . . . : Thursday, 02 December, 2010 7:06:52 AM
Default Gateway . . . . . . . . . : 10.0.0.138
DHCP Server . . . . . . . . . . . : 10.0.0.138
DHCPv6 IAID . . . . . . . . . . . : 203206647
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-82-40-63-1C-6F-65-3D-2C-37

DNS Servers . . . . . . . . . . . : 10.0.0.138
NetBIOS over Tcpip. . . . . . . . : Enabled

Here is the IPCONFIG/ALL from this laptop when connected to the same LAN cable:

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\Chris>IPCONFIG/ALL

Windows IP Configuration

Host Name . . . . . . . . . . . . : Chris-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Mixed
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : BigPond

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . : BigPond
Description . . . . . . . . . . . : Intel(R) PRO/1000 PL Network Connection
Physical Address. . . . . . . . . : 00-15-B7-A8-D5-67
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::fdf0:d04:197c:465a%12(Preferred)
IPv4 Address. . . . . . . . . . . : 10.0.0.17(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Wednesday, 1 December 2010 7:44:39 AM
Lease Expires . . . . . . . . . . : Thursday, 2 December 2010 7:44:39 AM
Default Gateway . . . . . . . . . : 10.0.0.138
DHCP Server . . . . . . . . . . . : 10.0.0.138
DHCPv6 IAID . . . . . . . . . . . : 268441015
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-13-2E-14-B7-00-15-B7-A8-D5-67

DNS Servers . . . . . . . . . . . : 10.0.0.138
NetBIOS over Tcpip. . . . . . . . : Enabled

I have no idea why I can't get it work. Any suggestions would be greatly appreciated.
 


Trouble

Noob Whisperer
#2
According to the IP information that you have posted, it looks like you are connected. Please disable the wireless adapter just to avoid potential conflicts, open the network and sharing center and make sure your network is properly defined and run the network trouble shooter and then see what you can ping.
First ping the local address 10.0.0.5
then your laptop 10.0.0.17
Then the inside edge of your router 10.0.0.138
Then google 64.233.169.99
Then google FQDN www.google.com
keep us posted on the results
 


#3
Tried pinging earlier. Can ping myself, and thats it. Can't ping the router, can't ping my laptop, can't ping google.



According to the IP information that you have posted, it looks like you are connected. Please disable the wireless adapter just to avoid potential conflicts, open the network and sharing center and make sure your network is properly defined and run the network trouble shooter and then see what you can ping.
First ping the local address 10.0.0.5
then your laptop 10.0.0.17
Then the inside edge of your router 10.0.0.138
Then google 64.233.169.99
Then google FQDN www.google.com
keep us posted on the results
 


#4
Install this driver as it the absolute latest and best, to make sure driver is not an issue:

RTL8111

Uninstall any 3rd party firewall apps if present, to test.

In the router settings, make sure that WAN ping is not blocked. Blocking it disallows hackers or others to ping your network to see if it is online, but can also give you the results that you are saying above, as well.

Also, you can set your router to use the fastest dns server that the app in my attachment finds. In most cases, it is faster than even your own isp's dns, by a large and very noticable margin. This means extremely fast browsing.

If you do so, I recommend to disable the DNS Client service.
 


Attachments

Last edited:
#5
I had this happen to a router, the wireless portion would work but not the LAN after much testing of cables and such and all other possibilities. It was determined that the LAN ports on the router had gone belly up. Replaced router everything then functioned properly.
 


#6
I managed to get it working yesterday afternoon by manually assigning an IP in the range of 192.168.1.1-10 and having the default gateway as 192.168.1.254.

It appears the router we have has two gateway IP's, which is weird in itself, but this is working for now, so I won't touch anything else. It also fixed my 10Mbps problem. As soon as I changed these settings and plugged the LAN cable back in, the network connected and gave me internet access.
 


Trouble

Noob Whisperer
#7
Wow, I didn't see that coming. Completely different subnet and gateway. Evidently something is present on your network that is handing out bad DHCP information for automatic IP addressing. Either the primary router (DHCP server) is somehow misconfigured or else there is a second device on the same segment behaving as a rogue DHCP server. Anyhow, very glad you have managed to resolve your problem and thanks for posting back and updating your thread. Hope to continue to see you around the forums.
Best Wishes
Randy
 


#8
Hey,

I've had a similiar problem on the HP Elitebook 8530w.

Whenever I turned my notebook to sleep or hibernate, it makes you lose LAN connectivity.
I've been messing around with basically any setting you can think of... except for the right one of course...

Anyway, for those who experience the "Invalid IP Configuration" after hibernating or sleeping. What seems to work (for me atleast) is turning off the laptop and take out the battery as well. With all these new features nowadays (turning on your pc remotely and stuff) it seems the adapter can't be fully disabled... otherwise disabling/enabling would have the same effect I guess...

The way to prevent it from happening again... Don't use sleep or hibernate

It's not a real solution. But for those, desperate to get their connection back up... it should do.

Last thing to say: I know this is an old/dead thread... but it pops up on Google as first hit.. it's still an existing problem in windows 7 (professional 64 bits is what I have) and I'd like to offer people this temporary solution.

Greetings,

Crucidal
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.