"Unidentified Network" problem, no solutions working

Discussion in 'Windows 7 Networking' started by Oski, Oct 31, 2009.

  1. Oski

    Oski New Member

    Oct 31, 2009
    Likes Received:
    "Unidentified Network" problem, no solutions working -- EDIT: Problem solved

    The "unidentified network" problem seems to be fairly widespread. In my case, I just upgraded my computer from 32-bit XP to 64-bit 7 via custom install of a Windows 7 Home Premium Upgrade Pack.

    Some basic details of my computer, Core 2 Duo E6600, Asus P5NSLI motherboard with onboard Marvell Yukon Gigabit ethernet adapter. I am running a wired connection to a Verizon Fios network, courtesy of an Actiontec MI424WR router (it's a wireless modem/router that has ethernet cable outlets, which I'm plugged into). I'm using a Cat6 ethernet cord, and the internet worked fine when I had XP.

    With 7, I haven't been able to access the internet since installing. I get the "Unidentified Network" that others have written about. There is often a yellow exclamation mark displayed between my computer and the unidentified network, and then a red X between the unidentified network and the internet. Troubleshooting the problem leads to a determination that I have a problem with the router, and that the Local Area Connection doesn't have a valid IP.

    I have pages of suggested, attempted, and failed solution efforts.

    Verizon tech support advised me to find out if there are any newer drivers for the network adapter. I found a driver dated about a week ago and tried that, but it changed nothing.

    A solution posted on these boards stated that I should uninstall a particular service, called "Bonjour," that is installed as part of programs such as iTunes, Office, or Adobe. I haven't installed anything since upgrading to 7. As far as I can tell, I don't have anything called Bonjour on my computer.

    I tried to tell my computer never to turn off the network adapter to save power. That didn't solve the problem.

    I tried to tell my PC to never sleep. That didn't solve the problem.

    I've reset the modem/router more times than I can count. Shut down the computer, unplugged the ethernet cord, disabled/re-enabled the network adapter, turned off ipv6, confirmed that my ipv4 obtains its IP address automatically...

    I tried booting in safe mode. That didn't solve the problem either.

    I'm willing to try anything else that might solve the problem. My computer skills are on the amateur side, but I can generally find my way around both the hardware and software with detailed instructions. Thanks for any feedback.

    EDIT: After days of troubleshooting, problem "solved." Older motherboards, such as my P5NSLI, apparently cannot handle 4 gigs of memory plus networking. That sounds unusual, but it's apparently true. I have 4 gigs of memory in my computer, and when I tried pulling out 2 gigs, the internet worked fine. Next I tried installing Windows 7 32 bit, which has the same memory limitations as my former XP 32-bit had. With the 4 gigs of memory installed, it recognizes 3 gigs, and works fine. I hope this is helpful to others having the same problem.
    #1 Oski, Oct 31, 2009
    Last edited: Nov 1, 2009

Share This Page