Unzipped files are playing hide and seek with me!

Discussion in 'Windows 7 Help and Support' started by hlung10, Aug 1, 2010.

  1. hlung10

    hlung10 New Member

    Joined:
    Aug 1, 2010
    Messages:
    4
    Likes Received:
    0
    Hey all,

    First off, let me state that I have looked elsewhere (on other windows forums and tech forums in general) for solutions to this problem, but to no avail. I have found problems similar to the one I'm experiencing, but no tech support guy or gal has got the answer figured out.

    This is my specific problem.

    I play lots of games.

    I downloaded and installed a vanilla version of a game called Mount and Blade on my new HP notebook running Windows 7. This game has worked on XP, and it works on Windows 7 as well.

    However, when I download a mod for this game (and most mods come in some zipped form), and then try to unzip the mod into the modules folder within the game folder, something funny happens.

    7-zip, which is what I use to unzip files because it's just damn convenient, performs the actions, it shows me an unzipping progress bar, and it takes about the right amount of time you'd expect it to, then it's done unzipping. When I go to the folder I specified it to unzip the mod into, there's nothing there.

    Now, I know that the files ARE there. How do I know this?

    1) When I try to unzip the mod into the same folder again, I get a notification telling me that the files in question are already there and I'll have to overwrite them.

    2) When I try to locate the specific folder I want to unzip the files to using the browser windows/7-zip conveniently pops up for me after right-clicking on the .rar file in question, I see that the mod DID in fact get unzipped to the correct folder, but there's a padlock icon next to it. NOT ONLY IS THERE A PADLOCK ICON NEXT TO THE FOLDER WHICH CONTAINS THE UNZIPPED FILES IN QUESTION, I cannot locate this file AT ALL by any conventional means. I can go to Computer/C:/Program Files/Mount and Blade/Modules, and there will be nothing there except the native vanilla game. ON TOP OF THAT, when I search for the file from the start menu, it says it doesn't exist either.

    BUT I KNOW IT'S THERE BECAUSE I NEED TO OVERWRITE IT IF I WANT TO UNZIP THE SAME FILE TO THE SAME LOCATION, and because it appears in the 7-zip browser, albeit with a padlock. Lastly, you know how a lot of games have a launcher, right? A launcher in which you can check/uncheck which expansions/mods you're playing the vanilla game with? Well, the mod THAT I HAVE UNZIPPED TO THE PROPER LOCATION doesn't appear in this list either.

    So, my question is, HOW ON EARTH DO I MAKE WINDOWS 7 acknowledge the existence of this file so that my game will play it?

    Any help would be appreciated, and I read something along the lines of "this has to do with security exceptions", but I honestly don't know how I can edit the security options of a file I can't even right-click to begin with.

    If it's not asking too much, I'd like to know:

    1) How can I locate this file and right-click on it, period (remember, I search for it and it doesn't show up, and it's totally playing hide-and-seek when I try to access it from Computer/C:/Program Files/Mount and Blade/Modules).

    2) How can I remove the padlock?

    Thank you in advance, even if just for reading this whole thread, and I sincerely hope you guys can help.

    a sad windows user

    PS: oh, I almost forgot to mention this - it's not because I'm an idiot and I'm unzipping the file to one location and looking for it in another location. Like I said I play lots of games and I've been doing this for years. I know how to unzip files to the proper locations. This have never happened to me before.

    PPS: really sorry, two more important details:

    1) I cannot just double-click on the .rar file I want to unzip - windows says it cannot open it so I have to rely on an unzipping program of some sort.

    2) I can right-click on the padlocked file in the browser 7-zip opens up for me (the extract-to selection window), but I can't change the security exceptions. This is what happens when I try. I right-click on the padlocked file, I click properties, I go to the security tab, and I click on edit. Now, in the window that I'm redirected, to, I see under Current Owner: "Unable to display current owner." When I try to change the current owner to either myself or the administrator (also myself, I guess) I get this message: "Unable to set new owner on <insert mod name here>. The system cannot find the file specified."
     
    #1 hlung10, Aug 1, 2010
    Last edited: Aug 1, 2010
  2. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,455
    Likes Received:
    268
    Sounds like it's trying to unzip to protected folder so it's doing it to a virtual version of the folder in your user area. Have a look in C:\Users\XXX\Local\VirtualStore (where XXX is your windows username), search around in there and see if it has been unzipped into there.
     
  3. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    This has to do with manifests and code signing of the program and it's modules. (Deep tech stuff)

    Basically anything Win7 puts into the Program Files folder has to pass scrutiny of the UAC, if it does not meet muster it is placed in a virtualized copy of the folder under your user account... As patcooke pointed out, c:\Users\<you>\local\VirtualStore. Win7 compatible software is expected to know now to find it there...

    One solution you could try is to run the program in XP compatibility mode....
    Also check the makers website and see if you can download patches or updates for Win7.
     
  4. hlung10

    hlung10 New Member

    Joined:
    Aug 1, 2010
    Messages:
    4
    Likes Received:
    0
    Thanks a lot for the quick responses! Fortunately, I solved the problem by just unzipping the mod in question to the desktop. The unpacked files do appear. I have no idea why, but it works!

    Han
     
  5. Mandorin

    Mandorin New Member

    Joined:
    Sep 4, 2010
    Messages:
    4
    Likes Received:
    0
    What I want to know is how to disable this annoying option. Every time I try to download something for one of my games, it gets sent to the wrong end of Rodinia, and I have to go fetch it.
     
  6. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,455
    Likes Received:
    268
    Are you saying the download goes to the wrong place or the unzipping sends it to the wrong place?
     
  7. Mandorin

    Mandorin New Member

    Joined:
    Sep 4, 2010
    Messages:
    4
    Likes Received:
    0
    Unzipping tends to send things to the virtual store, which I find inconvenient.
     
  8. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,455
    Likes Received:
    268
    You just need to configure your unzip software (whichever one it is you're using) to set the default drive and folder for unzipping.
     
    Elmer and (deleted member) like this.
  9. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    I'm gonna agree with patcooke. I always set unzipping programs (7zip, WinRAR) to have the Unzip here or Unzip (to named) folder in the same folder as the zip is. At least you can find it straight away!!
     

Share This Page

Loading...