USB Drivers Need Help

Discussion in 'Windows Vista Help and Support' started by licid, Apr 9, 2008.

  1. licid

    licid Guest

    My USB mouse & keyboard was working on and off. This happens regularly on my Windows Vista. So I decided to delete my USB Hub drivers and reinstall.

    However not thinking, after deleting those drivers, of course my mouse and keyboard stopped working.

    Now when I turn on my computer, neither my mouse or keyboard works. However they do work in the BIOS, and I've went into safe mode, did not work there, went to last known good configuration, did not work there.

    Does anyone have an idea what I can do?
     
  2. kjanx

    kjanx Guest

    you'd best get a ps2 keyboard and mouse from a friend, boot with those and check the usb ports.
    in the bios, in cmos, check the halt on all errors. change to none.
    you should be able to boot to windows with the usb stuff, and windows will auto load those usb ports
     
  3. superbill

    superbill New Member

    Joined:
    Feb 6, 2008
    Messages:
    774
    Likes Received:
    1
    Hi licid


    Try connecting another mouse and keyboard while Vista is running. It may
    force Vista to install drivers for them.

    Incidently have you installed vista sp1? If not try doing it when you get the mouse & keyboard working. It may make a difference!!!!!
     
  4. 03hdfatboy

    03hdfatboy Banned

    Joined:
    Feb 8, 2008
    Messages:
    1,416
    Likes Received:
    2

    What he said
     

Share This Page

Loading...