USB external disk not showing? Try this.

After searching around for a couple of weeks only to get more frustrated, I found a solution that worked for me last night. I do see there are many threads about this, but hope you can handle one more.

Funny thing was that in Safe Mode my external disk showed up and I could even go into it like normal.
It was also visible in Disk Management - but I could not open the drive when running in normal mode. It did show up, but the total disk space and free space was not available. When I tried to open it, it just popped up a "warning"
saying "F: Not available".

What I have tried before my solution worked;
- different fixes from both producer (Western Digital) and Microsoft
- updating USB drivers and lots of other drivers "that should take care of it"
- assigning a letter to the disk
- etc

In the end I just did a fresh install to get a new and fresh start and go back to the beginning.
(Note: maybe not be mandatory for you unless you have installed real crappy USB drivers and dont know how to get rid of them).

My disk is Western Digital Extreme Lighted Drive - USB 2/Firewire (Im using USB now) - 320GB.
My Mobo is Maximus II Formula, socket 775 - BIOS 2202

My fix:
- Go to BIOS
- Advanced
- USB Configuration
- USB Mass Storage Device Configuration (see if you can find your disk there and)
- If so, Enter it and look for Emulation Type
- Set Emulation Type to "Forced HDD"
- Other options you might find there (just so you know you are on the right place); Auto, Floppy, Hard Disk, CDROM
- Save BIOS and Restart computer

If you have another type of BIOS try to find something similar like the ones above. It might be found under other tabs than Advanced.

Sadly, I can not guarantee this will work for you, but I really hope so `cause this was getting on my nerves! :redface:

Ps! You do not need to download any fixes at all before doing this. Just install updates after Windows 7 is installed and then restart and Enter BIOS.

Good Luck!


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.